[RELEASE] NST Manager v5.0

thermostat
smartapp_hvac
dth_hvac
cameras
nest

#2979

Where do I go to set that just to make sure I am doing it right.


#2980

After you do that, you can always verify it in the IDE by going to Locations and then selecting the name of your location. You will see your information populated here:


#2981

Thanks so much that fixed it and now running thru setup.


#2982

Awesome! Glad to hear it. :slight_smile:


(Johnny2678) #2983

what would cause the app/vThermostat to stop checking in?

Noticed this after the house was warm. Only ECO automation I have setup is the contact watcher and all associated contacts were closed, yet the thermostat was still in ECO mode (automation is configuration for a 0 second delay to return to prior settings once contacts are closed). I should also mention I’m using the NST streaming service, if that matters. This happens periodically with no real pattern that I can discern.

Got yelled at by the wife. Any tips?


(Johnny2678) #2984

quick update - tried force closing the app, power cycling the hub, and re-saving app settings and nothing could wake up the vThermostat, which was stuck in ECO mode. Finally I tried changing the vThermostat temp and it woke up and resumed the previous schedule.

Glad the fix was easy, but having to manually restore the temperature after an ECO automation isn’t really automated. Will be monitoring more today to see if I can duplicate.

If I can reproduce, what can I provide to help troubleshoot?


(Wumasta) #2985

I’m getting an error when NST Manager attempts to set the mode on my thermostat to away:

NEST Manager API CMD Failed:
The (nestCMDRespone 0 (structures(away:away))) CMD sent to the API has failed.
Status Code:400
ErrorMsg: No write permission(s) for field(s):
away

I tried resetting the nest token and that didn’t work, what’s going on here?


(Giles) #2986

Hello, I have recently been trying to get my Nest Protect to work with Smartthings. I have followed the instructions for setting up a Nest product and copying the ID and secret into the IDE. I even have the Smartthings App loaded with Nest Manager in Automation. The Nest Protect shows up as a product and displays battery and status like it should. The issue I am having is that I still have the “Houston, we have a problem” error when I go to Marketplace - MyApps - NST Automations. I have deleted everything (twice now) and started over. Can someone please help with this issue. I plan to add a thermostat very soon and would like to be able to add automations. Thank you for all of your hard work.


(Wumasta) #2987

Nevermind, I found the problem, I had the security settings on my token of away enabled for read v2 when it should have been read/write v2.


#2988

You aren’t supposed to install NST Automations from the Marketplace. Automations gets installed as part of NST Manager and the Automations are inside of there when you open it up. :slight_smile:


(Giles) #2989

Hello. Thank you for your quick reply. I did not install NST Automations from the Marketplace. I installed it in the IDE and then it just shows up in the marketplace. Should I just remove it from my marketplace?

I do see now that I can get to automations in side of NST manager. Thank you for clearing that up


#2990

It shows in Marketplace because the code is Published in IDE. Any SmartApp code you Publish for me will show up in the Marketplace to be installed.

Once you have installed NST Manager from Marketplace, always open it up from Automation/SmartApps moving forward :slight_smile:


#2991

You will need to detail your exact setup in NST Manager.

For example, you can setup the Mode Automation to automatically set your Thermostat to ECO Mode when Away. If the problem is here and the Thermostat is not coming out of ECO when Neat gets set back to Home then you will have to track all that down on the he exact order that it is happening with specific details and then also live logging from IDE.

You have Thermostat Automations where you can change the HVAC Mode to ECO. If you do something with this, you have to have an automation that sets it back to another HVAC Mode. (You can’t adjust setpoints while ECO mode is on - That’s a Nest feature). I’m guessing that this the area you are having issues with.

You just have to troubleshoot and provide the exact steps you did to reproduce and also exactly how you have setup any / all Automations/Schedules and which Automations (Mode or Thermostat).


(Johnny2678) #2992

Sorry @wb70, here’s some more info:

The thermostat entered eco mode through the contact watcher automation. I have it set to go into eco when a contact is open for 2 minutes and to return immediately (0 mins) after the contact is closed. Only, it didn’t return from ECO when the contact was closed.

I think I manually pulled the thermostats out of eco (from the Nest Hardware). Even then, the virtual Thermostat still showed ECO. When I changed one of the temps (cool, I think) on the vThermostat, then it resumed the current NST manager schedule.

It’s hard to capture logs when this occurs because you never know when it’s going to happen, but I’ll try to reproduce today.


#2993

In your automation, do you have “Mirror Changes to these Thermostats” enabled for the virtual? Is that how the virtual thermostat is being set to ECO?

So for the Main thermostat, this is the one being set to ECO Mode when the Contact is Open?

Maybe turn off disabling the Mirror to the virtual thermostat, and instead with another Automation, do the same thing that you are doing with the Main thermostat for the virtual. Two Automations doing the same thing on Contact open but for a different tstat.

Another possibility is that things simply got out of whack because you manually took the thermostat out of ECO Mode from Nest directly and the polling from NST Manager had not taken place yet, leaving the vstat in ECO Mode. This is what I would test first. This is most likely what caused the issue and needed more time for the changes to reflect back in NST Manager/ST.


(Johnny2678) #2994

I have 2 Nest Thermostats on the wall. Each has its own virtual thermostat.

For each hardware thermostat, I have a NST automation setup with presense sensor/time-based schedules. Each hardware thermostat has different NST manager schedules so I do not mirror automation to the other hardware thermostats, i set them separately.

I never even thought of mirroring NST automations to the virtual thermostats, or setting NST Automations on the vThermostats directly. I guess I assumed that the Automations did that already - might be my first mistake.

Is that recommended?

I let it go almost an hour before figuring out how to get it “unstuck”. Plus, I’m running the streaming node.js service so I don’t think polling was the issue - could be wrong.


#2995

Hehe. Ok that’s not a polling issue. Disregard that then.

So ya, reversing the thought process on how I thought you had things setup, then actually enabling the Mirror to each vStat that corresponds to each of their Main thermostats should automatically put the vStat into Eco and pull it out of ECO when the contact goes back to Closed. Test that and see if your vstats go in and out of ECO with mirroring turned on.

There are many ways to skin a cat and one way over another all depends on your use cases and complexity. Some people use the Automations within, some use webCoRE and others use Nest Schedules directly from Nest itself. No wrong way to do it if it is reliable and meets all the requirements. :slight_smile:


(Johnny2678) #2996

Doesn’t look like this works :wink:

I had tried to do the ECO Automations myself in WebCore but couldn’t figure out the Eco part. Then I read a few posts back about using the [mode]btn() commands - I might try again with that.


#2997

I have never used the mirroring functions so it was just a suggestion. From the screenshot though it looks like there is a conflict. Mirroring main against virtual and then virtual against main, cancelling each other out.

Ya so for webCoRE and your use case with ECO Mode, all the —btn— commands can be used for your use case. You saw that during that testing and those posts that you can’t mix and match “Thermostat Mode” with those btn commands. The thermostat mode doesn’t contain ECO so that why you have to use the other set of commands. I’m sure @flyize might be able to share some tips with you on this as that’s who that whole conversation and testing session was with. To me this gives you a more direct approach with Nest and potentially less issues when the ST environment has issues or goes down and tries to recover from a problem. :slight_smile:

EDIT: I just quickly went and tested your error message. On one automation I attempted to add my vStat as the mirror to the real tstat and those two errors immediately populate. So not you. I will research this a little more. It may be because the automation also includes creation of the vStat which is a direct correlation of the main and you can only mirror to another Main (real) thermostat.


(Johnny2678) #2998

weird, I only have 2 automations setup, one on each physical thermostat.

Oh well. I’ve got a couple of things to try. Thanks for the help - always good to talk/type it out with a fellow enthusiast :beers: