SmartThings Community

[RELEASE] Neo Coolcam Power Plug

dth_lighting
dth_powermeter
dth_pocketsocket
dth_outlet

(Kevin) #21

It shows it as NAS-WR01ZE which is a valid model, although an older model, but the manual on z-wave alliance for that model is still the same or almost the same as the new model.

Does your device have Neo Coolcam stamped on it?


#22

It does(neo coolcam) stamped. By the way, even knowing the seller says 01, this model seems to be newer and the secure inclusion is a good evidence.


(Kevin) #23

You’re probably right, it’s just odd that they had me write this handler for them 2 months ago and they didn’t send me the latest version or even mention that there was going to be a new version with completely different configuration parameters…

Without a manual that defines the new config parameters I won’t be able to modify the handler so that it works with your model.


#24

Yeah… totally agree. Im trying here to figure out the new parameter numbering by try and fail method.

Tried also to find a manual in their website but did not find anything. Weird.

UPDATE: I give up. There are effectively new parameters…not just shuffling. Lets wait for official info.


(Phil) #25

Hey all,
I have recently brought one of these from a seller on Amazon. And have used the DTH created, which appears to work, however I have the same issues as Wgentine, in that I get sync issues.

I am going to have a look today, although have never edited a DTH before, but have attached the manual sent from the supplier on pdf. Perhaps this will help someone work out the differences faster…

Fyi I have the EU version (incase that makes a difference).

Cheers


#26

Your manual is the same as mine and doesn’t correspond to the actual firmware coming with these new devices.

Very typical chinese manufacture behavior.

We have to wait for them to pronounce.


#27

Facing the same issue. Everything works just fine on some older plugs that I have but the new ones that arrived today I cannot turn off the LED. Let me know if I can help in some way.


(Kevin) #28

Is it the EU or US version? Please post the raw description.

The manufacturer is still on holiday so it will most likely be a couple of weeks until I can find out what’s going on with these new devices.


(Phil) #29

cheers for looking into it for us.
It’s the UK version, so EU.
The raw description is:
zw:Ls type:1001 mfr:0258 prod:0200 model:1027 ver:2.32 zwv:6.02 lib:03 cc:5E,98,9F,55,6C sec:73,86,85,8E,59,72,5A,25,27,32,71,70 role:05 ff:8700 ui:8700


(Phil) #30

While we await the official documents I have used the DTH tweaker to test some of the parameters my findings are :
There are 10 parameters that I can see
Param 2 turns the switch action on / off
Param 3 turns the led on and off
Param 8 is the max ampage (overload)
Param 10 is the alert amps… I think - as it seems to cap out at Param 8 minus 1

Some of the other values and ranges
Param 1 : 0 or 1 only
Param 2 : 0 or 1 only
Param 3 : 0 or 1 only
Param 4 : 0 or 1 only
Param 5 : 1 to 30001 (size 2)
Param 6 : 0 or 1
Param 7 : 51 to 30000 (size 2)
Param 8 : 1 to 16
Param 9 : 1 to 1599
Param 10 : 1 to value of Param 8

Hopefully this helps in some way…


(Kevin) #31

The same number of parameters, but every one of them is different which is really frustrating. This is probably a change in the latest version of the EU model only which would explain why they didn’t send me the latest version.

I’m hoping this won’t be an issue with all their products…


(Phil) #32

The seller on Amazon has said he will get the new manual / parameters when the Chinese manufacturers are back in from the new year, as soon as I get it I will post it here, however you may have it before me :slight_smile:


#33

Same issues here, got 2 new plugs which seem to be the new model.
Updated to v.1.1 of the device handler and they pair in secure mode, then I got some readings but I’m also getting negative kWh readings. Looking forward for the updated handler that fixes the issue.


(Kevin) #34

Is your device EU or US?

I believe Neo will be back from Chinese New Year tonight so I hope to get answers within the next few days.


#35

I have the EU model.
I’m running MQTT smartapp on the side, which logs all requests to database, I have a custom webpage that displays data from my sensors. I can see all the records sent from the plug for the kWh usage and
sometimes the report seems valid, then sometimes this strange minus values is reported.
See example below …

topic message timestamp
Beer Fridge/energy -21474835.13 2019-02-09 13:33:46
Beer Fridge/energy -21474835.11 2019-02-09 13:43:47
Beer Fridge/energy 1.39 2019-02-09 13:48:46
Beer Fridge/energy 1.41 2019-02-09 13:58:47
Beer Fridge/energy -21474835.05 2019-02-09 14:03:46
Beer Fridge/energy -21474835.03 2019-02-09 14:08:46
Beer Fridge/energy 1.47 2019-02-09 14:18:46
Beer Fridge/energy 1.49 2019-02-09 14:23:46
Beer Fridge/energy 1.51 2019-02-09 16:27:11
Beer Fridge/energy 1.53 2019-02-09 16:32:11
Beer Fridge/energy 1.55 2019-02-09 16:37:11
Beer Fridge/energy 1.57 2019-02-09 16:47:10
Beer Fridge/energy 1.59 2019-02-09 16:52:10
Beer Fridge/energy 1.61 2019-02-09 16:57:10
Beer Fridge/energy 1.63 2019-02-09 17:02:10
Beer Fridge/energy 1.65 2019-02-09 17:12:10
Beer Fridge/energy 1.67 2019-02-09 17:17:10
Beer Fridge/energy 1.69 2019-02-09 17:27:10
Beer Fridge/energy 1.71 2019-02-09 17:32:10
Beer Fridge/energy 1.73 2019-02-09 17:37:10
Beer Fridge/energy 1.74 2019-02-09 17:40:18
Beer Fridge/energy 1.76 2019-02-09 18:00:22
Beer Fridge/energy 1.78 2019-02-09 18:05:22
Beer Fridge/energy 1.8 2019-02-09 18:10:23
Beer Fridge/energy -21474834.66 2019-02-09 18:20:22
Beer Fridge/energy -21474834.64 2019-02-09 18:25:22
Beer Fridge/energy -21474834.62 2019-02-09 18:30:22
Beer Fridge/energy -21474834.6 2019-02-09 18:40:23
Beer Fridge/energy -21474834.58 2019-02-09 18:45:23
Beer Fridge/energy -21474834.57 2019-02-09 18:52:29


(Kevin) #36

@WGentine mentioned that problem earlier so I included it in the email I sent my Neo contact.

A firmware update that fixes the energy reporting won’t help since ST doesn’t support firmware updates so I’ll make the handler ignore weird values. Hopefully they’ll be able to send me the new manual so I can fix the configuration parameters.

Unfortunately since it’s the EU model having problems I won’t be able to test the changes myself so I’ll most likely PM it to you and the others so you can test it for me.


#37

OK, thank you.
I will be happy to test the updated device handler.

Cheers


#38

This energy reading seems to be something more complicated. I have another device here, a Qubino Flush 2 Relays behaving exactly in the same manner. Not sure what’s going on.


(Castro) #39

Thanks for your interest in this situation. :blush:
I’ll be waiting for news from you, @krlaframboise

Cheers


#40

Did you guys have any luck contacting neosz? They simply do not respond me!