[RELEASE] Neo Coolcam Power Plug

@krlaframboise, first of all, thank you for making the effort.

All basic features seems to be working… amperage, voltage, switch on, off, etc. However, the configuration parameters are not coming through. There are always 7 or 8 pending changes and sync or re-saving parameters won’t make it. I trying to change the LED behaviour and had no effect (as example).

d44b8cae-9f60-44dd-ba7d-bf2b616186db 07:38:31: debug voltage is 234.14 V

d44b8cae-9f60-44dd-ba7d-bf2b616186db 07:35:18: debug Physical Button Enabled(#10) = 1

d44b8cae-9f60-44dd-ba7d-bf2b616186db 07:35:17: debug Swith Off Timer Period(#9) = 150

d44b8cae-9f60-44dd-ba7d-bf2b616186db 07:35:16: debug Switch Off Timer Enabled(#8) = 16

d44b8cae-9f60-44dd-ba7d-bf2b616186db 07:35:15: debug Remember Switch State After Power Failure(#7) = 300

d44b8cae-9f60-44dd-ba7d-bf2b616186db 07:35:14: debug Power Reporting Threshold(#6) = 1

d44b8cae-9f60-44dd-ba7d-bf2b616186db 07:35:13: debug LED Enabled(#5) = 120

d44b8cae-9f60-44dd-ba7d-bf2b616186db 07:35:13: debug Current Overload Alarm Threshold(#4) = 0

d44b8cae-9f60-44dd-ba7d-bf2b616186db 07:35:11: debug Current Overload Protection Threshold(#3) = 1

d44b8cae-9f60-44dd-ba7d-bf2b616186db 07:35:10: debug Meter Reporting Interval(#2) = 1

d44b8cae-9f60-44dd-ba7d-bf2b616186db 07:35:10: debug Meter Reporting Interval(#2) = 1

d44b8cae-9f60-44dd-ba7d-bf2b616186db 07:35:10: debug Meter Reports Enabled(#1) = 1

d44b8cae-9f60-44dd-ba7d-bf2b616186db 07:35:08: debug Changing Physical Button Enabled(#10) from 1 to 1

d44b8cae-9f60-44dd-ba7d-bf2b616186db 07:35:08: debug Changing Swith Off Timer Period(#9) from 150 to 150

d44b8cae-9f60-44dd-ba7d-bf2b616186db 07:35:08: debug Changing Switch Off Timer Enabled(#8) from 16 to 0

d44b8cae-9f60-44dd-ba7d-bf2b616186db 07:35:08: debug Changing Remember Switch State After Power Failure(#7) from 300 to 1

d44b8cae-9f60-44dd-ba7d-bf2b616186db 07:35:08: debug Changing Power Reporting Threshold(#6) from 1 to 5

d44b8cae-9f60-44dd-ba7d-bf2b616186db 07:35:08: debug Changing LED Enabled(#5) from 120 to 0

d44b8cae-9f60-44dd-ba7d-bf2b616186db 07:35:08: debug Changing Current Overload Alarm Threshold(#4) from 0 to 12

d44b8cae-9f60-44dd-ba7d-bf2b616186db 07:35:08: debug Changing Current Overload Protection Threshold(#3) from 1 to 13

d44b8cae-9f60-44dd-ba7d-bf2b616186db 07:35:08: debug Changing Meter Reporting Interval(#2) from 1 to 300

d44b8cae-9f60-44dd-ba7d-bf2b616186db 07:35:07: debug Changing Meter Reports Enabled(#1) from 1 to 1

d44b8cae-9f60-44dd-ba7d-bf2b616186db 07:34:46: debug configure()…

I decided to exclude and include the device again and got the following error so far:

Unhandled zwaveEvent: NotificationReport(eventParametersLength: 1, eventParameter: [8], zensorNetSourceNodeId: 0, v1AlarmType: 0, reserved61: 0, notificationStatus: 255, sequence: false, event: 0, notificationType: 8, v1AlarmLevel: 0)

Another weird thing is energy consumption seems to be working fine until it gets a response like -129382874435.

This device has a lot of configuration parameters and SmartThings often drops some of them. When you tap sync it resends all the configuration parameters to the device which may result in the same ones getting dropped. When you go into the settings and tap save it only sends the configuration parameters that are out of sync so I recommend attempting to save again if it shows pending changes instead of tapping sync.

That’s not an error it’s just a notification that I’m not doing anything with. I believe notification type 8 means that the device was plugged in.

That appears to be an issue with the device and not the handler, but I could make a change that ignores the value if it’s negative…

Thanks for clarifying.

Saving the changes again or effectively changing something don’t seem to change anything. The pending items remains the same and I tried to change the LED behaviors (turn off) but did not work.

Agree with the negative value being a device issue. I have similar issue with Qubino devices. If you could implement this bypass, I appreciate too.

The logging results after tapping save will allow me to identify all the configuration parameters that aren’t syncing. It’s possible Neo either changed the supported values, size, or number for those configuration parameters.

How many pending changes is it showing?

I won’t be able to get any information from Neo until the middle of February because they’re closed for Chinese New Year so any chance you can post photos of the config section of the manual. (don’t bother if pending changes is 10 because that means all of them are out of sync)

This is the logging results after tapping save (there are always 7 pending items):

Here are the pics taken from the manual:

Either the manual isn’t in English or the writing is way too small to read…

Can you post the raw description?

Based on the values being reported by the device they must have changed configuration parameter numbers because the LED setting and remember switch state setting should only support values 0-3 and yours are currently set to 120 and 300.

Indeed. The device looks just like the same but the raw description is different:

zw:Ls type:1001 mfr:0258 prod:0200 model:1027 ver:2.32 zwv:6.02 lib:03 cc:5E,98,9F,55,6C sec:73,86,85,8E,59,72,5A,25,27,32,71,70 role:05 ff:8700 ui:8700

Please, check my last post again, edited with higher resolution. My bad.

That’s weird, it’s a completely different product # and model #, but the manual matches mine.

Your manual confirms that it shouldn’t be possible to set param #5 to 120 or param #7 to 300, but that’s what they’re currently set to.

I’m starting to think you might have a defective device that somehow has the wrong firmware. What’s the model # shown on the box?

In theory, if you try changing each config parameter to 0/disabled you may stumble upon one that disables the LED, but other than that I’m out of ideas.

I’ll talk to Neo about it, but it will be a couple of weeks before they’re back.

yeah… I bought 2 of these… same behavior.

The box wont say the model but “Power Plug”.
The sticker says Y-V07-A04-201 (202944102). White EU Plug.

That model number’s not even close to any of the EU or US Neo product numbers so if you don’t mind me asking, where did you purchase them from?

From here:

It shows it as NAS-WR01ZE which is a valid model, although an older model, but the manual on z-wave alliance for that model is still the same or almost the same as the new model.

Does your device have Neo Coolcam stamped on it?

It does(neo coolcam) stamped. By the way, even knowing the seller says 01, this model seems to be newer and the secure inclusion is a good evidence.

You’re probably right, it’s just odd that they had me write this handler for them 2 months ago and they didn’t send me the latest version or even mention that there was going to be a new version with completely different configuration parameters…

Without a manual that defines the new config parameters I won’t be able to modify the handler so that it works with your model.

Yeah… totally agree. Im trying here to figure out the new parameter numbering by try and fail method.

Tried also to find a manual in their website but did not find anything. Weird.

UPDATE: I give up. There are effectively new parameters…not just shuffling. Lets wait for official info.

Hey all,
I have recently brought one of these from a seller on Amazon. And have used the DTH created, which appears to work, however I have the same issues as Wgentine, in that I get sync issues.

I am going to have a look today, although have never edited a DTH before, but have attached the manual sent from the supplier on pdf. Perhaps this will help someone work out the differences faster…

Fyi I have the EU version (incase that makes a difference).

Cheers

Your manual is the same as mine and doesn’t correspond to the actual firmware coming with these new devices.

Very typical chinese manufacture behavior.

We have to wait for them to pronounce.

© 2019 SmartThings, Inc. All Rights Reserved. Terms of Use | Privacy Policy

SmartThings; SmartApps®; Physical Graph; Hello, Home; and Hello, Smart Home are all trademarks of the SmartThings, Inc.