[RELEASE] Neo Coolcam Power Plug

With the latest version 1.2.4, I also have 1 pending change but when I click save there is nothing in the logs.
The old models work just fine as well, they stay synced.

I finally had some time to test and having same issue. 1 item pending sync.

I just PM’d you both the test version. I need someone to install it, open live logging, tap the Refresh tile and post the logging results

Logs

168176e3-e875-4a7f-acbd-9bcabc19f5fa 14:30:21: warn pending changes: 1

168176e3-e875-4a7f-acbd-9bcabc19f5fa 14:30:21: trace Param #2: 1 == 1

168176e3-e875-4a7f-acbd-9bcabc19f5fa 14:30:21: trace Param #5: 120 == 120

168176e3-e875-4a7f-acbd-9bcabc19f5fa 14:30:21: trace Param #4: 0 == 0

168176e3-e875-4a7f-acbd-9bcabc19f5fa 14:30:21: trace Param #1: 1 == 1

168176e3-e875-4a7f-acbd-9bcabc19f5fa 14:30:21: trace Param #9: 5 == 80

168176e3-e875-4a7f-acbd-9bcabc19f5fa 14:30:21: trace Param #3: 1 == 1

168176e3-e875-4a7f-acbd-9bcabc19f5fa 14:30:21: trace Param #10: 12 == 12

168176e3-e875-4a7f-acbd-9bcabc19f5fa 14:30:21: trace Param #8: 13 == 13

168176e3-e875-4a7f-acbd-9bcabc19f5fa 14:30:21: trace Param #7: 300 == 300

168176e3-e875-4a7f-acbd-9bcabc19f5fa 14:30:21: trace Param #6: 1 == 1

168176e3-e875-4a7f-acbd-9bcabc19f5fa 14:30:21: debug refresh()…

Cool, thank you.

In the settings, what is the power reporting threshold?

It is: 5% [DEFAULT]

When I changed from 5 to 50 I got:
168176e3-e875-4a7f-acbd-9bcabc19f5fa 14:49:33: trace Param #9: 50 == 800

168176e3-e875-4a7f-acbd-9bcabc19f5fa 14:49:22: debug Changing Power Reporting Threshold(#9) from 80 to 800

168176e3-e875-4a7f-acbd-9bcabc19f5fa 14:49:22: debug updated()…

That’s working as expected.

The old model supports values 1-100% the new model supports 0.01A - 16A (1-1600) and 50% of 1600 is 800.

It’s just the pending change calculation that has an issue, but I’ll post another test version shortly that will hopefully solve the problem.

Update: I finally found the problem so I’ll have the new version posted to GitHub shortly.

2 Likes

I just posted 1.2.5 which should solve the problem.

If you tap the Sync tile the pending changes should go to “Synced”.

Just tested and it is working. No pending changes.

Thank you!

Would you mind testing one more thing? Change all settings to their highest value (or lowest value if they’re already on their highest) and then Save. SmartThings often chokes when you send a lot of commands at once so it’s possible that there will still be pending changes afterwards, but if that happens go back into the settings and tap Save again.

Changed then to max values and everything synced from the first time. Then reverted the settings and it worked again.

I’m glad to hear it. I’m keeping my fingers crossed that they don’t release new models of all their devices with needless changes like they did for this one.

Thank you everyone for helping me test the handler. Writing a handler for a device you can’t test yourself can be extremely frustrating…

2 Likes

I have a motion sensor and water leak sensor on the way, so I will post if there are changes there.

Thank you for work and patience!

1 Like

I haven’t written a handler for their Leak Sensor yet, but the configuration parameters aren’t that useful and you’re probably better off using the built-in handler so that it executes locally.

I wrote a handler for their Motion Sensor which reports Motion, Light and Temperature.

Awesome work. Thank you @krlaframboise

Thank you @krlaframboise
Great work

Woke up in the morning and all my neo cool cam devices stopped responding… still no idea what’s going on. All other devices are fine.

Snap, my aeotec nano devices have also stopped.

I know that SmartThings are rolling out an hub update… but can’t see why that would stop devices…

SmartThings isn’t known for its reliability or stable updates…

Unplug the hub, remove the batteries, wait about a minute and then plug it back in. Not sure if that will help, but it can’t hurt.

© 2019 SmartThings, Inc. All Rights Reserved. Terms of Use | Privacy Policy

SmartThings; SmartApps®; Physical Graph; Hello, Home; and Hello, Smart Home are all trademarks of the SmartThings, Inc.