SmartThings Community

[RELEASE] Neo Coolcam / MCO Z-Wave Light Switch

dth_lighting
(Khaled Qari) #63

or just delete them through app? @hongtat

0 Likes

(Khaled Qari) #64

just figured I could just change the device type

should I change to NEO Coolcam Light Switch or NEO Coolcam Light Switch child?

0 Likes

(HONGTAT TAN) #65

You have to exclude/remove them and add back again.

0 Likes

#66

Would it be possible to install a 2 gang switch and only connect 1 light to it? or even 0 liights.
What i would like to do is install a 2gang switch and use the second button to scroll through different scenes, while the first button is just an on/off button. Would be nice if it could be used just as a z-wave switch.

Also did anyone buy one of the neo coolcam switches without the hideous logo on it?:slight_smile:

0 Likes

(HONGTAT TAN) #67

Yes. Don’t have to connect the L1/L2, if you don’t need to connect to lights.

For without logo, contact them.

1 Like

(Khaled Qari) #68

after some use of the switch, I realized that they have it configured that if I :
1- slightly touched any of the buttons it turns on/off after a short delay.
2- but if I kinda try to push harder it turns on/off instantly

since I know nothing about coding I need help please:
is there any way that these can be programmed so that I could use it when I slightly touch, it goes instantly or something

Thanks in advance

0 Likes

(Khaled Qari) #69

@hongtat Could you look at it please

0 Likes

(HONGTAT TAN) #70

@Khaled_Qari No. It is not possible. Try adjusting the cover and capacitive touch sensor - it may improve the sensitivity.

0 Likes

(Khaled Qari) #71

@hongtat the sensitivity is good. i have a few of them , they all react the same. i feel like it was made this way

2 types of touches. slight touch and kinda like pushing maybe the version i have i dunno. no one else has the same issue ?
thanlk anyways

0 Likes

(HONGTAT TAN) #72

Yes. Some batches/switches have the issue.

0 Likes

(Magnus Bergsson) #73

@hongtat, I have the updated dt’s installed but seeing some strange behavior and was hoping you could help. After synching a light switch I see an instant update in the app when turn the switch on and off, but when I press on or off in the app I am sometimes getting very long delay (maybe 30 seconds) until that command acts on the switch. So it looks like the communnications from the switch to the app is almost instant, but going from app to switch is sometimes very slow. Another strange thing is that occasionally going from app to switch works right away, but most of the time it does not.

I have bought 15 switches so i really want to understand what is causing this. Hope you can help or anyone else that has seen this and solved it.

0 Likes

(HONGTAT TAN) #74

I haven’t seen the delay, it is near instant (<1sec) for me.

Try

  • Check your network connection
  • Check other devices whether they have the same delay
  • Check the logs in the IDE
  • Get Google/Alexa to turn on/off the switch
0 Likes

(Magnus Bergsson) #75

Hi @hongtat

  1. Network connection is fast and stable. Have a fiber optic coming into my house and a 1GB connection.
  2. Other devices work instantly.
  3. Have been monitoring the logs and nothing there indicating any type of error. What I am seeing is that while other device commands show up in the logs right away, the commands for the Coolcam switch are showing up in the logs with a delay. But when I press the button on the switch itself I am seeing an instant update in the app. It’s just when go from app to switch I am seeing a delay, and it can be a long one.
  4. Alexa commands are also happening with a delay.

This is really causing me headaches and making the system sluggish and unsatisfying as you can imagine. So if you have any ideas of what could be causing this OR just ideas of how I can find out what could be the problem then you could make a very good friend in Iceland :smiley:

0 Likes

(Magnus Bergsson) #77

@hongtat, thought I give you, and everyone else, an update as it might help those that run into zwave latency issues.

I removed all zwave devices from ST, but I had about 40 synched. This included Coolcam switches, motion dectectors, water sensors, window sensors and power plugs. Again all from Coolcam, but running code from various people or using the built in zwave device drivers.

Then ran zwave network repair after I had cleaned out all zwave modules.

At the same time I cleaned out some IFTTT experiments and when I did that I was finally able to remove Rooms Manager, which I haven’t been able to remove until now.

With all that excess fat removed I started adding Coolcam switches using this handler and now everything is working perfectly. I get instant response from the switches both from the app and back from the switch.

As I add the other devices back onto ST I will be running extensive testing after each module in an attempt to find out what the problem is, and if I do find the problem I will update this post.

So my advice to everyone is to be careful when adding new things and test your system after you introduce a new device handler or hardware. Faulty zwave hardware can from what I have read overflood your hub creating a mess, and finding out what is causing the problem is almost impossible unless you test not just the device you installed, but also all the others.

Regards,

Magnus

3 Likes

(Luis) #78

I have 3 neo coolcam switches that serve the same lamp, so I do not need the 3 in the things panel, just one.
is there any possibility of doing this?
Only one is that is physically connected to the electrical installation, the other 2 only has the neutral on.

Thanks

0 Likes

(HONGTAT TAN) #79

Unfortunately, the app doesn’t provide a way to hide a “thing”.

You can prefix “–” to the thing name, so that it appears at the bottom of the things panel.

0 Likes

(Joseph Ong) #80

Hi all, i recently swop in a new neo coolcam single gang switch and i cant get it add to smartthings. I have over 10 such switch working in my hub, but however i try, i still cant get the new switch included. Can anyone help please. Thanks!

0 Likes

(Brian) #81

Hi guys!
I bought 4 pieces 1 gang switch to test.
My problem is with the switch is the sensitivity.
When i press slightly it responds with delay, but when i hit it hard (touch it firmly) it responds immediately.
Lots of times when i am in a hurry and unable to touch it with normal power, it responds with delay, and this is very annoying, especially if i want to put this switches to my new home.
I have other brands (sonoff and some chinese brand) to test, and both responds immediately only with a slightly touch (like a capacitive screen)

Can you help me guys and make a video to prove to the seller i have a bad batch…
Or all the switches like this?
Here is my video to show:

Thank you

0 Likes

(Khaled Qari) #82

Exactly!

that is what I have been explaining if you up a bit to read my posts

I am also not sure if this is an issue or they should work like this

0 Likes

(Ben Erkens ) #83

@gamcon

Hi Joseph, have you tried to reset it and then pair?

Hold the button for 10 seconds, the light will blink and the switch is “as new”.

Then try it to pair.

Is the distance between switch and hub not too far?

Do you have a switch with the correct zwave frequency (us/eu differ)?

Grtn Ben

0 Likes