[RELEASE] Neato (Connect) V1.2.6c (Botvac Connected Series)

I just installed this smart app to control my D7. First, I just wanted to state how great a job the developers did. Neato states that the only way to control a D7 and have No-Go lines enabled is through their app and you guys have overcome that.

I do have one question about how this smart app works with IFTTT integration.

  1. Obviously turning a neato on starts it on a cleaning mission. However, when you turn it off is that a stop command or a pause command?

  2. I’m trying to coordinate vacuuming with other actions in my smart home through IFTTT. What I want to know is when the vacuum has finished cleaning so I can trigger other actions in the home. If SmartThings tells IFTTT that the vacuum is off then is that a definitive notification that cleaning is complete? What happens if someone uses the neato app to pause the vacuum because, for example, they are talking on the phone? What happens if the vacuum gets stuck? Again, just trying to definitively know when the vacuum is finished cleaning and has returned to the dock.

Thanks in advance for the help

I don’t seem to be getting any response to my question so I’ll try phrasing this as a feature request for @Alyc100.

Right now the smart app acts like a switch and only exposes an on/off status. Is it possible to change it to represent a dimmer that would maintain the on/off status output but also include an analog output that could represent that status of the vacuum. For example, 100% might mean running, 0% docked/mission complete, 10% mission in progress but currently docked and recharging, etc. Then people could take other actions in their smart home based on the status of the vacuum.


I’m absolutely not a fan of this idea - I mean - I get what you’re after, but I’m not a fan of corrupting capabilities and attributes to represent something unrelated… Instead I’d suggest this (which is more in line with the way the platform is moving)

Considering this DTH is not a Zwave or Zigbee device and relies on Groovy and the Groovy IDE’s day’s are numbered - (within a year), most people aren’t to keen on putting much dev effort into this solution right now.

BUT - if someone wanted to - You should be able to implement the standard capabilities: Robot Cleaner Cleaning mode: SmartThings Developers | Documentation (samsung.com)
Robot Cleaner Movement:SmartThings Developers | Documentation (I just looked - it’s not in the DTH right now)

Implementing those ‘should’ provide attributes that are accessible in Automations as a trigger. Then you could use that to turn on a switch, set security mode, or trigger whatever off platform thing you want through IFTTT… Much cleaner than messing with the level attribute and adding something that shouldn’t be there.

You’re right @nathancu. If the driver implemented the robot cleaner capabilities it would certainly be a better direction. I was simply thinking in terms of an incremental improvement that wouldn’t impact current users who may be using the current “switch” implementation. Thanks

Hello. Has this / will this be updated to include the D8/D9/D10??
Ive been toying with a D7 for a while but the recently released their new ones.


EDIT: problem solved without making any changes to the smartapp
Everything has been perfect for over a year … for a couple of days my D5 no longer starts automatically in the morning when we leave the house, I don’t know if it’s a problem with the smartapp or simply my problem. I am asking here to understand if others have this problem. Thanks

I am trying to remove the smartapp, but apparently I can’t.

I tried in the app, in the IDE in the smartapp section, and also in the IDE in the Locations section.

Obviously I also removed any device and automation using it.

Any advice?

you have to remove all devices in use / created by a smartapp before you can delete it. Also, generally speaking, devices don’t like to be deleted until they don’t have any automations attached. What I usually do:

  • Remove the device from as many automations etc as possible. (is it used by Alexa, WebCoRE, etc?)
  • Login to the IDE using incognito mode (to eliminate the possibility of a few known token issues)
  • Then Attempt to delete the botvac(s) in the IDE, force delete if necessary, repeat until works or I’m tired of trying (I had one night where I got an error 500 every time I tried to delete until try 10 - and suddenly it worked - no clue why, possibly load, timing - just - don’t give up on the first failed attempt.)
  • Then attempt to remove the smartapp normally in the app, if that doesn’t work then in the ide under My Locations > Smartapps (Note the edit button not very conspicuous under the list of installed smartapps - you’ll need to hit that before you can delete anything.) Also IF YOU’RE HERE TO DELETE MANUALLY BE VERY CAREFUL You can break things. Double check before clicking a button.

If none of this works, you’ll probably need an assist from support.

1 Like

Hello, but does the automatic deactivation of smart monitors work for you while the neato is cleaning? I have tried and I notice that this does not work. I’d like to see if it’s just my problem. I just put the flag on the option. Need to do anything else? Thanks

I dont think that has worked properly since they stopped supporting the old SHM Diego… Groovy doesnt have ways to directly manipulate STHM and only operates against SHM which doesnt exist anymore. Basically because groovy only addtessed SHM and not STHM - when they pulled SHM out of the system this just stopped working.

Mine worked for a while after because of the way I had SHM and STHM tied together with webcore but if I remember correctly that stopped working too for me sometime late last year.

1 Like

Thank you, I had never used it in a year and a half of using SmartThings, I wanted to try it, but without this support, with a Neato running around the house Every day, it becomes impossibleEvery day, it becomes impossible :joy:

in the new app it is impossible to use a ìnew smart app how can I do?

In Android go to Automations tab, plus sign (upper right corner), add routine, discover (lower right corner), scroll down to Smart apps

1 Like

this smartapp work with the new app used for D8-D9 and D10? thank you

1 Like

Anyone using Neato D7 with the community smartapp? :thinking:

Everything worked fine with the D5, with the D7 zero just … You see it but then it doesn’t work :man_shrugging:t2::pensive:

@Diegocampy , yes I use it with my D7, no problem. When you say “You see it” do you mean in the SmartTthings app, but when you try to turn it on, nothing happens? On the tile in the app for your robot, does it say “READY TO CLEAN”? or any other status?

1 Like

Yes I see it in the smartapp, but it doesn’t work. I tried to delete everything from the smartapp but from IDE if I try to delete the old Neato D5 gives me this error:

“Hibernate operation: could not update: [physicalgraph.app.InstalledSmartAppData#0bccc248-5b2f-466d-bf07-b0b1fde9a7ce]; uncategorized SQLException for SQL [update installed_smart_app_data set version=?, data_type=?, encrypted=?, installed_smart_app_id=?, name=?, value_string=? where id=? and version=?]; SQL state [25S03]; error code [0]; (conn=11172542) Communications link failure with primary host eu01euwest1-datamgmt.cluster-co0mxsvdfmrv.eu-west-1.rds.amazonaws.com:3310. Connection timed out; nested exception is java.sql.SQLException: (conn=11172542) Communications link failure with primary host eu01euwest1-datamgmt.cluster-co0mxsvdfmrv.eu-west-1.rds.amazonaws.com:3310. Connection timed out”

I think it’s a problem with the smartapp from the moment. He you try to add a second device.
I can no longer delete the smartapp to try everything again from the beginning.

@Diegocampy - I’m not an expert with how the IDE and SmartApps work - but this looks like maybe a temporary issue with your account or there’s still some dependency that is now allowing the SmartApp to be removed (is your D5 in any automation or WebCore rules?) - I see you’re trying to delete it in the IDE, normally when it isn’t allowed it’s because of a rule/piston or something else that the device is still assigned to. Although this long error message looks like it’s not happy about the SmartApp for some reason.

You should see this on the D5’s IDE device page at the bottom under “In use By” and the various apps/rules listed on the right.

Your smartapp looks completely hosed there Diego. Doubtful anything will work right with it until you get it fixed. Those errors are basically saying SmartThings itself cant connect to and read the configuration database about the smartapp. Thaslts some deep core stuff and nothing youbcan fix yourself.

If whatever is causing that is temporary hey ir may go away. But… I doubt SmartThings is chasing and fixing operations issues on the Groovy side of things as a priority. So im pretty sure you’ll need to open a ticket to get that looked at.

Thank you for your interest @tmielonen and @nathancu. Now I managed to delete the old D5 by deleting all the Neato connected to the smartapp through the account. Then from the smartapp I reselected the new Neato D7 and now I see it,

But always with status check In progress.
If I press play, however, it works, but I do not see it from The SmartThings App. Should I try maybe to delete everything and redo everything

1 Like