SmartThings Community

[RELEASE] Neato (Connect) V1.2.3 (Botvac Connected Series)

smartapp_appliances
dth_appliances
project_small_appl

(Alex Lee) #610

The Neato Developer API has not enabled the new zone cleaning functionality for D7 yet so no chance at this moment in time.


(ilker Aktuna) #611

@Alyc100 , ok but how does it act for now ? If I make a zone cleaning from original app, then will that reset the timer on the Smartthings device ?


(Jim Radzicki) #612

Could use a little help. I tried updating my Neato (connect) (been using it well since Sept 18 and even donated $) Recently I am getting Robot Serial and/or secret is not correct in the App. However the maps are updating when the robot finishes
I figured. no trouble, I will just start over tried to delete the Device and I get:

Object of class [physicalgraph.device.Device] with identifier [0f5a2dab-aab2-4085-8a49-58bdb3300bf0]: optimistic locking failed; nested exception is org.hibernate.StaleObjectStateException: Row was updated or deleted by another transaction (or unsaved-value mapping was incorrect): [physicalgraph.device.Device#0f5a2dab-aab2-4085-8a49-58bdb3300bf0]

I cannot delete the smart app or handler because I cannot delete the device.

I am suspect the problem started when I reset my robot wifi connection and perhaps orphaned a device id.

Any help appreciated.


#613

From what others have said in the past they had to go into some of their other smart apps like IFTTT, Alexa, … and remove the Neato from those before they could remove the device.


(Jim Radzicki) #614

Thanks… Indeed… I found MS Cortana integration, although not being used, was holding it… Once I was able to clear the device, I republished with the updates and everything worked well… oddly, through the process the new Smartthings apps showed 4 or 5 robots (classic only showed 1). I deleted them all and refreshed… It took a couple of minutes for all the changes to sync, but the new code is working well now… Thanks again.


(Roberto Ostinelli) #615

Hello @Alyc100,
You may find now the updated documentation at the address:
https://developers.neatorobotics.com/api/robot-remote-protocol/housecleaning

Thank you for your support!

Best,
r.


(Alex Lee) #616

Thanks @roberto. I shall take a look. Appreciate the community support from Neato as always.


(ilker Aktuna) #617

@roberto , you seem to be someone from Neato. Maybe close to the development.
Is your team aware that the Alexa skill needs updating ?


#618

I seem to have an issue with SmartSchedule not triggering as expected. I’ve got it set to trigger on Away Modes every 2 days but it gets stuck on waiting for configured trigger despite the fact that the Home Mode is Away as configured. Oddly one of the Neato’s is triggered by the scheduler fine but the other does not. Any suggestions on troubleshooting? I’ve tried removing and re-adding everything to no avail.


(Patrick Mjoen) #619

Does anyone else have 2 Neato vacuum’s? It looks like it is only starting the newest added one with the smart scheduler, but both if a force is necessary…


(Alex Lee) #620

I use 2 Neato’s each with their own schedule. One is based on presence and the other is on a fixed schedule. Haven’t noticed anything yet. What schedule do you have configured to each one?


#621

So basically I have 2 Neatos.

Downstairs was added first and is set to run on a 2 day interval measuring from midnight before the last clean triggered on away modes of Away or Night with a 5 minute delay. This Neato does not work with SmartSchedule.

Upstairs was added more recently and is also set to run on a 2 day interval measuring from midnight before the last clean triggered on away mode of Away with a 5 minute delay. This Neato appears to work fine with SmartSchedule.


#622

We have two Neato D3 Connected’s. I have one setup for every two days when we leave and the other every 7 days. They both work perfectly. It will only send them out when we leave after the scheduled wait time has passed if we leave two hours before it won’t send them out until we come home and leave again unless it makes it to the forced clean time then it will send them out no matter where we are.


(Alex Lee) #623

I’ll look into it. In the mean time, go into the smart schedule for the first Neato and save the config again. This should trigger an update and refresh the schedules to try and fix it. I think this is a bug and will look into it.


#624

Thanks much appreciated the app works well other than this minor niggle I’d look at it myself but not at all familiar with groovy.


(Alex Lee) #625

Just out of interest, do the people who are seeing this “2nd robot” issue . have the “measure from midnight before” option turned on? I know @mastermc0 has but wonder whether @pmjoen has too. Trying to narrow down where the bug is.


(Patrick Mjoen) #626

I also have that setting turned on.


#627

I don’t use the "measure from midnight before” option and my two robots work fine.


(Alex Lee) #628

I have found the bug, just trying to figure out how to solve it. I believe the delay start setting with 2 Botvacs with the same schedule trigger creates the issue. Could any of you with the issue tell me if you have a delay configured and then turn the delay to 0 to see if this is the issue?


(Chris) #629

@Alyc100 I am having trouble with the Neato App and device. It was working perfectly. Over Christmas I had to change my WiFi because we got new hardware and I updated the Neato App and Neat D7 vacuum and it connects and works perfectly. However the SmartThings znetao zconnect app and ST Neato device does not work anymore. It says wrong serial number or secret key. I want to delete the Neato device and SmartApp and just reinstall them from scratch but I don’t seem to be able to due to an error deleteing the device as well as an error deleting the SmartApp.

What steps should I do to resolve this?

Thanks