[RELEASE] Neato (Connect) V1.2.3 (Botvac Connected Series)

smartapp_appliances
dth_appliances
project_small_appl

(Stuart Smith) #528

Hoping for a bit of help please?
I’ve been moved to the new smartthings app but now can’t access neato.


Have checked and I’m on version 1.2.4b of the app and 1.9.2b on the device handler. Any suggestions?


(Alex Lee) #529

Unfortunately the app doesn’t support the new Smartthings app as of yet. Hopefully in the future it will.


(Nathan Curtis) #530

And you can continue to use classic with your shiny new Samsung ID. Works just fine.


(Stuart Smith) #531

Nope, old one worked for a bit but stopped working this weekend. Support told me I’d been moved. :frowning_face:

Old app just looks like this:

I’ll try support again try to get old one working.


(Nathan Curtis) #532

That’s teh experience you’ll get in Classic if your account is migrated and you dont login with your new creds. I can’t blame you - the way They (Samsung) have handled this from a tech and user education perspective is STUNNIGNLY wrong.

‘Moving’ is only the id - not the app. To make it work, you first have to completely log out of classic. (Hamburger menu, My Account, Sign Out) Then close the app. Then log in again with the new Samsung ID that your account migrated to. If new app works Classic should as well. It’s just an interface.


(Stuart Smith) #533

I updated to Samsung ID a while back and continued to use the ‘classic’ smartthings app for a while without any problems. Then the classic app stopped working this weekend. Tried signing out and then back in but didn’t fix it. I contacted support who told me I needed to use the new app for it to work now. Was a pretty quick response from support so i may have been fobbed off. I’ve contacted them again. I’m open to other suggestions until I hear back from support.


(Nathan Curtis) #534

Yeah you were DEFINTIELY fobbed off with an unacceptable answer. Need to call them back. There’s no problem going back and forth between the two. There’s definitely not feature parity between them so some (like me) would be completely unable to work in Connect alone.


(Alex Lee) #535

Just to let you know Device Handler v1.10 adds initial integration for the New Smartthings App. This functionality is very basic. It’s just an on and off switch. For full functionality stick with the Classic Smartthings App if possible.
@Stuart_Smith - Let me know how you get on.

You might have to go into the IDE, update the device to something generic like Z-Wave switch. Update. Then switch back to Neato Botvac Connected Series…


(Damien) #536

One update I have made to the device handler that I think would be worth adding to the main code is
adding the status attribute. I added it so that my WebCore pistons can make decisions based off of what the vacuum is currently doing. If any body else would like this ability now just open up the device handler and underneath the
attribute “bin”,“string”
add
attribute “status”,“string”


(William Hancock) #537

I’m getting an error if anyone could help? Thanks in advance

No signature of method: script_app_metadata_fb5d6e8d_5370_4fec_9ba9_86909b8e1331.metadata() is applicable for argument types: (script_app_metadata_fb5d6e8d_5370_4fec_9ba9_86909b8e1331$_run_closure1) values: [script_app_metadata_fb5d6e8d_5370_4fec_9ba9_86909b8e1331$_run_closure1@3ef826e9] Possible solutions: getMetadata(), getState(), setState(java.lang.Object), metaClass(groovy.lang.Closure)


(Alex Lee) #538

Double check that you’ve put the device handler and smart app code in the right places in the SmartThings IDE.


(William Hancock) #539

Yeah, that’ll do it. Doh!
Thanks for the reply. Great app!


(Michael Harman) #540

I want to give props to @Alyc100, I’ve been using this device handler for the 1.5 years, since we got our D5, and I’ve never had an issue with it and it’s been great to have it integrated with SmartThings and all the features that came with it.
Alas, I won’t be using it going forward. We recently had our second D5 die on us, it’s posting an error that won’t clear (it wants me to put it on the floor while it’s sitting on the floor). The first was replaced under warranty by Neato, but we’re out of the warranty period now since it’s based on original date of purchase and my wife is fed up with them. So we’re trying something different.
I hope you all have better luck with your Botvacs than we did. :slight_smile:


(Jake Seaton) #541

I’ve been using this app faithfully for months with my D3, but after the latest Botvac firmware update, I’m seeing an error.

I’ve tried reauthorizing the device and tried removing the device (this gives me an error), but I’m still seeing the same error.


(Alex Lee) #542

Does the botvac appear ok in the official Neato app?


(Jake Seaton) #543

Yeah, and the logs are showing the device is unhealthy.

EDIT: they were showing as healthy…

Now it’s healhty again.


(Jake Seaton) #544

Just wanted to provide an update. I needed to revoke access to the device by other smart apps, was finally able to remove to device, removed the Neato SmartApp, re-added the SmartApp and re-added the device.

Everything is working again.


(Jake Seaton) #545

I’m still getting a TON of connection errors. The vacuum is working fine and the automation seems to be working fine, but I get a connection error every few hours.


(Alex Lee) #546

You can turn off these notifications in the smartapp notification settings. I experienced this a lot on one of my botvacs. I upgraded my router because I changed isp and it stopped happening which made me think it was a WiFi deadspot issue.

If you notice the connection go down in the smartapp, check the official neato app too. When the disconnect happened, it happened on both for me.


(Jake Seaton) #547

No changes with my ISP or router, and no issues (that I can see) in the official Neato app. It just suddenly started throwing the errors in ST.

I turned off those notification, so it’s less annoying. And so far my smart schedule has not be affected by the connectivity issues.