[RELEASE] Neato (Connect) V1.2.3 (Botvac Connected Series)

smartapp_appliances
dth_appliances
project_small_appl

#468

This is absolutely fantastic. Thank you Alex Lee and other contributors.

I am using SmartSchedule with “Set your ideal cleaning interval in days” set to 0 to allow cleaning multiple times per day.

Would enabling a fractional input here (between 0 and 1) allow cleaning multiple times per day, yet with a minimum time between cleanings? For example, 0.5 would allow a cleaning once every 12 hrs if other triggers are met.


(Alex Lee) #469

Hi Brian,

Thanks for the feedback. The minimum value is 1 for cleaning interval. Decimal places aren’t handled at the moment.


(Andrew Rossetti) #470

Alex:

Any recommendation to fix this error?

Unexpected error occurred.

e41c28ee-6445-4cab-ba45-ddcf748e60cd 8:01:01 PM: error java.lang.NullPointerException: Cannot invoke method minus() on null object @line 1215 (getNextTimeInSeconds)


(Jonathonbsimon) #471

Hi Alex. i had your App working for several months, but had to reinstall and configure it all over again. Running the very latest Neto app version. I seem to be having some problem this time getting a simple schedule configured.

I started with a 7 day schedule (with the Beta midnight), no triggers, Saturday, 10am, but last weekend it would not start on Sat at 10a - i think because the 7 day limit had not quite been reached. So I manually started, reconfigured the cleaning cycle to 6 days, leaving the Sat 10a. But just now, 00:00 Saturday, the Smarthings started the Neato, seemingly ignoring the 10a restriction. So I stopped the clean. I have now tried configurating the schedule to 0 days and adding an end time (which was previously empty) in hopes of achieving the desired schedule. I know this shouldnt be so hard - I just want to clean every Saturday at 10a. Thanks for your help.


#472

@alyc100 hey mate, amazing stuff you’ve made here. absolutely revolutionizes this robot.

Curious if there were any plans to open up access to the two size Spot Cleanings?


(Alex Lee) #473

I’m currently thinking about including Spot Cleaning functionality. What I try not to do is duplicate functionality from the official Neato app. I don’t use the spot clean functionality myself so how would you see it working with the SmartScheduler? Would it just be an extra cleaning mode after you have configured the spot clean settings in the device handler?


(Alex Lee) #474

Hi there, yes the scheduler functionality is mainly built around smartthings triggers rather than a static schedule as this is happily handled by the Neato app. However, if I wanted to do a static schedule for Saturday 10a, I would try the following settings (disclaimer: I’ve never tried this):
Interval in days: 1
Measure day interval from midnight: true
How do you want to trigger the schedule: No Triggers
Operate Botvac only during a certain time: Between 10:00AM and 5:00PM
Operate Botvac only on certain days of the week: Saturday


(Alex Lee) #475

Try Neato (Connect) 1.2.4b which I’ve just published.


#476

Hey mate! And thanks so much for getting back!

Yeah, I recently repositioned my Robot so that the two spot cleaning modes could be utilized as quick kitchen cleans - therefore, it would be really cool if we could open up the Spot Cleaning functionality in the device handler - so then I, personally, would create a string of things starting with an Alexa command and leading to the device just doing that 6x6 or 13x13 spot clean in the kitchen.

If you could add that, it would be absolutely amazing mate. And I have seen at least one other who would like to be able to use this!


(Patrick Mjoen) #477

What updates were in this version?


(Alex Lee) #478

To try and prevent those null pointer exceptions people were experiencing. If you haven’t come across this error then it’s not a necessary update.


#479

Did you ever find a solution to this? I get multiple Smartthings notifications a day saying

Neato Botvac - Neato has an error: Not Connected to Neato

Looking in the logs at the same time I see the nucleocloud API posts are intermittently failing with this error:

12:30:24 PM: error Unexpected result in poll(): [404] [message:Could not find robot_serial for specified vendor_name]

The Neato device is basically yo-yoing, up and down, all day, with no pattern I can figure out. Sometimes it’s every 5 minutes, sometimes it doesn’t go down again for 12 hours. I’ve tried removing and re-adding the device and app, and updating to the latest app and device handler versions: 1.2.4b and 1.9b.

Anyone have any ideas?


#480

I get an error message every once in a while but if i look fast enough i see it isn’t responding in the Neato app either so i know it isn’t anything that can be helped by this SmartApp or DTH and the only time i get the secret message is when my Internet goes down.


#481

Do you have good WiFi coverage everywhere the vacuum goes?


#482

Yeah, fantastic coverage. It’s only a 750 square foot apartment, and the dock is about 8 feet from the router. I highly doubt this issue is my wifi - I have a ton of other devices here and none exhibit this problem.

Are there any other debugs I can turn on to figure this out? Could it be a problem with the neato itself?


(César Olea) #483

Unfortunately no. I ended up creating a new botvac entry in my account because I could never delete the old one. The new one has the same intermittent behavior that you described, but I mainly start it via a schedule and it works reliably.


(Jonathonbsimon) #484

Thanks so much - will give that a try. Curious - what actually happens when the interval is set to 0; I was surprised the app allowed 0, because I thought I remembered you saying in an email to someone else that the interval should be >=1 ?

Jonathon


(Barbara Schiavinato) #485

@Alyc100, I have the same issue: Body: [message:Could not find robot_serial for specified vendor_name]
Mine is a D7


(Zack) #486

@Alyc100 - Love the idea and design of the smartapp - but I’m having an issue getting it to run for the first time.

I’m able to add the SmartApp - v1.2.4b, enter Neato credentials, select my Botvacs (1 - Botvac Connected), and press “Save” on the devices screen. At this point, I haven’t changed any other settings (preferences, notifications, schedule, etc.)

I get an error when I attempt to Save the overall configuration of the App - “An Unexpected error occurred”

I’m not sure how to provide more detailed information about the error.

I have tried to restart the app, but I’ve had the same results each time.


#487

Have you turned on logging in the IDE to see what error occurs and at what point when you get the unexpected error message?