[RELEASE] Neato (Connect) V1.2.3 (Botvac Connected Series)

smartapp_appliances
dth_appliances
project_small_appl

(Kevin) #386

First, thanks for the great app. It’s been exactly what I am looking for. I’m getting the same error (Robot serial and/or secret…). It popped up when I got a new ISP and router. I had to reset my Botvac to reconnect it to my new router. I am reconnected and can access from the Neato app, but not from ST. The strange part is that if I go into the Smartapps tab and click Neato (Connect) it sees my botvac in the device list. I reconnected to neato and it hasn’t helped. Any advice is much appreciated.


(Mario Fuchs) #387

I have this exact same problem. I have 2 Neatos, one is working and the other one just shows as offline with
"Robot serial and/or secret is not correct.
Not connected To Neato."

Using the Neato app both are connected though.


(Alex Lee) #388

Try remove the device and re add. It might be that it generated a new secret which the Neato .app picks up but the smart app does not. I’ll see if this could be automated in future releases if this is the problem.


(Mario Fuchs) #389

Removed and re-added. No dice, still the same error message.

Strange thing for me is that 1 is working, the other one not. Starting the, in ST non-working Neato, using the Neato app will generate a cleaning map viewable in ST.


#390

On Friday I got the “Neato Botvac - (Botvac name here) has an error: Robot serial and/or secret is not correct. Not Connected To Neato”. However I checked the recent tab on the ST vacuum screen and it showed it reconnected after that and Saturday it said it had scheduled the Botvac to clean when I’m next away, then Tuesday it said “Neato Botvac - (Botvac name here) has an error: Not Connected To Neato”, again it showed it reconnected shortly after. When everyone was finally out of the house last night this SmartApp told the Botvac to clean and we had a nice clean floor when we got home. So mine seams to have self healed since I haven’t done anything with it since the first error occurred. I only have the one vacuum, is it possibly an issue when there are more than 1? I love this integration and hope it continues to self heal whenever it has an issue.


(Monte Montemayor) #391

Shoot, getting an error when trying to save after logging in and setting options. Confirmed the Neato is connected (just started to vacuum with the Neato App). Any ideas?


#392

What do you have set in the “How do you want to trigger the schedule?” it doesn’t show in your screenshot as expected.


(Monte Montemayor) #393

OK - I thought I set that trigger as “none” or “no trigger” but I’ll check. Thanks.


#394

You may have I’ve never tried that option, maybe try a trigger to see if there is an issue using that option to see if it will save without an error then.


(Monte Montemayor) #395

Good idea. Thx


(Justin) #396

Anyone have a hubitat hub?


(S0t0ng22) #397

I keep getting ‘An unexpected error occurred.’,when I try saving the Neato (Connect).

The live log showed the following error:
eb967475-b035-4ba0-8132-5a4a13441180 3:53:08 PM: error java.lang.IllegalArgumentException: TimeZone not found in time input string or provided as a second parameter. @line 1194 (doCall)

Anyone can advise on how to solve this?


#398

What timezone do you have set under My Locations and click the name of your location in your IDE? It should show something like Time Zone America/New York, it sounds like the script doesn’t like what yours is currently set to. You can edit it at that location to try setting it to another setting if you can find another which would have the same time as you to see if that makes a difference in saving the smartapp.


(S0t0ng22) #399

Problem solved! Thank you!


(Monte Montemayor) #400

I think @krlaframboise does.


(ilker Aktuna) #401

@Alyc100

is it possible to “pause/resume” (not start/stop) Neato Botvac from a Core piston ? how ?
And is it possible to trigger Core pistons when Neato Botvac is paused ?

thanks


(Monte Montemayor) #402

I just can’t get this connected to ST. BTW, this is a brand new today D5 (I took the old one back). Works great with the Neato App but I would really like it to be controlled via ST. Any ideas?


(Damien) #403

Trying to install this, but after adding the repo, I click on Update from Repo and select the new repo, but I do not see smartapps/alyc100/neato-connect.src/neato-connect.groovy in the list for smart apps. the closesest I see is smartapps/alyc100/neato_icon.png.

Any ideas what I have done wrong?


(ilker Aktuna) #404

does anyone have any idea on this ?

thx.


(Damien) #405

Got everything installed.
It seems to monitor my new Neato Botvac D7 just fine. But I can not start cleaning with the app. If I click the button to turn on cleaning it will show cleaning in SmartThings for about a minute, but it never starts cleaning, and within a minute the status of it refreshes to Stopped.

Also tried starting it from WebCore, and it does not start with this either, which would be expected if the SmartThings app doesn’t work.

I do see “Sent On Command to Neato Botvac - myName” under Recently when trying to start from WebCore.
No log when trying to start manually from SmartThings.

Hopping tomorrow the SmartScheduler will try to start it.

I know it just came out but are there some updates that may be needed to start the D7?

Not sure if it will matter. I would love to be able to use WebCore or the SmartSchedule to control my Neato, but I don’t think it will use the No-Go lines when started with this device controller.

I started it once with the Alexa Skill, and it started cleaning, but in the Neato App it showed that No-Go lines were disabled. I would think the Alexa Skill uses the same API as this device controller. If that is so I guess I am going to have to use the Neato App to create a basic time schedule, because the No-Go lines were the main reason I waited until the D7 came out, and the only reason to pay the extra money for it over the D5.

I am hoping Neato fixes this soon, because I love really want to have a schedule that is based upon my SmartThings Away mode.