[RELEASE] MyQ Lite Door and Lamp Control (for Liftmaster/Chamberlain)

How do I update the app? I already have the myq lite app setup and working properly

Update the smart app in the IDE

//log.debug "This door (no sensor) version: " + state.thisDoorNoSensorVersion
//log.debug "This door version: " + state.thisDoorVersion
//log.debug "This light version: " + state.thisLightVersion

if (state.thisSmartAppVersion != state.latestSmartAppVersion) {
	state.versionWarning = state.versionWarning + "Your SmartApp version (" + state.thisSmartAppVersion + ") is not the latest version (" + state.latestSmartAppVersion + ")\n\n"
}
if (usesDoorDev && state.thisDoorVersion != state.latestDoorVersion) {
	state.versionWarning = state.versionWarning + "Your MyQ Door device version (" + state.thisDoorVersion + ") is not the latest version (" + state.latestDoorVersion + ")\n\n"
}
if (usesDoorNoSensorDev && state.thisDoorNoSensorVersion != state.latestDoorNoSensorVersion) {
	state.versionWarning = state.versionWarning + "Your MyQ Door (No-sensor) device version (" + state.thisDoorNoSensorVersion + ") is not the latest version (" + state.latestDoorNoSensorVersion + ")\n\n"
}
if (usesLightControllerDev && state.thisLightVersion != state.latestLightVersion) {
	state.versionWarning = state.versionWarning + "Your MyQ Light Controller device version (" + state.thisLightVersion + ") is not the latest version (" + state.latestLightVersion + ")\n\n"
}
log.debug state.versionWarning

}

def notify(message){
sendNotificationEvent(message)

can anyone suggest anything for me?

Your code is outdated. You need to grab the latest SmartApp and Device handler code and paste it into the IDE.

Still working ok for me at the moment.

Mine too stopped working about 30 days ago. Turns out the fix was to remove the garage door and reauthorize myself from the MyQLite smart app. Then add the garage doors back. For some reason the state.data didn’t have the garage door in the payload, so the open and close buttons refused to work. I was only getting errors when I would do “Open” and “Close” within 30 seconds of each other to figure out what the bug was.

Replying to an an old post in case someone else has same question. When I got the the new opener, I repurposed the no longer needed GDOOZ as a tilt sensor for MyQ Lite. It works great. Note I believe you need to leave the base unit plugged in and the tilt sensor communicates through that. I changed the device type in IDE from garage door opener to door/window sensor. An expensive tilt sensor, but avoids having to buy a new one.

1 Like

Just installed and have MyQ Lite working well with 3 doors, a gate operator and 3 garage lites. Great app brbeaird, thank you. One minor issue I thought I would share in case anyone else has same issue. Two of my doors have tilt sensors, 1 door does not and the gate does not. The set-up did not seem to like a mixed configuration of sensor/no sensor. On the first set-up the two units I associated with sensors still showed up as no sensor versions upon completion. When I changed them to sensor version in IDE they did not communicate with the previously associated sensor. After unsuccessful re installs, here is what worked for me. I installed all 4 as sensor versions, adding open/close tiles for those that don’t really have a sensor. I temporarily associated them with another random sensor. After install I changed these 2 back to no-sensor devices in IDE. So far so good.

Yes, there are certain combinations that give the app fits. I’ve had this on my list to fix, but it will probably not happen until I get around to rewriting the entire thing with the new API dev tools (see announcements category for more details related to that).

I HAVE HAD PROBLEMS SINCE LAST YEAR. STILL CANT GET IT WORKING. I removed EVERYTHING and added the device handler and SmartApp back in and not SmartThings doesn’t even see it as an installed app. No trace of it in the SmartThings app.

Really frustrating cause one of the reasonsI replaced my garage door was to get SmartThings to control it. I am an experienced systems engineer and this is still knocking me on my behind with not working.

Does this app need Oauth?

…Alan

No, it does not need Oauth. If you’re reinstalling via Classic app, keep in mind you’ll need to scroll down into “My Apps” to find it and install it again.

I absolutely know that and it does not sho under my apps.

Sorry you’re having trouble. Another possible route you could try if you haven’t already is installing the community installer ([BETA] Community SmartApp Installer) and then trying to install this SmartApp through there.

1 Like

Is anyone having login error issues? Just yesterday, I started getting a “MyQ command failed due to bad login” errors. I verified my credentials in the smart app settings but it indicates my username or password is incorrect. I’m able to use the regular MyQ app with these same credentials without issue. Overall it’s worked perfectly up until yesterday.

1 Like

Yep, mine is dead at the moment. Been playing with it in Postman to figure out what changed. No luck yet.

Found the issue. Username and password attributes are now case sensitive and begin with capital letters.

I pushed an update to the SmartApp code to fix it. You’ll want to grab that and update yours to get working again.

8 Likes

Thank you for everything you do for the community.

2 Likes

Agreed and NOT AT ALL looking forward to this all being taken away…hopefully it will be coming like all the integrations promised…NEVER. :wink:

1 Like

I just installed and updated via the community installer method. First time using it, new garage door opener. The MyQ app works, but i cannot login via MyQ Lite. I am getting the Username and Password error. I have tried to make sure i am up to date from all of the repos