SmartThings Community

[RELEASE] MyQ Lite Door and Lamp Control (for Liftmaster/Chamberlain)

smartapp_garage

(Tom Steele) #1529

@gbruyn

  1. I have this problem with one of my doors (I have two). Luckily it is one that I rarely use so I haven’t delved into it. Sometimes the hub will just beep and flash and the door never goes anywhere. This happened before installing the MyQ Lite, which I just did today, so this is a MyQ thing, not an ST thing, at least for me. At this point I am not sure what could be causing the problem.

  2. I looked at those on amazon and saw a lot of reviewers mentioning that. It seems a lot have switched out the ball-bearing switch inside with a mercury switch. Seems like it’s pretty easy if you don’t mind tinkering with things and can solder. But it is more than I wanted to deal with. I ended up getting the Smartthings multi-purpose sensors. It’s only been a few hours but so far so good :slight_smile:


(Tom Steele) #1530

edit I got this figured out. Had to add Momentary Tile handler and set up the push button tiles. Then set the routine to act on those</edit>

I just got this app up and running today and first off i just want to say thanks so much for this great app! I have been so frustrated with MyQ’s lack of integrations and “Premium Partner” BS

So I have two doors, one MyQ Hub, and I am using the Smartthings multipurpose sensors. I set up the “Alexa, open the garage door” routine as mentioned on the github page and that worked fine. But then I went to set up “Alexa, close the garage door” and when I went to set up the device action, it just defaulted to turning on the garage door, which is the same thing “open the garage door” does. I was thinking maybe it considers turning garage door to off as unlocking? I’ve tried all sort of combinations and permutations between the Alexa permissions to allow the app/voice to unlock and different settings in the MyQ Lite app but maybe I just haven’t stumbled on the right combination. Any thoughts?

I just installed the MyQ hub about a week ago and as mentioned just set up MyQ Lite today and this is my first Alexa routine so apologies for my newbiness


(Erik) #1531

@brbeaird

I am having the same issue in the default ST SmartLocks Smartapp. I do use the rboy DTH for my locks, and have changed the DTH to be the “Zwave Lock” for it to work with the integrated ST Smartapp. But after the update today I get the same thing for my garage doors.

Hopefully your can get this sorted out pretty quickly…my OCD doesn’t like “unknown states”! Haha.


(Brian) #1532

Yes, I believe I have a fix for the “unknown” state issue. Everything ran smoothly for me over the weekend. I am, however, going to go ahead with splitting out the “lock” type doors into a separate device handler to minimize confusion for people who don’t care to have their doors overlap into lock apps where they don’t want them.

Might be another few days, but I’ll have something better out soon.


(Brian) #1533

Just pushed an update that should resolve recent issues.

  • If you want lock functionality, doors are now automatically created as a different device type. This device type has no switch capability, which forces users to go through the normal lock procedures with voice command units.

  • An automatic refresh now runs every 30 minutes to sync door status with sensors (if applicable). This seems to resolve the “unknown” status problems, even in the SHM lock SmartApp.

This update has some pretty significant changes. I tested as best I could, but if you find bugs, let me know.


(Erik) #1534

Will it take the 30 minute refresh to sync SHM with the SmartLock SmartApp? The Smartlock SA is now correct without the doors as “locks” but SHM still shows 2 “unknown” lock status, which are the garage doors. Should I wait for 30 minutes?


(Brian) #1535

Yep, I saw the same thing. It may have taken an hour or so but SHM did eventually correct itself. Did not seem to be directly tied to the refresh event for whatever reason.


(Flip) #1536

Is there no way to connect these two and still have the garage door status without a separate sensor? the myq app obviously knows the door status, why doesn’t ST?


(George A Roberts IV) #1538

See post 1366: [RELEASE] MyQ Lite Door and Lamp Control (for Liftmaster/Chamberlain)


(milandjurovic71@gmail.com) #1539

I am curious why do you want to remove lock feature from garage door? Some new garage door openers have lock (deadbolt) that can be locked automatically.

LIFTMASTER 8500W 2-893MAX remotes JACKSHAFT GARAGE DOOR OPENER MYQ ENABLED WIFI AND BATTERY INSTALLED https://www.amazon.com/dp/B07C59BL9G/ref=cm_sw_r_cp_apa_i_Z2xlCbVVCSWJ1

I was thinking to add standard z-wave schlage deadbolt to my garage door, but if this device handler works with Lifmaster 8500W, I might just change door opener.


(Brian) #1540

The last update was not related to any actual locking features. It was more of setting up the door device in SmartThings to behave more like a “lock” so that things like Alexa/Google/ActionTiles will open up some more secure features for the door.


(milandjurovic71@gmail.com) #1541

Brian thanks for update. Would your handler work with Liftmaster 8500. I guess open/close would work, as is myQ device. That model has deadbolt, and battery backup. Looks nice


Liftmaster 8500
(Brian) #1542

I don’t have that model myself, but I do believe there is confirmation somewhere earlier in the thread where that model does work. I can’t imagine any reason why it would not.


(Erik) #1543

@brbeaird I get this notice when running through the setup again. Do you know why? I just updated it again and got the same message.


(Brian) #1544

I just tweaked the door device a few minutes ago, which bumped the version to 2.2.2. If you pull the most recent update again, that should take care of it.


#1545

Brian,

With the update that introduced 30 minute auto-refreshing of the status it causes Alexa routines to fire with the refresh if you are triggering off the Garage Door device in Alexa. In other words, every 30 minutes Alexa is telling me the garage door has closed. If you use a sensor then I think one workaround is to trigger off the sensor instead (I will try later).


(Brian) #1546

I made a change last night that fixed an issue where the door was updating and spamming the event log even when nothing changed. Maybe try the latest door handler and see if that stops it?


#1547

Great, I will give that a try. Thanks.


#1548

I’ve got the 8500 and it works great.


(Brian) #1549

I pushed an update this morning to re-add the door control capability (I removed it because it appeared redundant alongside Garage Door capability). If you were having issues related to this, updating to the latest version should fix that.

I also moved the “lock” option deeper into the setup process and buried it in a hidden “advanced” section. Given its highly experimental nature, I don’t want people stumbling upon it and getting confused if they’re not specifically looking to use it.