SmartThings Community

[RELEASE] MyQ Lite Door and Lamp Control (for Liftmaster/Chamberlain)

smartapp_garage

(JimMay3) #1509

Well, the door ran several times perfect today with the latest updates.

Ran it from phone, remote and wall, all were captured immediately and indicated good all day.

Just ran the new Refresh button and logs look much cleaned now, so must have been a ST glitch some have been seeing:

10:34:28 PM: debug Door: Garage Door Opener: Updating timestamp to: Fri Dec 07 20:31:57 UTC 2018 - from sensor Garage Door Sensor
10:34:28 PM: debug Door: Garage Door Opener: Updating timestamp to: Fri Dec 07 20:31:57 UTC 2018 - from sensor Garage Door Sensor
10:34:28 PM: debug Door: Garage Door Opener: Updating with status - closed - from sensor Garage Door Sensor
10:34:28 PM: debug Door: Garage Door Opener: Updating with status - closed - from sensor Garage Door Sensor
10:34:28 PM: debug refresh called from Garage Door Opener
10:34:28 PM: debug No change; door is already set to closed
10:34:28 PM: debug Request received to update door status to : closed


(Hal) #1510

Ah. The idea of scheduling a door to close (or open if they allowed it) at a particular time sounded so useless to me that I completely forgot the ability existed in the Chamberlain app.

If they would allow me to be notified that the door was open at some time, I can see a use for that. I do use the notifications in the Chamberlain app for door open events. They arrive with the right timestamp but can be delayed up to several minutes.

Anyway, getting off track again. Sorry @brbeaird!


(JimMay3) #1511

Use the “Notify Me When” Smartapp under security in ST, just tag it to your garage door sensor. I go mine set to notify me when left open for more than an hour and anytime between 10pm-6am, their system seems to push and text immediately. When my mailbox goes off, if by window I can still see him at the box.

@brbeaird, yes we’ve been off track, but your efforts to date to keep us running and can not be appreciated more, thanks for all you do…


(Hal) #1512

Thanks. Good suggestion … once I get sensors…


(Rick) #1513

Just wanted to say thanks for the efforts!
I was extremely pleased to see someone didnt give up when they blocked it last time. It’s nice to have a backup if the wife needs it etc


(Kyle) #1514

Well, just wanted to come and admit… I messed up. Finally had time to take a look at it after being out of town last week, and discovered in the setup instructions (after I reset it from assigning different device handlers to try something else) that I had the device upside down :man_facepalming:

Everything is working much better now, thank you all very much!


(Bejoy Kollikara) #1515

Is the only way to fix the issue of it stuck in “Opening” state to redo the whole set up?

Been running this for almost two years with no issues. Noticed my pistons not working since Nov, and just getting to troubleshoot.


(Brian) #1516

It’s not as big of a deal as it sounds. After you update the code, you can just open the SmartApp and tap through the setup (everything should be saved as it was before).


(Bejoy Kollikara) #1517

Thanks Brian, it seems to have worked. I’ll keep an eye on it.

BTW, this is one of my most used app and cant thank you enough.


(M) #1518

The app works fine within SmartThings, but for some reason is not importing into my list of devices in Google Home (and the accounts are linked). Would be great to be able to control it by voice - anyone have any ideas?


(Brian) #1519

Minor release tonight that adds lock capability. It also adds the option to disable switch on/off commands in case you’d like to force the use of lock/unlock with voice command devices that support pin codes.


(C.Cruise) #1520

Love the new features but I noticed the garage door now appears under the ST “smart locks” area as an “unknown” lock state. First glance it does appear that there is anyway to “remove” the garage door as a lock but I haven’t dug into it quite yet.


(Brian) #1521

I’m honestly not sure where you’re seeing this. Is this in the ST app? And have you tried going to the door device and triggering a refresh to see if that sets the lock state?


(C.Cruise) #1522

Including ST classic screenshots. I haven’t searched in the ide logs yet but the feature is the ST Smart Locks in classic app and unfortunately there’s not a way that I can tell to exclude locks from that app. Hopefully this helps; I’ll also look in the ide for other events.


(C.Cruise) #1523

Looks like there’s a polling event per the ST classic app log


(C.Cruise) #1524

Here’s the “app” from the selection menu:

It’s found via AddASmartApp -> SmartThings Recommends -> Smart Locks


(Brian) #1525

Interesting. I’ve not used the ST Smart Locks app and have just been rolling with the RBoy version. I’m able to reproduce now, but I’m not sure yet how to fix that. I may need to dig through some of the other lock device handlers to try to see what that app is looking for. There probably are not that many custom handlers for virtual locks.


(Brian) #1526

@ccruiser - could you try going into the door device in the IDE, clicking “edit” and making sure the garage door is associated with the correct hub? Once I did that, the lock manager correctly showed the status.

I’m not sure if this will stick if the Smart Lock app depends on some of the health check stuff, but I’ll try and test it out over time.


(Brian) #1527

Yeah as I suspected, the lock status flips back to “unknown” after awhile. I chatted with RBoy about this a little bit today, and he said SmartLocks and Device Health both have similar issues where custom handlers like this are not supported in a way that would keep the status automatically updated. Does not seem to be a way currently to exclude custom locks like these, either.

I’ll play with a few things to see if I can figure out another way. Otherwise, I may just separate the lock type out to a different device type so it will only show up for users who want to use it.


#1528

A couple of notes after using this for about a year now. Perhaps someone has some ideas to fix some of my issues:

  1. Sometimes when I go to close the garage door using the app and I’m home (watching this process), the My-Q hub will flash and sound for a while but then nothing will happen. I’m now guessing that this probably has nothing to do with this ST integration and would probably also happen with the Liftmaster App as well. I have my hub installed right next to my Liftmaster 8500. Perhaps it’s too close and signal isn’t getting through all the time?

  2. The tilt sensors that everyone recommends from Amazon (gold plated generic ones) seem to get “stuck” sometimes. I have to either tap them or cycle the door to get them to cooperate again. Perhaps I got a bad batch. Everyone else having that issue?

Other than that, it seems to work as advertised. Thanks for the hard work and keeping it updated!