SmartThings Community

[RELEASE] MyQ Lite Door and Lamp Control (for Liftmaster/Chamberlain)

smartapp_garage

(Kyle) #1449

Thank you for this, I purchased it on Black Friday not realizing that it doesn’t have native z-wave support like some of the other devices out there. I ended up buying the Smartthings multipurpose sensor a couple of days later after I installed it and realized it wouldn’t all work together and now things seem to be working good with IFTTT/Assistant. I have a couple of questions:

The Smartthings tilt sensor seems to be polling like crazy and it’s draining the battery (7% since last night). Is this normal? Any idea on what’s going with it?


(Brian) #1450

I don’t have the ST tilt sensor, but that does not seem normal to me. I’m not exactly sure what you mean by polling - what does the “recently” tab look like on the actual sensor?


(Kyle) #1451

By polling, I mean that it seems something is attempting to get the status every minute or so. I didn’t know if that was normal behavior for the SmartApp to do so or if it’s something going on with the sensor. I did add the sensor after the fact, now that I think about it, wondering if deleting everything and starting over would help?


(Bill Wolfe) #1452

I don’t use that sensor either, and Brian is the expert here, but, your first screen shot appears that something is sending an Open command to your door but it never opens…? Mine is always followed by an orange icon that says “is Open” . But my door is actually operating

Looking at your second screen shot it appears the multipurpose sensor is seeing (or thinks it’s seeing) something… Could that cause the “Sent opening command” in the first screenshot (faulty sensor)? Do they correlate?


(Kyle) #1453

I do get the “is open” message for when it is actually open, but it’s still pinging it every minute.

I also see there is a correlation between times between the two devices. I tried to remove the garage door and readd, but that seems to not take care of it.

Hopefully it’s not a faulty sensor, it seems to be working but I guess it could be bad if it’s doing all of that on it’s own - I just wasn’t sure if it was the SmartApp pinging it a bunch of times, and then I noticed this:

It wasn’t opening, but because of that “active/inactive opening/closed” messages between the two it acts as if it’s opening during that time - which it’s not.


(Bill Wolfe) #1454

OK… I did a little experiment on my end. Again, I don’t have a multipurpose sensor. I have a door/window sensor (open/close) mounted on a hinge (works great BTW).
sensor%202 sensor1

I manually opened my sensor (not the door) and my “virtual garage door” (your first screen shot) showed it was open. I think the question to ask is, “Why is multisensor continueing to report “active” when the door is not moving?” Are you seeing the result of the sensor reporting motion when there is none? Just a guess My sensor doesn’t have the ability to show “active”, only “open/close”, so I really don’t know what to expect to see.


(Erik) #1455

I have this setup with the ST multi purpose sensor and don’t have that level of polling.


(Brian) #1456

What I can say for sure is that this SmartApp does not “poll” the sensor. Instead, it is “subscribed” to changes from the sensor, so when the sensor reports its status to the hub, the hub “notifies” the SmartApp, which then updates the status of the door.

Oddly, signs seem to be pointing to something wrong with the sensor. Maybe just try to change the battery out first? And if that doesn’t work, you may just need to try another one.


(Kyle) #1457

OK… I did a little experiment on my end. Again, I don’t have a multipurpose sensor. I have a door/window sensor (open/close) mounted on a hinge (works great BTW).

First of all, that is awesome. I was wondering how to set that up!

I didn’t think I needed the contact sensor set up, just acceleration. I removed the magnet part and just did the sensor since the MP sensor can be used as an acceleration/garage door sensor. I think it’s basically the same thing.

I have it set up like this, I take it it’s the right way?

I also contacted Samsung about it, in case it is faulty.

I appreciate all of the help!


(Brian) #1458

For the sake of simplicity, I suggest ONLY using the contact sensor. Lots of people have had weird results with acceleration.


(Alex) #1459

I’m actually having the same issue as @unrly. The opener is stuck in “opening.” I didn’t have this problem before I updated to the latest code in Github. Is there a way I can easily rollback or tell you what version I was using before?


(JimMay3) #1460

I have the same “Opening” issue with a tilt sensor installed.


(Alex) #1461

For what’s it is worth, I’m using a contact sensor for mine with the same problem.


(Brian) #1462

I actually had a similar problem with mine this evening. Looking at the event list, the MyQ door device completely missed a “closed” status from the tilt sensor, leaving the door to show “open” when it was closed. Very, very odd. Possibly a bug in the SmartThings platform with event subscriptions?

I tried to reproduce a couple different ways tonight, but everything worked correctly. If anyone is able to reproduce post some logs, let me know.


(JimMay3) #1463

Maybe a refresh button on the screen to hit to clear the mismatch, else have to cycle the door to go clear the message.


(Brian) #1464

Ah, great idea. I had intended to do this awhile back and forgot. I’ll add that.


#1465

Quick question . . . I have read that that the MyQ sensor cannot work with this smartapp. Is there any way to get it to work? I am sure there is a really good reason for this, but I have noticed that the MyQ sensor seems to have been made to work the Homebridge plugin (https://github.com/caseywebdev/homebridge-chamberlain). Since I installed that a few weeks ago, the position of the garage door has been flawlessly reported in the Home app. When I restart the Homebridge server it always correctly identifies the garage door position. There is probably something going on here that I am completely unaware of, but I was hoping this might be helpful. Thanks!


(Dominick Barile) #1466

Are any of you guys able to get a genie Aladdin garage door to work with smartthings? Dur9ng my last conversation they said that they are making a new model available next year that will work with homekit. They also said its smartthings responsibility as Amazon’s to.contact them I’d yhey want there products to basically be compatible with Samsung and alexa.


(Brian) #1467

The Homebridge plugin (and other similar solutions) works by polling the MyQ API every minute or so to get the door’s status (which is reported from the sensor). MyQ does not allow SmartThings to poll like that due to the large amount of traffic it creates, and they actually disabled the previous version of this SmartApp integration for that reason.

So yes, technically it could work, but if we did it, MyQ would shut us down again. MyQ does seem to let it slide as long as you’re doing it on a smaller, decentralized platform.


(Bill Wolfe) #1468

I reported about a week ago that I was getting similar behavior. It didn’t last long. What I do know is at that instance the MyQ app itself was giving spotty behavior because I jumped into it to try to operate the doors and received very sluggish, if any response. All of my doors (5) have been rock solid since that one time and the last update. I’m only using an open/close sensor.