[RELEASE] MyQ Lite Door and Lamp Control (for Liftmaster/Chamberlain)

smartapp_garage

(rvs007) #1408

What works better with the MyQ Lite SmartApp, the Samsung Multipurpose sensor (configured as an accelerometer), or a tilt sensor such as ones from Monoprice or Ecolink? Which one of those would give action status updates to the app (e.g. Garage door opening…; Garage door closing, instead of just opened or closed status).


(Rich) #1409

I use the monoprice zwave tilt sensor and it gives me what you are asking for depending on which method I use to open the door.


(Dave) #1410

I’m having an issue when I try to add my contact sensor, from scratch or into my current integration. I get the “Error - bad state. unable to complete page configuration.” notice. Any thoughts?


(Brian) #1411

Can you open the IDE live logging while that’s happening and see what error you get?


(Brian) #1412

Good day all! MyQ Lite update pushed today:

  • Increased maximum door limit to 8
  • Added partial support for the new SmartThings app. This does require a full SmartApp reinstall to take effect and even then, it’s still not perfect. It does seem to allow the door to device to show up and have commands sent, though, so it’s a small step forward. Credit to @vseven for sharing the code changes needed here.

@wolfewl - give it a shot and see how it works. As I only have 2 doors, it’s tough to fully test the code to make sure it works with more than that :slight_smile:


(Bill Wolfe) #1413

Thank you!

So, delete the existing SA and DH and start from scratch? Same link to get what I need?

Thank you for your time!!!


(Brian) #1414

If you just want to see the higher door limit, you can just copy/paste the updated App/Handler code over what you’ve already got. Then open the existing MyQ Lite SmartApp setup on your phone and walk through it - it should then pick up the other doors. No need to totally delete in that case.


(Bill Wolfe) #1415

No luck… I went into the SA and DH and copied the new code into each.

Now, after I get two doors setup and hit next for the third door I get “Page ‘content’ method does not exist

I deleted the SA and DH and started from scratch. I installed the SA and created the device handler for the sensor version. Still having issues. I can only setup three doors. They do not perform correctly now… In the app under devices they can not be controlled. When I try to operate the door it flashed “unknown” and then goes right back to the previous state. If I go into the device itself I can operate it from there…?


(Allan) #1417

Just my feedback. I updated the app and DTH just by doing an GitHub update (not copy and paste) and everything updated correctly. I ran through the smart app to refresh everything that was successful also. I only have a single door but it is working in both classic and the new connect app.

There is a bug in the connect app that holds onto old DTHs even after they are updated. So will most likely have to delete your garage door object and then run through the smart app again to have it recreated. It should work in the connect app after that.


(Bill Wolfe) #1418

I’m not familiar with that method. I went to “https://github.com/brbeaird/SmartThings_MyQ” and replaced the code from there. When I deleted everything and installed from scratch I used the same link. I did notice this as well in regards to the version:

Keep in mind I had flawless performance with the previous version. I suspect it’s something I’m doing, but, I have no clue what. That’s why I deleted everything and tried to start from scratch but I’m not having much success.


(Brian) #1419

It’s definitely possible I broke something. Let me see if I can dig in a bit deeper and maybe simulate more doors on my end.


(Bill Wolfe) #1420

I can call on them in a Routine and they will also operate…


(Bill Wolfe) #1421

I couldn’t delete the SA or DH until I removed the doors


(Brian) #1422

Yep, I made a few typos that broke the setup process for more than 3 doors. I pushed another update that should hopefully fix that now. @wolfewl - let me know if that works for you.

I would also recommend checking out the Community Installer SmartApp. Once you have that running, you can open it, choose MyQ Lite, and just hit a single “update” button to get the latest App/Handler code installed in your environment.

As far as deleting goes, yes, there is a known issue with SmartApps where you cannot automatically delete devices that are used in routines and things like ActionTiles. You have to manually go in and force-delete the doors first, then you can delete the SmartApp.


(Bill Wolfe) #1423

Thanks, Brian.

Yes, that solved the limitation of doors. I now have five!

I’m still having the issue of not being able to control my doors from My Home tab (where it has all devices listed and shows open/close to the right of each door). If I go into the door itself (from that same screen) I can control it. I can also control it using a routine. I used to be able to control them from the My Home screen… Any ideas? It’s really nice to be able to control them all right there in that view with a quick click.

I didn’t do this as the setup video link seems to be broken and at this point I figured I better just stay with what I know. I will look into it though! Looks really useful.


(Bill Wolfe) #1424

It appears not being able to operate the door from the My Home tab (flashing to UNKNOWN when tagged and no action taken) is also causing issues with my webCoRE programming. My program that reports if the door changes from “Open” and the contact doesn’t show closed after 30 seconds isn’t function properly. It’s sending alerts when they open now.


(jkp) #1425

With the most recent update, my garage door keeps showing as Unavailable in the Classic app or Disconnected in STSC. I can still operate the door and it changes to normal status but after awhile it goes back to showing as Unavailable.


(Bill Wolfe) #1426

I woke up to all of the doors being unavailable, I’m not sure where to go from here… I think I’m seeing what you are. I can not operate my doors unless I go into the device. It just flashes UNAVAILABLE and returns to it’s previous state.

Is there a way I can go back to the 4 door version and make sure it’s not me? It was flawless.


(Brian) #1427

That’s really odd. Seems to be working fine on mine. I went ahead and reverted some of the changes to the device handler (I don’t think the door limit changes would have impacted this piece).

Can you try updating to the latest door device handler version and see if that helps?


(Bill Wolfe) #1428

Just to insure I’m using what you think I am… I’m downloading from the following link:
https://raw.githubusercontent.com/brbeaird/SmartThings_MyQ/master/devicetypes/brbeaird/myq-garage-door-opener.src/myq-garage-door-opener.groovy

This is where I’m supposed to be, correct?