[RELEASE] MyQ Lite Door and Lamp Control (for Liftmaster/Chamberlain)

Are you using the sensor version of the door? If so, it should show up as a simple switch. If not, you’ll need to go into the SmartApp setup and enable the momentary push buttons, and those should show up in Google.

To be honest I’m not sure lol what I do know is I’m using the solution from Roman’s post From here which uses a local server so I’m not sure if it’s the exact same set up. In my SmartThings app I have a “Thing” called Garage Door that shows the state. In the right now screen I see THIS under "SmartApps for the device there are none installed and the config option only allows me to change the name.

EDIT: I went into the SmartApp through the IDE to see if something popped out on how I could add the momentary push buttons however I’m not sure what I’d actually need to do unless it’s actually modify the source code to include buttons?

Ah ok, I missed that. Yeah, that’s a completely different SmartApp, but I’m sure there’s something he could tweak to make Google recognize it. I’d send him a PM.

1 Like

Thanks Brian. Very sorry for posting in your thread for something unrelated I had a little doh moment as I read back further :frowning:

1 Like

Thank you so very much Brian, mine stopped working today and could not figure it out, the new code did the trick.

Thank you Brian ! This worked perfectly for me.

SOLVED: Does this still work for Craftsman Assurelink with what is basically a MyQ gateway? I am very new to this so could be doing something wrong. I followed most the instructions (you know how things don’t make sense until you do it 10 times)… but I see the app on my phone, I select Craftsman and put my login info in and it fails the login each time. I am pretty sure I am typing the password right.

Any help would be appreciated!

edit: shoot me… shoot me now… I use an auto password generator and I went to google to “see” it… well it was cutting off a few characters! lol… I am seeing both my doors. To control them is next!

1 Like

Hi brbeaird. Great stuff. I just updated to the latest code, though the SmartThings app says I’m not on the latest which it says is 2.0.3, though the code on GitHub is 2.0.2. Am I missing something? Also: when I installed your code about 10 months ago I hadn’t starting using GitHub yet. Now I am. Is there a guide for sort of retrofitting updating from the repository instead of manually? Thanks again. This app is great!

Brian,

I’m using this -https://www.amazon.com/Chamberlain-MYQ-G0201-MyQ-Garage-Controls-Smartphone/dp/B00EAD65UW/ref=cm_cr_arp_d_product_top?ie=UTF8

Everything was working fine up until a few days ago. It stopped seeing me when I would come home. So I removed and reinstalled everything per your instructions you’ve posted. Now, my smartthings isn’t seeing my MyQ garage doors anymore. When I’m setting up the app, it sees the garage doors there but no longer sees the sensors. So when I complete the SmartApp MyQ lite, it doesn’t look like it’s set up correctly because it never saw the sensors. Then I go to “add a thing” and it never finds the garage doors. I’m probably missing something simple, but I keep repeating the steps over and over and nothing works.

My actual MyQ app on my iPhone still works like a champ so it doesn’t seem as if there is an issue on that end. If anything pops into your mind I would love to hear it.

Thank you. -Todd

Are there any benefits of the models with built-in wifi vs those needing the Internet Gateway? Aside from the obvious not needing an extra component.
I am already using the gateway for one garage door opener but now need to replace the second bay opener. Trying to see if it makes sense to buy the wifi model for the second door or just use the gateway for both.

What kind of contact sensors are you using? If it’s not seeing the sensors, that’s a SmartThings issue. The SmartApp simply does a check to see what sensors you’ve got that have the contact capability and associates those with the doors you choose.

My guess is they’re basically equivalent. I have a single gateway that runs both my doors. What would be cool is if one wifi opener could also act as gateways for non-wifi doors, but I’m pretty sure that’s not possible.

You’re right - that would be really nice.

Thanks for the confirmation and thanks a lot for the work you’ve done on this.

I was getting the error “Could not find any supported device(s). Please report to author about these devices:”

I found a solution that worked for me. I downloaded the previous version of the MyQ lite smartapp, and that error went away.

To do this, I made sure I was connected to the brbeaird : MyQ Lite Github repo. Then from “My SmartApps” I selected “update from Repo” and selected “SmartThings_MyQ (master)”.

Then I checked the version that was under “Obsolete (updated in GitHub)”. Clicked the “publish” box and hit “Execute”.

That gave me (what I believe is) the older version of the MyQ lite smart-app that no longer gives me the “Could not find supported devices” error. Something must have broken between the two versions.

I have no idea what that did and it definitely sounds like that should NOT have worked, but I’m glad you’re up and running again.

@brbeaird So this got really flaky recently. Yesterday ST stopped communicating with MyQ and my Main Garage Door was stuck in a state of “opening”. I couldn’t remove the device, nor the app even when I attempted from the Web UI.

I walked through the steps as if I was setting things up again and I found a new device listed but my old device was still there.

I don’t want to do anything but it seemed a bit odd. Was some part of the code changed recently?

@mejifair - The code wouldn’t have changed on your end without you doing it. However, I have recently updated the code in the repository to account for some changes MyQ made that has gradually been breaking the integration for people over time.

I would try updating to the newest version of the SmartApp code first and see if that helps.

As for not being able to remove the device, that’s typically because it’s a part of a SmartApp or routine that for some reason it can’t automatically remove itself from. You would probably need to dig around some more to figure out what’s holding on to it. It also may help to view the live logging while you try to remove it.

Thanks - I will take a look.

What are the chances that it will just stop working? Obviously, I know that you don’t actually know the answer to that question…just preparing for whether I will be buying the linear openers for my doors. :slight_smile:

Based on past experience, I’d guess a 60% chance Chamberlain makes a breaking change at least once a year. However, I’d also guess a 95% chance that I’ll be able to make changes on my end to keep things working.

Since what we’re doing isn’t official, there’s always a chance Chamberlain could find a way to shut it down to where we couldn’t reverse-engineer it (although honestly that would take quite a bit of work on their end that hopefully just isn’t worth it for them), but so far we’ve always been able to work around it.

1 Like

Edit: found a different issue-
Edit 2: I honestly thought I had updated from the repo, but I guess not. I updated and not it works.

@brbeaird Brian, I’ve got a new Liftmaster opener, and I can’t get connected. Here’s what the log shows when I try to connect via MyQLite:

8f90325d-a7ce-4565-821d-fd221199b212 5:09:04 PM: debug got login response: groovyx.net.http.HttpResponseDecorator@5df31b4e
8f90325d-a7ce-4565-821d-fd221199b212 5:09:04 PM: debug lightVersion: 1.0.1
8f90325d-a7ce-4565-821d-fd221199b212 5:09:04 PM: debug doorNoSensorVersion: 1.1.1
8f90325d-a7ce-4565-821d-fd221199b212 5:09:04 PM: debug doorVersion: 2.1.2
8f90325d-a7ce-4565-821d-fd221199b212 5:09:04 PM: debug latestVersion: 2.0.3
8f90325d-a7ce-4565-821d-fd221199b212 5:09:04 PM: debug installedVersion: 2.0.1
8f90325d-a7ce-4565-821d-fd221199b212 5:09:04 PM: debug previousVersion: 2.0.1

Any idea what is going on? I’m pretty sure I have it setup just like I had the old opener. FYI, the model is a Liftmaster 8500.

Thanks!

1 Like

So I got everything loaded into the IDE and I can see the MyQ show up when adding as a SmartApp, however my 2 sensors do not show up so I can’t finalize the SmartApp setup process. The 2 sensors are Chamberlain branded sensors that I purchased with the Chamberlain unit. Can these sensors be added? If so can you share some tips? The Chamberlain system works as it should through the Chamberlain app.

From GitHub I am using the MyQ Garage Door Opener handler and have the Momentary Button Tile and Light Controller also installed as the instructions stated. Thanks in advance.

EDIT: Just realized maybe I have the wrong MyQ system? Mine looks like this and I added it to a Genie opener, which I noticed is not listed during the SmartApp setup.

Is it possible to use this code with this opener?