[RELEASE] MyQ Lite Door and Lamp Control (for Liftmaster/Chamberlain)

I’ve ready through most of this long thread (most of last years posts - but brain started getting numb as I worked through 2017).

Not much of it stuck except that I’m consistently very impressed with brbeaird. Awesome in every post!

I’m still unsure which garage door opener to get if I want it to work with smart things. I am limited to getting a “jackshaft” style opener. I think my only options are liftmaster of these models:

8500
3900
3800

I’m willing to get whatever (old model or new or even a different brand if I could find one) so long as it works with smartthings :slight_smile:

I’m not happy with what I’ve heard of MyQ so would love to avoid it - and just get a z-wave controller for it and be done - but if I understand correctly, I will need to use MyQ Lite AND in order for MyQ Lite to work I will need to have full MyQ operation with the MyQ hub in order to get it to work in smart things. Is that correct?

Any suggestions for jackshaft style openers that I can make work easily with smartthings?

Thanks for any help!!! - I’ve held off ordering for a month because I can’t determine for sure what I need.

1 Like

Yes, MyQ needs to be working first before the MyQ Lite SmartApp can integrate with and control it. If you’ve got a choice now, you may want to just go with a non-Chamberlain brand so you can just use a simple Z-Wave controller to open/close it. But if you end up with a MyQ door, this smartapp works great for me.

Thank you for the QUICK reply.

I was afraid you would say that. I would love to go with a non-chamberlain product but they are the only ones with the side mount “jackshaft” openers I’ve found here in the US. I think there is a company called Zap that makes them too but not here and seem expensive. . .

Thanks just the same :0)

PS> just a thought but do you recommend the Zwave opener soldered to a single button liftmaster/chamberlain remote as a reasonable work around? It seems that might work for using smartthings but not using MyQ. . .

Do I need a contact sensor now…I didn’t need one before. The system knows when it’s open and closed…did they shutdown pulling the status down through their API?

From SmartThings, yes, that’s exactly what they did. If you want to do any kind of routine or SmartApp that relies on knowing if the door is open or closed, then you will need a separate contact sensor for ST to know the status.

My App is giving my an “Error!” - Could not find any supported device(s). Please report to author about these devices: []

I’ve been using this App for a few months now, just today it started to malfunction. I’ve deleted/reinstalled the SmartApp and Device Handler. Error still exists.

Could you try renaming the door in your Chamberlain MyQ app? Sometimes that fixes that. Otherwise, we’ll need to dig deeper into the logs to see exactly what information is coming back from their server.

Thank you for the quick response. I’ve just tried your recommendation. Still unsuccessful

Have you gotten this fixed? I’m too having this issue.

The app has been working for months, up until a few days ago. I’ve deleted the SmartApp and Device Handler, reinstalled, and tried to login from ST app. MyQ app, however, works without problems.

I have not. I haven’t had time to try to track it through the logs as the developer suggested.

Update…just ran live logging. This is what I got.

94935796-5fcb-46b1-95a8-a73f78e2ff40 6:49:37 PM: debug got login response: groovyx.net.http.HttpResponseDecorator@335768b8
94935796-5fcb-46b1-95a8-a73f78e2ff40 6:49:37 PM: debug lightVersion: 1.0.1
94935796-5fcb-46b1-95a8-a73f78e2ff40 6:49:37 PM: debug doorNoSensorVersion: 1.1.1
94935796-5fcb-46b1-95a8-a73f78e2ff40 6:49:37 PM: debug doorVersion: 2.1.1
94935796-5fcb-46b1-95a8-a73f78e2ff40 6:49:37 PM: debug latestVersion: 2.0.1
94935796-5fcb-46b1-95a8-a73f78e2ff40 6:49:37 PM: debug installedVersion: 2.0.1
94935796-5fcb-46b1-95a8-a73f78e2ff40 6:49:37 PM: debug previousVersion: 2.0.1

I’m experiencing the same issue. It was just working the other day. I’ve tried renaming the door in Chamberlain App.

Something has changed for some people on the Chamberlain side. The API allows their account to get a token, but it throws an unauthorized error when trying to do anything after that. Mine still works fine, so I can’t do much digging into it at the moment. What we really need is someone with the issue who can look at the network calls going out from their device when using the MyQ app to see what changed for them. If you can find anywhere else on the Internet that has figured this out, let me know.

It’s also possible this is something bigger Chamberlain is gradually rolling out that will eventually hit all of us. We’ll just have to wait and see for now.

1 Like

I found that my IP is being actively blocked by Chamberlain. When I go to https://www.mychamberlain.com/, I get back:

Your request has been denied.
[4251746504170309467]

If I go to the site through a VPN or from another location, I’m able to log in. From the “unknown” IP, I was able to delete and re-add my garage door opener. However, now the MyQ smartapp doesn’t report any devices (as previously reported above). Do the requests to the MyQ API go out over the cloud or using the hub’s local IP? The blocked access from my IP is very suspect, but could just be coincidental?

Does this mean the native MyQ Chamberlain app doesn’t work from your phone while on your home wifi?

They go out from the SmartThings cloud, so your IP shouldn’t be involved with this at all. I really wish I could see some packet traces from the MyQ app from someone who is having this issue.

TBH, I never used the native app. However, I would definitely like to assist if possible. What would I need to do in order to get packet traces from the MyQ app on the device? Would I need to run software on another computer and intercept them or is there something within Android (either system app or third party) which would let me capture them. I should have some free time over the weekend to do this if you can just point me in the right direction to get the info you need.

Basically, I need to know what the native app is doing differently than what I’ve written the SmartApp to do. I think the only way to do it will be from the Android device itself. I’ve not done this myself, so I’m not exactly sure of the best way to do it. You’ll need some sort of packet capture app (not sure if this is possible on an unrooted phone). That app needs to be running while you open up the MyQ native app, and it will log everything that happens. If you can manage to get some logs from that, send them my way, and I’ll take a look.

I am also hit by this issue.

@brbeaird, I tried a few different programs to capture packets on Android without root. One was able to filter by app (to limit packets to the MyQ app only), but that one didn’t seem to work. I found another that captures ALL packets and saves it to a pcap file. Would that be a useful format for you?

Yes, I can make that work. Make sure you have it set to decrypt ssl if you
have that option.

The issue has finally hit my account. I can get a token from the API but get an unauthorized error trying to do anything with it.

The upside to this could be that it starts to affect the other MyQ integrations people have built around the Internet and someone on one of those forums/repositories figures it out faster than I can. I’ll try to get my hands on an Android device I can use to do some packet captures of my own, but that could take awhile. If anyone else has any luck figuring out what changed or finds another place out there that figures it out, let me know.