[RELEASE] MyQ Lite Door and Lamp Control (for Liftmaster/Chamberlain)

did you also install the required Device Handlers in addition to the smartapp you installed for MyQ Lite in IDE?

That typically means something didn’t quite go correctly with the device type handler installation. A fresh install and/or manually copy/pasting the code over normally fixes it.

Thanks for the pointer, I had just installed the switch handler and not the full device handler. It is done now and works. Thanks again!

works perfectly! thanks so much to the author!

1 Like

I am having a tough time trying to figure out why my smartthings switch wont open/close the garage door. The garage door sensor works great and tested it. I just updated the MyQ smartapp from github. Any ideas what to check? I also checked via MyQ native app and the open/close works quick and great there.



in the first image you posted… the DoorDevice is not up-to-date :slight_smile:

Thanks yeah wrong screenshot it’s updated but still same behavior

try clicking on Tap to modify devices and go through the setup - next, (check that contact sensor is selected) - next, done!

What happens in live logging in the IDE when you click open or close?

1 Like

Sorry if this is not the correct place to post, move if needed.

I am wondering what others plan to do to automate their MyQ garage doors when groovy ends and we loose this amazing Smartapp. I’d like to figure something out ahead of time.

I have seen many people modify their remote and it looks like garadget now sells them as well

These look like they are setup for connection to a dry contact relay. If so, local zwave support would be an option.

As much as I’d like to have some alternative figured out beforehand, I doubt I’ll find the time or will to do anything before this one is totally broken. I have played around with the new API enough to have a general idea of how it would work, but it would mean self-hosting a piece of the logic, which is something a think a lot of people are not going to want to deal with. Still, one way or another I plan to have some kind of solution and will share it whenever it comes to that.

2 Likes

I don’t see any way to pull it off with edge directly. There is another project where someone has created a REST forwarding service that allows edge drivers to communicate with the outside world, but it requires installing a Raspberry PI device into your network that does the forwarding. The best bet looks like it would be the SmartThings Schema integration for Cloud-to-Cloud setups.

No, Edge is limited to device drivers and is not intended to handle web callouts. I believe the intended method would be to use the new SmartApp API.

This particular app would not be technically cloud-to-cloud because it wouldn’t be SmartThings connecting directly to MyQ. It would be a self-hosted SmartApp that connects to MyQ and handles the commands.

I too am running into this same issue.

Seems the only way to have the google home recognize the ST door is to set it up as a door opener with sensor. Selecting the type as no sensor doesn’t wont show up in google home.

When i set it up with sensor i can long press the garage door and open and close it as on/off. however the ST app keeps showing up as door open and wont timeout or anything so an error always presents itself in the ST app. it’s not a huge show stopper as i only use the google app for my commands, would the only way to fix this is to buy a sensor and connect it to the door?

Hello- New to all these smart integrations so bear with me please.

I cannot seem to get my tilt sensor to associate with the MyQ Lite app.

I have installed the device handlers (both sensor and non-sensor versions). Then added the tit sensor after. If I open the MyQ Lite app and follow the directions. I can use my MyQ credentials and open my door but theres no sensor listed. Thie last part from the instructions doesn’t happen for me:

Enter in your login details and pick your gateway brand. If login is successful, you’ll see a list of doors available for you to pick. ***

After you choose your doors, you can select optional sensors to be tied to those doors

.*

I recently removed the handler and republished it and opened the app but still no change change.

Do I need to do the same with the app?

Any suggestions appreciated.

More info here on my issues. Sorry if I’m not supposed to link other threads…

Do you see this page when opening the smartapp?

Click tap to modify devices which brings up your door

Either select your door or click next if already selected to open this page where you can select your tilt sensor

@brbeaird My whole SmartThings setup got hosed last week during the upgrade and I’m trying to reinstall things now. I had the MyQ Lite working just fine before then, but it stopped.

I’ve updated the SmartApp and drivers to the latest version (honestly I think I had them already). However, now I cannot authenticate through the SmartApp. I’m logged into the actual MyQ app just fine, and have tried re-logging in to ensure my credentials are correct, and they are.

But, they don’t work for MyQ Lite. I get, “Error! The username or password you entered is incorrect. Try again.” No…it’s not.

Suggestions?

Hard to say exactly what’s going on. You could check the IDE logs when you try to log in to see if there are more details. You can also try to download the separate auth token app (see GitHub details) and see if it you can get a token that way. It’s possible something is weird with your MyQ account?