[RELEASE] MyQ Lite Door and Lamp Control (for Liftmaster/Chamberlain)

I thought so, too, but the Update from Repo didn’t show any Obselete items. I then proceeded to delete the DH and re-add it. Still the error.

Did you tap to modify your devices in the MyQ smartapp?

@jkp , yes, I even deleted and re-added my Garage Door device a number of times. I did not delete the virtual sensor device as it’s still reporting back from MyQ correctly.

You may try manually copy/pasting the latest app and handler code just to be sure. That error indicates an outdated “sendCommand” method call is being made by your device handler. That method has been replaced by a sendDoorCommand method that takes in an extra parameter (myQAccountId).

I’m using the “Create Garage doors as door locks” option, which uses the myq-lock-door.groovy code that looks like it hasn’t been updated in 2 years. Could that be the reason for the error?

Well, my Internet fiber got cut today with a lawn aerator. The interesting thing is I noticed with my home Internet down, the MyQ command response to this SmartApp was an explicit status 403. I dug into it a bit and realized MyQ now responds if it detects your MyQ device (or hub) is down.

With this in mind, I pushed a small SmartApp update today:

  • Fixed issue where token refresh was happening too frequently instead of reusing the existing access_token for its lifetime.
  • Improved error messaging for when MyQ commands fail. You will now get the detailed error message directly from MyQ (ex: “Command failed because hub is offline”).
2 Likes

Ah yeah, that’s definitely not working currently. I’ll see if I can find some time to look at that again now that I better understand the new custom device type handlers.

OK, thanks. I like to use the lock option so that I can ask Alexa to lock the garage door, but I’ll use the other option for now.

1 Like

I’m still a little lost (keep in mind that I’ve not, previously, had my opener paired with ST, so this is “from scratch”). I installed the smartapp and the five device handlers. I got my oauth token and pasted it into the settings, but, when I try to create a device, it doesn’t seem to matter which DTH I use, none of them reflect the state of the door nor do they actuate the door.

Additionally, it’s not clear to me which DTH I should be using. The readme on the github repo talks about whether you have a third-party tilt sensor, and that the MyQ-included tilt sensor doesn’t talk to anything the DTH can interact with. However, my opener has an integrated position sensor. My MyQ app knows the position of my door, even though I’ve never had to stick any separate tilt/contact sensor on the door. So… which DTH do I use to read that?

I just updated from the repo. Do I need to step through the app on my phone in order for the new code to be functional?
Thanks!

I tried to write it in a way that it should work without doing that, but if you run into trouble, it’s worth giving that a shot.

@brbeaird, I noticed that you updated the smartapp and the lock DH. Perhaps they’re not finished. I published them and now I don’t get the error (good!), but the Garage Door device is created as a sensor, not a lock, so I’m guessing you’re still working on it.

Yeah, lock handler is not ready and may take several days before I find some time to play with it.

1 Like

True, most MyQ doors now have integrated sensors. However, there is no practical way for SmartThings to get the status of the door from MyQ itself. Doing so would require some kind of periodic polling to MyQ, which was explicitly forbidden year ago (and is why this SmartApp was spun off to begin with).

Your are then left with two options:

  1. Use the no-sensor handler
  2. Get a SmartThings-linked sensor and then use the sensor handler

So I have everything working on the SmartThings side, however, when I try to use the “Works with Google” feature in Google home, and select SmartThings, it says no devices found. They do show up in the SmartThings app though? Any idea why Google is not seeing them in the SmartThings app?

Make sure you add the Google Home in your SmartThings app first. Then add in Google home app. However, be aware that the garage door (including MyQ) will not work with Google home voice commands for security reasons (Google decided this).

OK. I got mine working. I’ll list the steps I did, since I couldn’t find them while googling and scrolling (so they might be years back in this thread, so it might be worth restating them).

I had connected to the github repo and installed the Smartapp and the DTH’s and published them to myself. I added the API key to the smartapp, and I thought that was all I had to do with the smartapp, so I just tried manually adding a device with the DTH… which, of course, didn’t work.

What I discovered I had to do is:

  1. On my phone, go to my Smartapps and use the Community Installer to install the MyQ Lite smartapp (so, I had to pull and publish it in the IDE, but I had to install it on my phone)
  2. From there, I was able to run the MyQ Lite smartapp and, from there, either use the API key or the login/password option.
  3. From there, I was able to see my garage door (as reported by the Chamberlain site) and also select the tilt sensor.

Funny thing… my main reason for wanting to connect my garage door was to be able to use WebCore or IFTTT to query it to alert me if it had been left open. Turned out that this app can’t really poll the opener, itself, so I had to buy a tilt sensor. Now that I have it all working, I just realized that I could have just bought the tilt sensor, in the first place, and avoided all of the pairing of my opener with Smartthings. :laughing:

1 Like

I’m trying to update it … my smartapps updated fine …but I can’t get the device handlers to update … I get this error in the IDE:

Oh No! Something Went Wrong!

Error

500: Internal Server Error

URI

/ide/device/doRepoUpdates

Reference Id

91185d57-8b8e-4376-a594-c6c0688c6511

Date

Wed Oct 13 16:30:59 UTC 2021

Try in an Incognito/private browser tab/window. The issue you have has been seen a lot and comes and goes.

I wonder if it could be related to another issue currently being seen by some users with the app