[RELEASE] MyQ Lite Door and Lamp Control (for Liftmaster/Chamberlain)

The SmartApp always gives you the option to select a sensor. Whether or not you choose one determines which device handler it uses, which means it also works to switch back and forth if you ever need to.

The virtual switch issue is still confusing to me. I can’t reproduce it, and they work fine for me. So odd.

does anyone know how to create the token using a chrome book. i tried following the steps but im getting an error so i cant even get started getting the token info

YouTube has a few videos on how to open a .exe file on Chromebook.

I don’t think the compiled utilities will work on a Chromebook, but you could try this:

  1. Download and install NodeJs
  2. Download package.json and app.js from the SmartThings_MyQ GitHub repository
  3. Open a terminal window to where you downloaded the above
  4. Run npm install
  5. Run node app.js

thanks ill try that. otherwise ill have to wait till i to a windows computer

both of those files you listed package.json and app,js dont have download buttons. all i can do is just copy the and paste the file.

Correct - you can either manually copy/paste into files and rename them or you could also click the green Code → Download Zip button at the top-level of the GitHub repo and just download everything at once.

I tried what you said above on Windows 7, and yes indeed that works!
You are a very smart man Brian.
Thanks,
Scott

1 Like

Thank you so much for your support and help! A+

I see an update for DTH is just a minor update?

I followed all steps but still getting this error in IDE, anyone seen this:?
“java.lang.NullPointerException: Cannot get property ‘accountId’ on null object @line 1044 (getDefaultAccountId)”

error java.lang.NullPointerException: Cannot get property ‘date’ on null object @line 155 (calculateAndShowEnergy)

I’m stuck at “warning: myq command failed for - groovyx.net.http.HttpResponseException: Not Found” when trying to open my door…
updated everything again, token refreshed and loaded…

OK - I installed the token, and the app states: “Token Loaded. (not yet refreshed)”. When I click to modify devices I get and Error! Login error: null.

Do I need to wait for some refresh on the back end or do i manually trigger this somehow?

I too am having this exact same problem.

My guess is something did not work quite right with your token. I’d try generating another, putting it in the app setting, and try the whole thing again.

Something in either the SmartApp or DTH update didn’t fully take. Have you tried the raw copy/paste method to update both of those?

You probably checked this, but up above someone said they accidentally got an extra space in their token.

If you keep hitting issues with token generation, sit tight. I may have another solution that actually brings the whole thing back into the SmartApp so we can avoid it altogether. Will be another few days probably.

2 Likes