SmartThings Community

[RELEASE] MyQ Lite Door and Lamp Control (for Liftmaster/Chamberlain)

smartapp_garage
(Brian) #404

I was wondering when someone would ask about this. I think in theory it probably would work just fine. Unfortunately, I don’t have one to test with, which makes coding for it quite tricky. If anyone has an extra MyQ lamp control they could send me, I would definitely give it a shot. I’d even send it back once everything is all working.

0 Likes

(Sticky) #405

Too bad I only got 1 lamp and 1 wall switch that I need. If there are things that I can help in other ways to copy codes or run tests, please let me know.

FYI, I just tried following this instruction http://imgur.com/a/tG6Ng
using Restful API app + Tasker on Android, and I’m able to open and close my door.

However, using the same method to look for the deviceID for my lamp/switch modules, and then pasting the deviceID as if it is a door, and issuing the command in Tasker failed.

0 Likes

#406

I have a craftsman gdo with an assurelink gateway. How where you able to link the assurelink cloud account with the myq account so this would work with smartthings? From what else i have read i need a myq gateway connected to my craftsman gdo in order to use with smartthings but would love to save the money if i can use my existing hardware.

0 Likes

(Brian) #407

I’ll keep an eye out for a cheap lamp module on ebay. Would be a fun little project to get this working for those devices again. The original copy-ninja code for it should give me a good start, but I’ll still need to work it into the new setup flow and pull out the old polling stuff. It might take me several weeks to get to it, but I’ll let you know whenever I do.

0 Likes

(Savio) #408

Thanks so much for such an excellent application and your hard work! Works great. I was wondering if there was a way as well to have google home “read” me the status of the garage door if it’s opened or closed if I have a tilt sensor enabled?

Thanks!

0 Likes

(Brian) #409

Not that I know of. The closest thing I’ve seen is the Ask Alexa SmartApp, but that will only work with Echos, obviously.

0 Likes

(Joseph Allen) #410

Hello,
I seem to be having problems with all this. I got the app installed with the deices, but it’s not working. First thing odd that I notice is it says I have 2 garage door openers under my MyQ account, I only have 1. If I select one, and set it up using one of my ST Multi-sensors everythings seems to configure fine, but if I try to open the door, it does nothing. I’ve tried using both garage doors listed, but still not working. Have any idea what my problem is?
I look at the LiveLogging and this is what I see…

    10:31:40 AM: debug Door: Garage Door Opener: Updating timestamp to: Thu Jan 05 15:14:10 UTC 2017 - from sensor Garage Door Sensor
10:31:40 AM: debug Door: Garage Door Opener: Updating timestamp to: Thu Jan 05 15:14:10 UTC 2017 - from sensor Garage Door Sensor
10:31:40 AM: debug Door: Garage Door Opener: Updating with status - inactive - from sensor Garage Door Sensor
10:31:40 AM: debug Door: Garage Door Opener: Updating with status - inactive - from sensor Garage Door Sensor
10:31:40 AM: debug Door: Garage Door Opener: Updating with status - closed - from sensor Garage Door Sensor
10:31:40 AM: debug Door: Garage Door Opener: Updating with status - closed - from sensor Garage Door Sensor
10:31:39 AM: debug refresh called from Garage Door Opener (931d8db7-4cad-4679-b7a7-0a54c13cb6f3|GarageDoorOpener|1746474)
10:31:40 AM: debug Door is now closed
10:31:40 AM: debug Request received to update door status to : closed
10:31:26 AM: debug InfluxDB: handleEvent(): Christmas Tree(power:null) 169.2
10:31:19 AM: debug Request received to update door status to : opening
10:31:19 AM: debug got login response: groovyx.net.http.HttpResponseDecorator@6a1be8b0
0 Likes

(Brian) #411

That’s really weird. And the door responds correctly if you open/close it via the MyQ app? What door brand is it? I have seen where the SmartThings app will think you have two doors - mine does this as well, and it’s just how MyQ returns the door info in the webservice call; it returns multiple entries for some reason, and there’s no obvious way to tell which one is the right one.

Do you have any experience using Postman or other webservice tools? Only thing I could think would be there’s something different about the way ST needs to be sending the command to your door.

0 Likes

(Joseph Allen) #412

So I kept playing around with it, and I found that if I select both the garage door openers and configure them with the same sensor, one of them will work. I then removed the one that wasn’t working and I the other one still works.

I’m a developer, so yes I have some experience with postman.

My guess is the 2 doors being returned from the MyQ service are not being returned in the same order when I configure it. So I may have been configuring the one that wasn’t working. When I configured both, I found the working one. I’ll keep poking around with it.

0 Likes

(Kevin Gibson) #413

The same author of Alexa Helper wrote a Google Home helper check it out.

1 Like

(Joseph Allen) #414

So I poked around in postman and sent the REST call to get the device list, and I saw what you were describing. 2 VGDO both looking like the same thing, with different IDs and no way to tell them apart.
I then went into the MyQ app, and changed the name of my “Garage Door Opener” to “My Garage Door Opener”. I re-ran the GET and I now see 2 VGDOs, one with the old name, and one with the new name.

I’m not sure if this is a design thing from MyQ to have 2 VGDOs, or maybe at one point in time I added the MyQ device, removed it, then added it anew and the MyQ app keeps a history.

Either way, changing the name of the device in the MyQ app makes it identifiable in the MyQ Lite app.

1 Like

(Brian) #415

Ah nice. I’ve suspected the same thing with mine thinking one of them was just a defunct old version I had added at some point. It’s super annoying they don’t put an inactive flag or something to let me know which one is legit. If you do figure out a way to tell them apart, let me know, and I’ll add that handling to the SmartApp code.

0 Likes

(Joseph Allen) #416

I threw the 2 device results in Notepadd++ and ran the compare plugin on them, and I think you might be able to implement a fix. I found the UpdatedDate to be a distinguishable value. I would do some comparisons like this:

  1. Check to see if there is more than 1 device with the same name
  2. Compare the “doorstate” “UpdatedDate” of the 2 devices, and use the most recent.

With mine, the old VGDO has an UpdatedDate of 2015-08…
If you have 2 devices with the same name, you probably want the most recently used.

0 Likes

(Brian) #417

Ooh, very interesting. I think you’re on to something. With the two entries I have, the working one’s DoorState date is today, and the defunct one is from 4 months ago. I’ll get this filter into the code when I get a chance. Thanks so much!

0 Likes

(Ken ) #418

I set up and registered a myQ account with no devices. I set up the login and pw for both the Assurelink and MyQ account to be the same. Then when I utilized the downloaded apps I set the link to be Craftsman and it works… I am not sure I know how or why but it does.

An interesting and confusing sidenote- I can open and close the door using the Garage Door Opener Open and Close “push” buttons listed in the My Home Things section of the app. But, using geofencing (which does recogognize my phone has arrived back home) the commands do not work. Fun-fun-fun.

0 Likes

#419

I have an Extra Liftmaster 825LM lamp control module, If you want it for programming. Just message me your address. My thanks for creating the MyQ Lite program.

0 Likes

#420

I was having the same problem with the Multipurpose sensor in garage door mode. I moved it all over the garage door, trying to get it consistent. Even playing with it in my hand tilting it, it was not consistent. I finally gave up on using it in garage door mode and changed it back to a regular contact switch. It works perfect as a contact switch. The only down side is that is shows closed to open right away as the door is going up. I would rather have it that way, than not have a consistent change in state. I guess the accelerometer is not as reliable as a tilt switch.

0 Likes

(Brian) #421

Sweeeeet. Address sent. I’ll see what I can do to get it integrated with this.

0 Likes

(Brian) #422

How exactly are you triggering the commands with geofencing? Is this happening in an “I’m back” routine? If so, are you using the “Open the garage door” option?

0 Likes

(Ken ) #423

Yes- I created an “arriving home” routine. Under the option to open or close garage doors I have it set to “Open Garage Door Opener” and then on the pull out menu the action is Open.

In the notifications section it says: Ken’s iphone has arrived and then “arriving home” was executed but nothing actually has occurred. My next step was going to be adding a light to turn on/off for testing.

Other ideas?

Thanks

0 Likes