[RELEASE] MyQ Lite Door and Lamp Control (for Liftmaster/Chamberlain)

This is why I came here this morning. So the Monoprice sensors do work?

I know that the garage door one works great, been using it for months. Just ordered some of the door contact closures to test also for less then $20 each with the sale and discount code.

1 Like

Brilliant app. Thanks for all the hard work. One thing I am trying to figure out is why I am receiving frequent notifications from the garage door opener that it is closed. I’m using the smartthings multisensor as a tilt sensor, which isn’t giving me any problems. However, the garage door opener itself (device) keeps notifying me that it is closed every so often, despite the fact that it has remained closed. I would expect if the door closes it would report as such and then not notify me again unless the status changes… any thoughts ? Thanks!

1 Like

I see references here to a solution to make Smartthings and MyQ work together, but I can’t find the post they’re referring to with the solution. Can someone direct me there? Or is anyone interested in doing it for me for a fee?

Read this in regards to integrating MyQ with ST:

1 Like

If anyone’s interested - I was playing around with a solution that doesn’t require any additional sensors, but requires you to run node server locally. Tested so far on my mac only, but will be testing this on raspberry pi later. Running node server on mac works fine so far however - able to control and poll for updates for multiple MyQ garage doors and switches in my house just fine.

Here’s the link - https://github.com/aromka/myqcontroller

7 Likes

For clarity, the tilt sensor that came with the MyQ hub can’t be used and you have to have extra sensors that register directly with ST hub? Apologies if this had been answered previously I’m still weeding through comments :slight_smile:

That’s correct. The MyQ tilt sensor only communicates with their hub, unfortunately.

Much appreciated thanks Brian. Now to see if I can find anything in Canada lol

Preston, I am here to say that the monoprice sensor works beautifully
I loaded both the smart app and the device handler.

The world is good.

I tried installing the node but I get these errors, any input is appreciated:

43 error Darwin 15.6.0
44 error argv “/usr/local/bin/node” “/usr/local/bin/npm” “install” "myqcontroller"
45 error node v6.7.0
46 error npm v3.10.3
47 error code ENOSELF
48 error Refusing to install myqcontroller as a dependency of itself
49 error If you need help, you may report this error at:
49 error https://github.com/npm/npm/issues
50 verbose exit [ 1, true ]

Tom, I ordered them and now have them installed. Yes the world is good, or at least as good as it used to be. :slight_smile: Very happy with the MyQ Lite app in conjunction with Alexa Helper I’m happy again. Thanks much!

Well I managed to install the node by editing the name in package.json to “myqcontroller-test”. Now I face another error when I run the server.

myq.js had too many unstable restarts (16). Stopped. “errored”

Do you know what could be causing this? I’m using pm2 to start the server.

I got it to work, gotta say it was painfully hard to figure out that node stuff. But now that everything is up and running, I wanna say thank you for your awesome app. I didn’t even have to buy any sensors.

I updated the instructions last night how to install it - should be more clear hopefully now. :slight_smile:
Glad its now working for you.

Just set this up and it’s working great so far. I already had a node proxy server running for my Honeywell alarm/Envisalink IP module so the setup went smoothly. Currently running both servers on a Synology NAS.

Just skimmed the code and it looks like you’re polling the API every 5 seconds as an iOS 9.3 device. Aren’t you worried that this will eventually get blocked?

It’s using your local IP address, same as you would be using their official app on your phone. It can get blocked eventually I guess, but there are bunch of unofficial integrations that use the same method (i.e. multiple node modules for homebridge), as well as myq’s official app is using the same APIs I’m pretty sure. But hopefully it’ll last until we get an official integration with ST. :slight_smile:

Did I miss something? Getting a weird error after running the server:

=== === === MyQ Controller === === ===
[08/10 18:04:39] Retrieved config for server: 192.168.1.105:39500
[08/10 18:04:39] Done.
[08/10 18:04:47] Handling request for: /ping
[08/10 18:04:47] Getting ping… replying pong
[08/10 18:04:51] Handling request for: /init
[08/10 18:04:51] Received init request
[08/10 18:04:51] Initializing…
[08/10 18:04:51] Error reading device list: SyntaxError: Unexpected token < in JSON at position 0
[08/10 18:04:51] Refreshing security tokens…
[08/10 18:04:52] Handling request for: /init
[08/10 18:04:52] Received init request
[08/10 18:04:52] Initializing…
[08/10 18:04:52] Error reading device list: SyntaxError: Unexpected token < in JSON at position 0
[08/10 18:04:52] Refreshing security tokens…

Interesting. Looks like the response that’s coming from chamberlain server is not in proper json format … or maybe server error or something. Can you add some debugging to see what’s coming?

Open server/service/myq.js file, and after line 90 ( where you see “if (body) {” ) - add:

console.log(body);

so it would be:

if (body) {
    console.log(body);
    try {

so that you can see in console what message is getting returned when trying to get devices.

ahh… didn’t try debugging but I got it to work. Realized I had a VPN running. Disabling the VPN got it going. Thanks for deving!! :smiley: