[RELEASE] MyQ Lite Door and Lamp Control (for Liftmaster/Chamberlain)

This will only show up on the sensor version of the door, so you’d have to have associated a separate tilt sensor already (which is named just to the left of the battery value). You’re correct this app cannot read any part of the MyQ sensors.

Fair point. I went ahead and made a change to default it to 100% if no battery value is found so at least it won’t be empty dashes. Unfortunately, there’s no good way to conditionally set it to “N/A” or hide it altogether.

Right, I’m using the sensor version of the door with a virtual contact sensor and IFTT to change the virtual sensor status. I was thinking you could also make a user configurable option on the device (click the gear in ST classic) and choose to have the battery display on or off. Just a thought.

That would be nice, but SmartThings is not set up such that those tiles can be conditionally displayed. It’s basically just metadata that then gets data populated into it - no way to hide it depending on the data (or options) on the fly.

That is awesome!! Thanks!!

Are we required to do the update if we don’t have the sensor version?

I had the same issue - what fixed it for me was making sure I updated the code on both SmartApps AND Device Handlers. The one I somehow missed was Device Handlers. Might not be the same issue but wanted to offer it up, just in case.

Can someone help me figure out how to update? This is a side hobby for me and I know just enough to be dangerous.

1 Like

After years of success, my good luck has finally come to end. I’ve removed rebooted, and pulled down the latest myq smart handler and smart app. After loosing nest I can’t loose myq as well. Below are some live log outputs…so far myq just stopped.

From the device handler:


96ab4412-374d-4d23-ba80-9d683ec2dec7
10:05:54 AM:error groovy.lang.MissingMethodException: No signature of method: script_app_dc6c4ac7dab3b1b43fda8582dad47d6e86c8fb71968476cfced04d91a5860143.sendCommand() is applicable for argument types: (script_dth_e33456448551cdab982f17b93e7e537c8244f6a50ea7799d8799a680caf4d06f, java.lang.String, java.lang.Integer) values: [script_dth_e33456448551cdab982f17b93e7e537c8244f6a50ea7799d8799a680caf4d06f@b4e3b1c, …]
Possible solutions: sendCommand(java.lang.Object, java.lang.Object) @line 128 (close)

96ab4412-374d-4d23-ba80-9d683ec2dec7 10:05:54 AM:debug Garage door close command called.

96ab4412-374d-4d23-ba80-9d683ec2dec7 10:05:54 AM:debug Garage door close command called.

96ab4412-374d-4d23-ba80-9d683ec2dec7 10:05:53 AM:error groovy.lang.MissingMethodException: No signature of method: script_dth_e33456448551cdab982f17b93e7e537c8244f6a50ea7799d8799a680caf4d06f.getMyQDeviceId() is applicable for argument types: () values:
Possible solutions: getDevice() @line 808 (refresh)

96ab4412-374d-4d23-ba80-9d683ec2dec7 10:05:52 AM:error groovy.lang.MissingMethodException: No

From SmartApp:

fbead50a-64c9-4fde-a5a3-d33696b04e17 10:08:21 AM: debug GenerateEvent returned {{ linkText }} has arrived

fbead50a-64c9-4fde-a5a3-d33696b04e17 10:08:21 AM: debug description: presence: 1

96ab4412-374d-4d23-ba80-9d683ec2dec7 10:08:19 AM: error groovy.lang.MissingMethodException: No signature of method: script_app_dc6c4ac7dab3b1b43fda8582dad47d6e86c8fb71968476cfced04d91a5860143.sendCommand() is applicable for argument types:

Yes - the underlying API was updated, which affects all installs.

Check out the instructions on the GitHub link. I’d suggest reading down link to the Community Installer method as that’s the easiest way to keep things up to date.

Those errors indicate your updates to the device handler code didn’t take. Try to force that to update and publish again.

Anyone still having issues connecting smartthings to myqlite?
I’ve had it working for a year now and updated with latest version from github. I’m using the myq-garage-door-opener.src for the dh and myqlite smartapp both version 3.1.1

I keep on getting this in the logs when I try to login
warn API POST Error: groovyx.net.http.HttpResponseException: Unauthorized
warn forceLogin: Refreshing login token
debug login result next page: prefListDevices

I even try to delete the device and reinstall, but no luck. Am I missing anything?

I’ve double checked the password and tried simple password in case the special characters were causing issues, but no luck.

Thanks.

That error actually seems to indicate the SmartApp did not truly update to 3.1. What does the SmartApp main screen show down under the app and handler version section?

When I try to add the MyQ Lite smartapp it immediately prompts for the login credentials so I’m unable go to the main screen of MyQ Lite app to verify the version. I’ve gone into the Smartthings IDE and verified the version in the raw code of both smartapp and device handler is 3.1.1. And I previously had deleted the smartapp and device handler and imported from github to make sure I had the latest version.

Thanks for the help and the quick reply.

Has anybody ever had this problem…sometimes my girlfriends garage door will open on its own sometimes. I have a piston in webcore to open it when her presence is home, and it works as expected but then it randomly opens. I checked the activity on her sensor and it’s not like the presence ever shows her leaving then coming back home. So I’m confused what would cause it to randomly open sometimes. Obviously this could be a problem if it happens randomly while we are sleeping and cause a security risk. Any insight is greatly appreciated

You may want to post this as a webcore question on the webcore forum. I’d also recommend posting an image of that piston (using the green camera icon above the piston) along with some of the piston logs if you have them turned on because they can provide lots of details. There may be a better way to write the piston to prevent the garage opening at times when you don’t want it to. Or at least create another piston to watch for such activity and take action, whether that is closing the door or notifying you in a manner that will get your attention. :slight_smile:

I am curious when you wrote “to open it when her presence is home”. did you set it up to open when her presence changes to present OR when she is present?

1 Like

yeah, you’re right just thought maybe somebody on here had this issue, and is changes to present

Sir-
I had started a thread in another category so bear with me. I got bit by the Chamberlin API change and updated the MyQ app and handler in the IDE. I was hoping this would fix the Smartthings integration.
I updated the MyQ Smartapp but I have a problem that probably isn’t related to needing an update as this happened before I updated. I cannot put my username and password into the app anymore. I removed the SmartApp and I am attempting to add it back in and username or password error occurs. I worked with Chamberlin support to be sure I could log into their MyQ website okay, which I can. But the app is acting like the credentials are wrong. I am currently not at home on my network, can that be an issue? I am remote.

?? This all worked before.

1 Like

Seems like it’s rejecting your account for some reason. What kind of door do you have? If you’d like to PM me a temporary username/password for your MyQ account, I could take a look at the API response.

Do you by chance have a Craftsman door? I know there was a change where those users need to transition over to MyQ accounts. Are you able to login ok on the native MyQ mobile app?

Thank for the quick reply!

No, I do have a Chamberlain door. Here
Is the strange part, and may take a while. I noticed there are 2 different myQ websites. I was able to log into one of them and I did a mental note of password. I tried this pw in the Smartapp and it failed. I tried this password in the myQ app and it failed. I tried one of my variations of this password in the myQ app and it worked. Did not work in the Smartapp, no password variation worked.
Also, when I was updating I saw the Smartapp in the obsolete column, and there was still a mismatch on ide and repository versions. I am slightly confused on how the IDE github stuff works. But I did get the local and repository versions to match and still no love. I was thinking of totally removing it-clean, and reloading the app with GitHub or do it manually. I tried loading the community installer but don’t see it in my apps on iPhone. Also note I do not see anything in the logging part of IDE, no errors.

A good reason I installed a new garage door and opener is so I can automate it. It’s a little frustrating right now. Thanks for listening.

Mine did that a few times and then the physical wall switch failed. Replaced it and have not had that issue again. I have to assume it (mine) was hardware related.

Since, I also setup alerts (using webCoRE) to let me know if it opens and I’m not home.