[RELEASE] MyQ Lite Door and Lamp Control (for Liftmaster/Chamberlain)

I’m glad things are working for you! If you’d like, you can check out the donation links at the bottom of the GitHub page.

This worked for me. Thanks!

Just wanted to post that @brbeaird is the best.

3 Likes

Thanks very much @brbeaird!

I’m new to smartThings as I just moved over my devices from Wink. Is their a You Tube video on how to add apps to SmartThings. I too have the MyQ door opener,

The only YouTube video I have ever seen for installing custom apps or device handlers is the for the webcore installation. Possible there could be others and hopefully others can point them out.

There is a faq page you can read with lots of good details…

Here is the webcore installation video I mentioned…

Hope this helps!

1 Like

Thanks for your work on this. I am hoping we can get the light module working again. If there is any way that i can assist in getting info for you on the lights just let me know

thanks

Good news on the lamp modules! I just pushed an update to the light device handler that should get those working again, too.

I ended up grabbing the Android apk and (mostly) decompiling it. After stumbling through it long enough, I eventually found the magic text “turnon” and “turnoff.” So simple, but I never would have thought to try that.

2 Likes

** Just ignore my previous question**

PS. Thank you for continuing to support this app!

1 Like

Thank you Brian for all the hours you put in supporting this app. I know it’s not much, but I recently made a contribution to your paypal account to show you my appreciation.

I believe I’m fully updated as of a few minutes ago and I think I’m able to authenticate to MyQ in the classic app and in the native iOS app, however, I still can’t get any open or close functionality to work. I have a separate sensor and, notably, the status works great. I also see that the gateway type is now “null”… that’s the only anomaly I can find, is that diagnostically meaningful? Anything else I can do to get back to working state (happy and stable user for years, here, up until 6 days ago!). Gracias!

Hi, I’ve been using the MyQ device handler ( myq-garage-door-opener-nosensor.src) which I manually updated from github (it wasnt avail through the repo update.)

Ive initialized and updated the door IDs accordingly.
Its is very sporadic. It opens the door approx 1 of 5 times.
I am getting the following error in my logs

Executed [Garage Door1 Opener].push (28ms)
+195ms Error while executing physical command Garage Door1 Opener.push([]): org.hibernate.LazyInitializationException: could not initialize proxy - no Session

I am getting same error message when I select “push()” or “on()” command…I try both

@brbeaird, What could be the cause?

Where are you seeing that? Also, do you get any errors in the log when you try opening and closing? When you ran through the MyQ device setup in the SmartApp after updating, did it pick up your existing doors or did it create new ones?

Did you also manually update the SmartApp code? I’ve never seen that error before - it almost seems like it could have been a temporary SmartThings connectivity issue.

Hi,

Yes I did update the SmartApp manually as well.

I believe I solved the problem by NOT using the optional “Create on/off push buttons” (which I’ve been using for more than a year with the prev version)

I am now using the Garage Door device itself in webCoRE and it seems to work reliably…that solves most of my problems. (using Open/Close commands instead of Push for the buttons)

However, regular ST routines (such as Good Night where all locks lock and doors close) does not work if I select “Close Garage Door”

I did not try the Advanced Option to “create garage doors as door locks”, maybe that would work with standard ST routines, but I’m afraid it will mess up my webCoRE pistons,.

BTW: Thank you for this update. It’s amazing how much havoc it causes when it stops working. I have been taking this tool for granted for over a year. THANKS @brbeaird

Ok, yes, so there’s a known issue with updating where the app will NOT be able to convert your existing push buttons, and the old buttons will no longer work. If you tap through the process, it actually ends up creating two NEW momentary button devices, so you would just need to switch your automations over to those. I need to find a better way to associate the buttons with their doors - I’ll fix that at some point.

Short answer: the push buttons should work again if you tap through the “Modify Devices” setup flow and get them recreated.

On a related note: I assume based on your setup that you are not using separate sensors on your door. The downside of this is that Open/Close commands will not work with ST routines. This is because SmartThings does not know the status of the door and thus will not actually send those commands if it thinks the door may already be open or closed. You can get around it with WebCORE, but native routines won’t work.

In your case, I would not suggest using the lock option. That, too, really needs sensors to operate well.

Thanks for your work on this I can confirm it’s working great for the lamp after I update.

Well, I just randomly tried the existing integration this morning and it’s working. The app still shows “Gateway Brand: null” on the SmartApp’s first status page (via Classic app, of course, MyQ app 3.1.0). I used my existing devices when I installed the newer app. I can’t seem to get into the IDE right now to check my logs, but that’s a bit moot since the net integration is working (I’ll still check later if you want, though).

Ah, you’re right. I forgot to remove the brand from the main page since it’s no longer used. I’ll do that. Glad it’s working now, though!

I’m having trouble getting this to work since the update. I’ve removed my device, updated the DH and app, re-run the app, log in and it finds my device. But I can’t control it. Any ideas?