[RELEASE] MyQ Lite Door and Lamp Control (for Liftmaster/Chamberlain)

I found a deal for an orvibo door contact for $7.5 (Canadian) and purchased one. I’ve set it up now and part of my system. Thanks

will Samsung multi purpose sensor work? anyone tried it with this myQ app? Samsung SmartThings Multipurpose Sensor [GP-U999SJVLAAA]

Yes, I’ve been using them for both of my doors without any issues

is there a difference/benefit between using a tilt sensor or a open/close one? or the only difference is that open/close may be hard to set up in a garage door scenario?

Not really - both end up acting as a contact sensor. Tilt sensors can just be easier to set up on moving doors.

1 Like

Hey @brbeaird I love the app here. I’ve been using it for… years?.. and just recently updated my DTH and Smart App to the 2019-04-30 update (a few days ago). Instantly the status in My Home stopped working (it forever reads “Opening”) and pushing that button no longer operates the door. However, going to the full items menu and using the manual Open and Close buttons still works fine.

Any thoughts on what went wrong and what I should do? Sorry if this is a repeat - I don’t see anyone having asked this since the 4/30 update so I think it’s a valid new ask.

I’m not sure on this - the My Home status seems to still work for me. Are you using the sensor version of the device handler?

Yes, I’m using brbeaird : MyQ Garage Door Opener . I realize upon inspecting the details that the sensor itself may be offline (probably low battery). Maybe this is the failure mode that you expect if/when the necessary sensor drops offline?

I’ve replaced the battery for the extra sensor and that did not fix things, unfortunately. I’m not sure what to do next…?

I’m not sure here. I tested again today, and it works perfectly for my doors. Do you see anything in the logs at all when you interact with things at the My Home level?

Is that hte currently maintained version of this? Or are people using the original in the OP?

Unfortunately no. With that said, I’m seeing some interesting debug messaging when I dive into the device level that is asking me to re-authenticate… that’s odd (how could anything work at all if I’m logged out?) but it leads me to give reauth a try.

Edit (solved!): I’m not sure what went wrong, but looking at the authentication solved my problem. I went to the IDE and deleted the Garage Door Opener device, then I went to my classic app, went into Automation > SmartApps > MyQ Lite and just hit “next” and re-added my door (which showed there, no problemo). Everythings working now!

1 Like

If I’m using the Samsung SmartThings multi purpose sensor with this integration do I just stick the sensor part on the door or do I have to but the magnet on as well?

Also, for the smart things sensor, there is an option to choose “do you want to use this on a garage door”. Do I choose yes? Thanks for the help

1 Like

So, noticed today that the smart things MYQ Lite install on my door stopped working. The native lift master app did not. An uninstall followed by a re-install attempt had the app reporting an incorrect password. So, logged out of the “native” lift master app, logged back in, verified my creds are working.

I blew away my myq install, updated the app and device handlers to the latest rev. On install, I again got “incorrect password” back. The log indicates thus:

[fbe3d7f7-cb3b-4788-bca4-658378ab56bd] 11:24:42 AM: warn API POST Error: org.codehaus.groovy.runtime.typehandling.GroovyCastException: Cannot cast object ‘’ with class ‘groovy.util.slurpersupport.NodeChildren’ to class ‘java.lang.Integer’

[fbe3d7f7-cb3b-4788-bca4-658378ab56bd] 11:24:42 AM: debug Got LOGIN POST response: STATUS: 200
HEADERS: [Cache-Control: no-cache
, Connection: close
, Pragma: no-cache
, Content-Type: text/html; charset=utf-8
, Content-Length: 129
]
DATA: Request RejectedYour request has been denied.[11038945473540090615]

[fbe3d7f7-cb3b-4788-bca4-658378ab56bd] 11:24:41 AM: trace Logging in

I parse this at first glance as if chamberlain put a stop to outside API calls somehow, or I’ve done something wrong, but I had an install working for months prior without any cred (or other issues). Did the update tango, get the error above in the log whilst the credentials in question continue to work swimmingly on chamberlain’s native (and inferior to my purposes) applications.

Any advice?

Mine is busted, too. Guess we’re doing this dance once again. I’ll see if I can figure out what changed.

Login request fails in Postman, too. I’m following an issue in another python implementation where they’re hitting the same problem. Good news is it’s not specific to SmartThings. Will need someone out there to successfully reverse-engineer the new call to figure out what I need to adjust in the app here.

2 Likes

Ah, I wished I checked here before executing my usual ST gymnastics this morning to figure out the problem. :upside_down_face:

Looks like the folks over at PyMyQ figured it out - the MyQ API has upgraded from v4 to v5. Might take me until later tonight, but I should be able to get a fix out later today.

5 Likes

Awesome thanks for update. Appreciate the work on this app.

Brbeaird…just wanted to say thank you for the development and upkeep of the app!

2 Likes