[RELEASE] MyQ Lite Door and Lamp Control (for Liftmaster/Chamberlain)

Did you add the device handlers in IDE?

I did

I just noticed the device handler for Garage Door Opener was not published.
I published it and im not seeing a difference.

Are you logging into IDE @ https://account.smartthings.com

Ok so I have different stuff at that link

I was going to https://graph.api.smartthings.com
What is the difference?

There are multiple shards and if you are new to ST you would not be on the url you were using. If you install on the wrong shard, you will never see them.

The url I posted above will forward you to your correct shard.

1 Like

Yeah I used it several years ago and I think i was selecting a link from autocomplete in my browser.

My MyQ has stopped working sometime in the last 24 hours. The chamberlain app works but not the integration. Checked the smartapp and device handlers. Rebooted the hub, gateway, sever, etc. Live logging shows:

Logging in to MyQ…
Login response code: 200
Successfully connected to MyQ

Ideas? Anyone else?

Yes, same here.
Had the sensor version installed given I have a tilt sensor on the garage door.
I had to select “create buttons” in the MyQ smartapp and reconfigure everything.
Just for clarity I kept the same sensor version but simply created the buttons to be able to control the door.

Mine still isn’t working. Republished the app in ide. Logged into the app again on my phone. Nothing works. Just sits at retrieving devices. I’d say it’s pooched. Can still use the chamberlain app.

Mine is dead also since yesterday. Republished the app in IDE also. The app won’t recognize my username/password.

I wish I knew what was going on with those that have stopped working. Mine still works well - unless the issue becomes reproducible for me, I’m limited in being able to troubleshoot it.

There’s definitely no reason for the push buttons to work and the normal sensor version of the door to not work - both methods are sending the exact same request to MyQ.

Are you able to log in? This is the error I get when I log in.

Mine works still also, wish I could be more of a help.

Just wanted you to know that this issue is not affecting everyone.

Mine also stopped working. I noticed there are 2 different webpages the smartthings smart app is using. 1 page for Chamberlain and Liftmaster devices, and 1 page for Craftsman devices. I wonder if this is the reason some people are having problems while others aren’t. My device is still not working and I’m using a chamberlain device. Anyone else with Chamberlain devices still have their door working? How about the craftsman people?

Yes, mine is working.

Well that blows my theory out of the water. I wish I knew what was going on. I really need to mow the yard but I’m too lazy to manually push the button.

Yes mine is working as well. Mine did stop a couple of weeks ago but after updating the code to the latest it started working again for me.

I’m still running the code I originally used when creating the app over a year ago. With the app working for some and not others I was worried about updating the code until there was a sure fix. if it worked for you I’m going to compare the latest code to what I have and give it a shot. Thanks.

That would almost certainly do it. Update to the latest code and see how it goes.