[RELEASE] My Next ManagerV2 for your Nest® products

Hi @gregws,

Yes, with MyNextManagerV2, MyNextstat DTH, and the WindowOrDoorOpen smartapp, you can do this use case and much more…

Refer to the 1st post of this thread for all the use cases supported.

With your contribution at my store, you can use many of my smartapps at my github:

Regards

Hello Yves. I have a lot of motion sensors and am using them in rooms(zones)to perform ‘Eco mode’ in the nest Thermostat. However, I do not use those zones to determine temperature settings as I solely use the upstairs zone to dictate that. If I make the other 2 zones that I don’t use for temperature settings, ‘inactive’ in my schedules(scheduletstatzones), will It also ignore the motion sensors that I have in rooms within in those zones? I do want those to be ‘seen’. Thank you

Thanks for doing this & more than happy to pay! I just purchased the full pack and installed everything. Looks like authentication is working (via a migrated Nest => Google Home account), but having two issues:

I have multiple (12) Nest Protects & 2 NEST Thermostats. All show as “MyAlarm null” and “MyTstat null”.

When I look at the alarms (Protects) (in the ST Classic, ST Connect & ST IDE interfaces), I can see it’s collecting data correctly based on timestamps and the values returned… but I can’t tell which one is which. Before I start looking at device IDs & structure IDs to rename them manually checking if there’s an easy refresh fix here.

However, when looking at the thermostats the same way, there’s zero data coming back… no telemetry on the device for current settings/temps, nor is there a name.

I’ve left it for 10m to ensure it’s refreshing & getting data, and I’ve gone to the devices in the ST Classic app and manually refreshed them, but the names are all still generic.

I looked through the troubleshooting section in the docs & searched this thread, but can’t see anyone else having this same issue. Suggestions?

[UPDATE] since posting the above, I notice that now, when I select NEXT in MyNextManagerv2 SmartApp from the initial landing screen, the next page is blank. I went back to the IDE and selected UPDATE after making no changes, but same result.

Notice that after the initial setup, it seems like the devices are not being updated. I went back through the process to get the credentials & update the app. I also went to the devices in the ST Classic app and hit REFRESH, but no change… it hasn’t seen the apps in over an hour.

Running MyNextManagerV2 v. 2.5.6

Hi, if you make a zone inactive, then the motion detector(s) in it will still be used for setting the thermostat to away or present, but the temp sensor(s) will not be used for the average calculation to adjust the setpoint.

If you have any vents in the inactive zone, the vents won’t be adjusted either.

Regards.

Hi @swamplander,

The ST platform has some rate limiting and, when you have more than 10 Nest devices, it’s recommended to split your Nest devices into 2 separate MyNextManagerV2 instances. You just need to create a second copy of the code and add the required login_information again in the IDE.

I’ve just updated the readme at the github to indicate this ST platform limitations.

That being said, I’ve just uploaded a new version of MyNextManager(v2.5.7) which will be more resilient to these kind of issues. It’s optimized to avoid loading/updating too many Nest devices in memory, just the ones selected in the smartapp.

Please download the latest version, copy & paste the minor update over the existing code, save & publish and recreate your Nest devices from scratch.

If you have any other issues, send me some detailed logs at services@maisonsecomatiq.com.

Here is how to enable detailed logging in the IDE:

https://thingsthataresmart.wiki/index.php?title=My_NextServiceMgr#Issue_.2310:_I_want_detailed_Logging.2FNotifications_or_I_want_to_enable_Ask_Alexa_Notifications

P. S. According to your update, you haven’t extracted the login info required from your Google/Nest account. Please follow the instructions in the Readme file as indicated at my store and in the installation pdf file in the downloaded zip. Also, do not log off from your active home.nest.com session after entering your login info in the smartapp (as indicated at my store).

Regards.

Hi,

If you have lost your auth tokens from Nest and/or migrated to a Google Account, and your ST-Nest integration is not working anymore, then the new versions of MyNextManager(V2.5.7), MyNextTstatV2 (v2.3.7), MyNextAlarmV2 (v2.4.2) and MyNextSensorV2 (v2.1.6) may be for you.

The Nest protects and Nest Tstats can now detect motion. If you want to use that feature, I’d recommend changing the polling interval to 1 minute in MyNextManagerV2 for faster updates.
For the Nest Tstat, you’d need to activate motion detection. Make sure you have the latest firmware version.

You can also use the motion capability in your WebCore scenarios.

You can now download the new major version at my store:
www.ecomatiqhomes.com/store

If you are already a contributor, you just need to use the original sellfy download link to get the new minor versions. The zip file contains all the required files for update and some release notes.

  • MyNextManagerV2.5.7: optimization for faster queries to the Nest web APIs and avoiding loading too many devices in memory when not required.

  • MyNextTstatV2.3.7: added tstat attributes such as thermostat_alert,should_wake_on_approach, user_brightness, smoke_shutoff_supported

  • MyNextAlarmV2.4.2: added some protect attributes related to homelink and night hight

  • MyNextSensorV2.1.6: added some minor attributes

_MyNextManagerV2 (service manager for My Next devices) now uses the Nest Web APis (not the “official” APIs as they have ended since August 31, 2019). The Web APIs don’t have the strict rate limiting as the old APIs and they are as responsive as the native Nest application.

_ MyNextTstatV2 now natively supports the following commands:

  • setHotWaterBoost: in the device UI and as a command for WebCore users. This is useful for Nest users in Europe.
  • setTargetHumidity: to set a target humidity level (for the control of your humidifier/dehumidifier connected to Nest)

For the full list of attributes, capabilities & commands supported,refer to the ST community wiki:

https://thingsthataresmart.wiki/index.php?title=My_Next_Tstat

https://thingsthataresmart.wiki/index.php?title=My_Next_Alarm

MyNestTstatP1

Regards.

Perfect. Thank you. I was hoping the motion sensors would still work for Eco regardless of whether or not zones were used for temperature sensing.

| | Nicholas Hillman - Chat @ Spike | j4x1h |

  • | - | - | - |

| yvesracine Insightful
May 30 |

  • | - |

Hi, if you make a zone inactive, then the motion detector(s) in it will still be used for setting the thermostat to away or present, but the temp sensor(s) will not be used for the average calculation to adjust the setpoint.

If you have any vents in the inactive zone, the vents won’t be adjusted either.

Regards.


Visit Topic or reply to this email to respond.


In Reply To

| Nicholas_Hillman1 Nicholas Hillman
May 30 |

  • | - |

Hello Yves. I have a lot of motion sensors and am using them in rooms(zones)to perform ‘Eco mode’ in the nest Thermostat. However, I do not use those zones to determine temperature settings as I solely use the upstairs zone to dictate that. If I make the other 2 zones that I don’t use for temperatur…


Visit Topic or reply to this email to respond.

To unsubscribe from these emails, click here.

Thanks for the quick update… one point of clarification: I had done the login details (google account option).

I removed all devices and the installed app, updated the code & went back thru the setup. Worked great. I only added 9 of my 14 devices on the first instance.

They are updating, however, unable to get back into the app and turn on more detailed logging. I get the same experience before: once I get past the first about screen, it’s blank and I get an error when clicking DONE. Same experience when I try to create a second instance.

Recorded a video… should I email that to you?

Also, better to remove all and re-add again and enable more detailed logs to send those?

Hi, there has been a lot of ST platform issues in the last week (timeouts and nosql issues)… The blank page in the 2nd page could be the results of ST rate limiting & timeouts.

Why don’t you start small with 4-5 devices in the 1st instance and build up from there? I have 8 devices at home, but at this time, they are not refreshing as often due to the timeouts. A way to do it is to break the workload into multiple chunks (2 or even 3 instances)
Make sure to use the latest version (v2.5.8 ) or at least MyNextManagerV2.5.7, copy & paste the new code over the existing one in the IDE, and don’t forget to save & publish. …You can download the latest version using the sellfy download link that was sent to you when you made your contribution.

Make sure to follow all the prerequisites and installation steps in the Readme file. And, do not log off from your active home.nest.com session. This approach will work like anyone in this thread.

I personally don’t need a video as the installation steps have been tested over and over again at multiple user locations… If you want to make a video after you’ve been successfull for others, that’s fine (but there are some secret login information not to share). What you need to do is to follow the prerequisites & instructions step by step…

P. S. You can also enable detailed logging in the IDE by clicking on a device and editing the preferences

Regards

I’m running latest (2.5.8), saved & published, verified I did all pre-req’s, auth is working as in the initial setup, I can see all my devices & I didn’t logout of my browser session where I obtained the login URL & cookie (I just closed the browser as your README says).

The “Last Activity” column for the list of devices in the IDE shows old timestamps when the device was seen, but when I look at the device properties in the mobile app, it shows it was updated in the last 10m. IOW, after going through the initial setup, everything seems to work fine.

I just deleted everything to try again, adding JUST my two thermostats and assigning the app the name “NEST Thermostats” to setup another instance later. I can see the status & control of the thermostats. IOW, everything worked exactly as I’d expect (and has so far).

But trying to get back into the SmartApp (or to add another instance by repeating the setup) & selecting NEXT after the about screen always goes to the blank screen. This is where my problem is… my understanding from your response is this is a ST issue that’s been going on for the last week. Is there a status page I can monitor (I’m a software dev, just not versed in ST development, so I understand this part of the process)?

Will monitor the thermostats to see if they keep refreshing & can connect and will keep trying slowly add more devices.

Hi, if you want to add another copy of the code, you just need to create another smartapp called MyNextManagerForProtect (change the name of the smartapp at the end of the file), copy the same Nest login info, and enable oAuth.

Will this work to get my nest thermostat into my smartthings 2.0 app?

Yes, as per the screenshots displayed above in the new Samsung Connect app.

Regards

@yracine: I had to finally migrate my Nest account to a Google account due to the new Nest Aware packages. I followed the instructions and was able to restablish communication with all of the systems by adding the request url and the cookie to the settings.

All devices started updating immediately when I did that. And my automations started to send notifications.

The challenge I have is, when I start MyNextManagerV2, click Next, I end up with a blank page, nothing is pulled in. Any thoughts on what is going on? I only have the option to go back or click Done. When Done is clicked, I get the “Error saving unamed page. Please contact SmartApp developer.”

The same issue happens in the old and new SmartThings apps.

Hi @Skates, since about a week, the ST platform has had lot of timeout issues. You can see it yourself when you enable live logging in the IDE. Due to the rate limiting in the ST platform, you may have this issue when you have a lot of Nest devices under a single Nest/Google account.

Hopefully, this is temporary.

Please refer to my previous post about how to split your Nest devices in 2 or 3 MyNextManagerV2 instances.

Regards.

What’s weird, it worked right before I migrated accounts and then stopped working right after.

In the Live Log, I see the following error when I open the app and hit next:

8:31:36 AM: error java.util.concurrent.TimeoutException: Execution time exceeded 20 app execution seconds: 236160926902145 @line -1 (doCall)

8:31:14 AM: debug getChildDevices(false), children=7

8:31:16 AM: debug getChildDevices(false), children=7

8:30:53 AM: error physicalgraph.exception.StateCharacterLimitExceededException: State cannot be greater than 100000.0 characters

Which version of MyNextManager are you using? You should upgrade to the latest version using the same selffy download link.

I believe that you have not the latest version.

P.S. As I wrote to you before, you may split your Nest devices into 2 separate instances due to the timeouts that appear in your logs.

I am on v2.5.8.

As I wrote to you before, you may split your Nest devices into 2 separate instances due to the timeouts that appear in your logs.

Make sure to save & publish the code also.

I don’t think it was a ST issue.

I got tired of playing around with it, deleted all of the devices and SmartApp for ST. I then reinstalled the SmartApp, and have had no issues since.

Luckily I only had a few Webcore items that needed to be updated.