[RELEASE] My Next ManagerV2 for your Nest® products

Another thing, it’s normal that if you press the thermostat mode tile in the ST classic mobile app, the mode will change… This is indicated at the ST community wiki under the look & feel section. Please refer to the ST community wiki for more information about the look & feel, known issues, etc:

http://thingsthataresmart.wiki/index.php?title=My_Next_Tstat#Look_.26_Feel

Regards

Once all tracked contacts are closed the thermostats are not returning to their previous state.

Hi,

Please extract the relevant logs from live logging in the IDE and send them to services@maisonsecomatiq.com.

Which version of WindowAndDoorOpen are you using? The latest version is 2.7.2.

I cannot help you without logs as this issue may be specific to your ST account.

Refer to the ST community wiki for getting the logs. I’d need the logs from the WindowAndDoorOpen smartapp & MyNextTstat.

https://thingsthataresmart.wiki/index.php?title=My_Next_Tstat#Issue_.237:_I_want_to_get_more_tracing_in_the_IDE

Regards

Any ideas on how to change the status of a Nest thermostat from Home -> Away and vice versa using Webcore?

I have not been able to figure it out.

Hi, with the Nest web APIs, you cannot change the structure to away. However, you can set your thermostat to eco and home.
Regards.

Hi,

If you have lost your auth tokens from Nest and/or migrated to a Google Account, and your ST-Nest integration is not working anymore, then the new versions of MyNextManager (V2.2, MyNextTstatV2 (v2.1.5), MyNextAlarmV2 (v2.1.4) and MyNextSensorV2 (v2.1.4 ) may be for you.

You can now download the new major version at my store:
If you are already a contributor, you just need to use the original sellfy download link to get the new minor versions.

www.ecomatiqhomes.com/store

_MyNextManagerV2 (service manager for My Next devices) now uses the Nest Web APis (not the “official” APIs as they have ended since August 31, 2019). The Web APIs don’t have the strict rate limiting as the old APIs and they are as reponsive as the native Nest application.

_ MyNextTstatV2 now natively supports the following commands:

  • setHotWaterBoost: in the device UI and as a command for WebCore users. This is useful for Nest users in Europe.

  • setTargetHumidity: to set a target humidity level.

  • For the full list of attributes, capabilities & commands supported,refer to the ST community wiki:

https://thingsthataresmart.wiki/index.php?title=My_Next_Tstat

https://thingsthataresmart.wiki/index.php?title=My_Next_Alarm

MyNestTstatP1

!MyNestProtect

Regards.

Do the Nest Protects have the same limitation? Or can you read there status?

My biggest pet peeve with my Nest Thermostats is that they haven’t created the functionality to adjust the humidity set point based on the outdoor temperature.

Has anyone been able to create a WebCoRE piston to automatically do this?

Yes, you can read the status, but it’s not real time like any ST cloud-to-cloud integration. However, you can set the polling interval to a refresh interval of 1 minute which is pretty good…

Hi,

You can try the MonitorAndSetNestHumidity smartapp at my github…It’s a new version based on the work I’ve done on the ecobee.

The smartapp will monitor your indoor Humidity based on your outdoor sensor and set the target Nest Humidity accordingly.

It can trigger some humidifier or dehumidifier switch(es) when needed.

Regards.

That is awesome, great work, will try it out before it gets to warm outside.

Thanks in advance, I’m glad I supported your My Next project this morning!

I added your github repo to the IDE and I get the following error trying to install your SmartApps, any ideas?

Updated 0 and created 0 SmartApps, 0 published (1 skipped due to errors)

My only option is to copy and paste.

Hi,

Check your github settings:

GitHub Settings:

Owner : yracine

Name : SmartThingsPublic

Branch : master

Regards.

And last question for the night? Any reason why the Humidity app says false for nestHasHumidifier shows “false”?

The Nest definitely has a humidifier connected to it that works.

Hi, it should be corrected. Please resync with the latest version at the github.

Nest has different attributes from ecobee, so I’ve adjusted the smartapp.

Updated to 1.0.3 and it has the same issue.

Also, any chance to limit this to Heat mode only so that it works only during winter months? TIA!

Hi, sorry but it looks like the Nest APIs have not registered that your humidifier is connected to the Nest.

You can check in the IDE for your tstat the value of the “has_humidifier” attribute and it should be false according to the smartapp.

If you want to execute the smartapp only in the winter, I’d suggest using a virtual switch that can trigger the smartapp at the date & time of your choosing. You can then also temporarily stop/restart the smartapp if needed.
Regards.

It definitely shows that I have a humidifier, any thoughts?

OK, try resync with 1.04.

Worked!

Now to automate this for heat mode only. Is it not possible with the Nest API?