[RELEASE] My Next Manager for your Nest® products: migrated to custom capabilities (home/away, motion, presence, and more)!

Just updated, thanks. Noticed an issue where the current temperature doesn’t seem to be accurate.

image
vs.

Also wondering, is it possible to have the battery level for Sensors conveyed as ‘battery’ consistent with your Alarm and other ST devices so that those be utilized the same via WebCoRE without having to write extra code to find the different battery level expressions?

image vs. image

Thanks again, great products!

Hi, you can download MyNextSensor (v2.1.8) which adds the battery capability.
FYI, I cannot explain your temp discrepancy as the value comes from the Nest web APIs.

Regards.

1 Like

Thanks. the update DH did the exact trick. Also the temp discrepancy eventually went away, I guess it just took a few polls or whatever.

Thanks again.

Hi, you can change the polling interval in MyNextManagerV2 smartapp (last page) to be as fast as every minute…

Hi yvesracine, I’m interested in using MyNext Tstat. In the README, the installation instructions for migrated Nest users says:

  1. Under the new Samsung connect app, execute MyNextManagerV2

Just to confirm, does “new Samsung connect app” refer to the current SmartThings (i.e. not the Classic) mobile app?

Yes, the new mobile app is callled Samsung connect app (as opposed to the SmarThings classic app).

Regards.

Thanks very much.

Apologies, I probably wasn’t clear enough in my original question. I’m on iOS, I just want to be certain that I’ll be able to use the device handler / app. The app I have is called SmartThings, this is the only one I’m able to use.

Here’s Samsung’s description of it and links to both Google and Apple app store: https://www.samsung.com/uk/apps/smartthings/

Yes, it’s compatible. Please refer to the screenshots in the 1st post for the UI presentation.

Regards.

Hi,

Good news for all my contributors (and Nest users)…

You can now use the custom capabilities (motion, presence, humidity, Nest Home or Away,etc), in Automation scenarios, see screenshot below:

Regards.

1 Like

@yvesracine any thoughts on eventually getting “partner program” thermostats to be loadable? Purchased the subscription when I had one Nest, then got a deal through my gas company and loaded up on 3 more… and then was hopeful Google and Samsung would release a decent integration. But, alas, no joy.

Since the nest web UI is clearly loading the devices, I can’t imagine that it would be impossible to get into your drivers. I believe the calls are probably in the long-polling request that follows the first api request with regular devices, but haven’t gotten further than that.

Hi, the Nest web APIs that I’m using only expose the Nest tstats which directly belong to the Nest structure/account.

I’m not aware of any long polling requests.

Regards

Hi Yves, I’ve successfully published the MyNextTstatV3 DTH and MyNextManagerV3 app and they are giving me more control than the native ST app, so I’m pleased. (I’ve also successfully done it without ever having had the ST Classic app.)

I’m just starting out on my ST journey and I’m trying to write a webCoRE piston with a condition that identifies if “thermostat mode” is set to eco. However, the only values I can select are auto / cool / emergency heat / heat / off. Can you help please?

Hi, please contact the Webcore team as eco is already supported by myNextTstat. This is probably an issue in Webcore.

You can also create a new Automation and you’ll see the eco mode as a valid mode option.

EcoMode
Regards.

Hi, yes, thanks, I can get the eco mode as a valid option in automations too. I’ll contact the webCoRE team as you suggest.

In the meantime, I’ve found a workaround in webCoRE by interrogating the state of eco_mode.

@yracine: I ran into a weird issue, my devices stopped updating. The two Thermostat logs are literally blank in the IDE.

Thinking that the login died, I relogged in and copy/pasted the correct cooke/url. Still nothing…

I tried to then delete the SmartApp (to start from fresh) and it won’t let me uninstall. And now its in a funky state where nothing is happening except for this error. Any thoughts?

[b26e60b3-5132-472f-b547-49d6f01ef3ce](https://graph-na04-useast2.api.smartthings.com/ide/logs#b26e60b3-5132-472f-b547-49d6f01ef3ce) 8:26:41 AM: error org.springframework.transaction.TransactionSystemException: Could not roll back Hibernate transaction; nested exception is org.hibernate.TransactionException: JDBC rollback failed @line 1870 (updated)

[b26e60b3-5132-472f-b547-49d6f01ef3ce](https://graph-na04-useast2.api.smartthings.com/ide/logs#b26e60b3-5132-472f-b547-49d6f01ef3ce) 8:22:21 AM: error org.springframework.dao.DataAccessResourceFailureException: could not delete: [physicalgraph.app.EventSubscription#3748e38c-6b8a-4d04-a30f-7742f19b2342]; nested exception is org.hibernate.exception.JDBCConnectionException: could not delete: [physicalgraph.app.EventSubscription#3748e38c-6b8a-4d04-a30f-7742f19b2342] @line 2227 (initialize)
[b26e60b3-5132-472f-b547-49d6f01ef3ce](https://graph-na04-useast2.api.smartthings.com/ide/logs#b26e60b3-5132-472f-b547-49d6f01ef3ce) 8:30:08 AM: debug getChildDevices(false), children=7

The SmartApp will now load still but when I press Next on home screen, it just returns me back to the home screen after processing.

Hi, this is clearly a ST platform issue related to their backend services (hibernate), and it’s not related to my code per se.

If you want to uninstall MyNextManager to restart from scratch,please follow the steps at the ST community wiki:

https://thingsthataresmart.wiki/index.php?title=My_NextServiceMgr#Issue_.239:_I.27d_like_to_uninstall_My_Next_devices

To install the devices again, download the latest version (no need to split the cookie anymore) and you have to follow all the steps at the readme…

Regards.

Of course, my struggle is the deletion. The SmartApp will not delete from iOS nor IDE.

I have deleted all of the individual devices and its still giving me trouble.

Due to the ST platform errors you’re experiencing under your ST account, you may have to contact SmartThings support.

In the meantime, you can create a new smartapp & rename the smartapp at the end of MyNextManager’s code, save & publish, and restart from scratch.

Regards

I already tried that too, I get the following error message:

[445c6635-15f7-41d6-aaf3-83ce0670c392](https://graph-na04-useast2.api.smartthings.com/ide/logs#445c6635-15f7-41d6-aaf3-83ce0670c392) 9:51:40 AM: debug checking sendExceptionCount=3 vs. max=5

[445c6635-15f7-41d6-aaf3-83ce0670c392](https://graph-na04-useast2.api.smartthings.com/ide/logs#445c6635-15f7-41d6-aaf3-83ce0670c392) 9:51:40 AM: error authPage() exception java.lang.RuntimeException: Unexpected status code 400 from global /clients/null with status text Bad Request, not able to create access token, probable cause: oAuth is not enabled for MyNextManager smartapp

[445c6635-15f7-41d6-aaf3-83ce0670c392](https://graph-na04-useast2.api.smartthings.com/ide/logs#445c6635-15f7-41d6-aaf3-83ce0670c392) 9:51:40 AM: debug about to create access token

[445c6635-15f7-41d6-aaf3-83ce0670c392](https://graph-na04-useast2.api.smartthings.com/ide/logs#445c6635-15f7-41d6-aaf3-83ce0670c392) 9:51:40 AM: debug authPage(),atomicState.oauthTokenProvided=null

Please follow the steps at the Readme.

It’s indicated in your logs, you haven’t enabled oAuth (step 2f).

Regards