[RELEASE]My Ecobee Devices and ecosystem V6- migrated to custom capabilities!

I’m using your smart app. It is working fine.
Today I got an email from ecobee saying they are moving EMS portal users to SmartBuildings and discontinuing EMS API in the near future. Should I need to worry about it?

Yes, it means that the EMS APIs will be phased out on March 3rd, 2021.

Do you have any plan to adapt to it?

Not for the moment as very few users have EMS tstats…

This would be too much work for such a fraction of users.

Hello @yvesracine - Will you be hosting this smartapp on your own server or in the cloud when Samsung decommissions IDE? Just want to make sure I’m prepared as I use your code for both keen smart vents and ecobee.

Thanks!

Hi @gpetru1, for the moment, I’m following this thread:

Regards.

@yvesracine, I just received notification that ST classic app will EOL on October 14th. Do you have a new version that fully supports the new ST app?

See my previous post:

I’m not planning to rewrite any code for the new Samsung platform at this point. The existing groovy code works at the moment under the new Samsung connect app (as per the screenshots above, see postings about the last version):

[RELEASE]My Ecobee Devices and ecosystem V5.

I’m hoping that the custom capabilities will allow to further leverage the existing groovy code in the new Samsung connect app as indicated under the thread.

Regards.

Hi,

You can now create My Ecobee devices (tstats and switches) in the new Samsung connect app and use many of my smartapps at my github for your use cases:

As an example, you can use ecobeeChangeMode to change your ecobee mode to Away or Home based on your ST location mode or use ecobeeResumeProg to resume your program when you come home.

All the smartapps work under the new Samsung connect app.

My Ecobee Device in Fahrenheit in the new Samsung connect app:

My Ecobee Device in Celsius in the new Samsung connect app:

My Ecobee Switch

You can download MyEcobee devices at my store

Regards.

Ive been using the vent control app for a year or more and love it. Just installed a humidifier and installed the monitorandsethumidity app. The thing I don’t know is if and if so, how to have the vent control work with the humidifier. When the humidifier is running and the thermostat is in fan only mode I think it would be good to have all vents open so the home all stays humidified. Is that possible?

Hi, yes it’s possible in the zoning smartapp (ecobeeSetZoneWithSchedule) under ScheduleSetup>VentSettings, there is an option to open all vents when the thermostatOperatingState is fanOnly.

You can set it schedule by schedule for more flexibility…

Hi,

d54605ba994a99147562d856d066149b46263760

Just want to inform my contributors that a new major version of MyEcobeeDevice(v6.0) & MyEcobeeInit (v4.3) can be downloaded at my e-commerce solution provider (sellfy) using the original download link.

  • All you need to do is to copy &paste the new code over the existing one for the DTH (Device Handler Type) and the service manager (MyEcobeeInit).

  • You’d probably need to refresh the Samsung connect app’s cache in order to see the UI changes. There are some instructions to do so in the release notes.

  • The new UI presentation (amongst others) adds a custom capability (set Ecobee Climate/Comfort Settings, see image below) and the presence/humidity capabilities.

And, there is also the ecobee Switch with all standard switch capabilities:


On top of it, there are many complimentary smartapps designed for My ecobee DTH and are located at my github. All ecobee smartapps are explained at the ST community wiki (all ecobee* smartapps):

You can also refer to the 1st post of this thread for all the use cases supported.

My Ecobee DTHs (thermostat, switch) are available at my store:

d54605ba994a99147562d856d066149b46263760

Regards

1 Like

Hi,

d54605ba994a99147562d856d066149b46263760

Just want to inform my contributors that a new major version of MyRemoteSensor (v2.0) can be downloaded at my e-commerce solution provider (sellfy) using the original download link.

  • The code makes some correction to the way the ecobee remote sensors appear in the dashboard (see below). The temperature is displayed instead of motion…
  • Also, it makes visible only the attributes available from the ecobee APIs: temperature and motion detection in the detailed view.

Dashboard

Detailed view

  • You’d probably need to refresh the Samsung connect app’s cache in order to see the UI changes. There are some instructions to do so in the release notes.
  • For MyEcobee device (V6), the new UI presentation (amongst others) adds a custom capability (set Ecobee Climate/Comfort Settings, see image below) and the presence/humidity capabilities.

My Ecobee DTHs (thermostat, switch) are available at my store:

d54605ba994a99147562d856d066149b46263760

Regards

1 Like

Does the original contribution allow access to the updated versions? I am having an issue where I lost connection to Ecobee a while back and I can’t seem to re-login. This is what I downloaded from Sellfy.com

I also seem to have lost the My Ecobee Device in the Device Handlers. When I updated it, it disappeared and every time I try to re-add it, I just don’t see it no more…

Hi, I cannot explain the reason when your DTH has disappeared. Have you published it under the right shard?

P.S. The namespace has changed due to the custom capability.

Ok, figured out you changed names!

Also figured out I had to go into IDE and reauthorize by updating the OAuth. Therms are back online but having issues with Sensors.

I suggest that you do a cleanup, you have many DTHs with the same name.

1 Like

I did. Here the crazy thing, I haven’t touched anything but my Therms and Remote Sensors have been offline for a while. For some reason, ecobeeRemoteSensorInit was no longer in the IDE. I installed it and now it shows. Going to install it in the New App and cross my fingers.

I also see some duplicates in your smartapp list, you should do a cleanup as well.

1 Like

Think I figured it out!

I have three Smart Apps that come up in ST under App.

I’m thinking I screwed the pooch when updating because when I click on one of the Remotes I get: