SmartThings Community

[RELEASE] Monoprice Shock and Acceleration Sensor

But is it sensitive enough to detect the dryer (or washer) running?

@RBoy @maddie
I finally got around to installing and testing your updated DTH with my Monoprice Shock Sensor #11988 and so far, it seems to work fine.

I was previously using version 1.0 of this DTH but found that it would randomly get ‘stuck’ as ‘active’. In spite of advice to the contrary (i.e., it’s the sensor’s fault), the stock, “Z-Wave Plus Door/Window Sensor” DTH worked very well (I.e., the sensor no longer got ‘stuck’). My only issue with the stock DTH is that I don’t like the ‘Contact/Open/Close’ nomenclature that it uses for my use case as a doorbell sensor.

So, I’ve loaded version “01.02.01” of your DTH to see if it no longer gets stuck.

1 Like

Although I’ve not tried it, I’d say it’d likely that it would work. I have an earlier model of this sensor and I’m using it as a doorbell sensor. If my grandsons play in the hallway near it or bump the wall, they regularly set it off. (As an aside, I have an override ‘switch’ to prevent it from becoming too obnoxious.) It is adjustable too. Since my wife and I are less rambunctious, we don’t often set it off by mistake. :grinning:

Awesome… great news to hear… I already ordered it and will be trying it out tonight. Thx.

1 Like

@RBoy

Seems to be working well. Thanks!

I have 3 MP shock (15269) sensors, which do not seem to be responding with this DTH. It has been 18 hours, since the install. I see the DTH version is correctly reported in the activity log, but nothing else. The LED does light up when the sensor is shaken, but I do not see anything on the sensor activity or IDE log. The sensors are about 10ft from the ST hub. Please help :frowning:

Sounds like the events from the device may not be reaching the hub which would indicate a z-mesh issue. Try to bring your devices closer to the hub, reboot your hub and then do a z-wave repair.

Most passive z-wave devices benefit from the addition of a buffering device which holds the messages until the hub is ready to receive them (and vice versa). Try adding a buffered repeater between your devices and the hub.

So I started from scratch - I paired two MP shock sensors. Both are close to the hub (<10ft), and paired from the same location. Both paired with the hub successfully, and were detected properly.

However, one is working well and detects shock/tamper.
The other is paired with the hub, but ST detects no shock/tamper.

I slightly modified the device handler code to print the {description} of the command send to the ST hub, this is what I see:

  1. The working sensor sends the following command:

  1. The non-working sensor sends the following command, which is parsed to a null command:

Can this provide any clues as to what might be wrong?

The packet may be corrupted so the hub isn’t processing it (this doesn’t appear to be a valid z-wave sequence). Try to reset the device and pair it again or try adding a z-wave repeater between the device and the hub.

Send me a PM and let’s see if we can extract more information from the device pairing. I need the device raw description from the IDE

I’m hoping someone can assist me with my issue.

REF: Monoprice Shock and Acceleration Sensor 123 (15269)

I’m having the same issues as most people here. I just purchased the device handler codes for $38 thinking it would fix my issues although when I apply the handler and add the device to my smartthings app, the device is added with RBOYS DH successfully although the sensor stays in an “Inactive” state, even though I trigger the sensor (By tapping or shaking it) the DH on my ST app stays Inactive. I’ve tried pretty much everything, spent about 4 hours last night trying to troubleshoot. Also tried using the default ST handler, and nothing. Ok I lied, I was able to get it working briefly although when I tried to remove the Rboys DH and delete the device from the ST app, I then tried to read it with the default DH to see if it would work, it didn’t, I then tried to read the RBOYS DH and it was in an INACTIVE state for good.

I also want to mention that I have 1 shock detect (MP) that I installed about a year ago, and it works perfectly with the ST default DH. Very weird that it no longer works and thinking that I paid for this DH and it still doesn’t work, is disappointing. This issue is causing much stress.

I’m pleading for some help, any would be much appreciated, as I’m my wits end. I have about 5 devices (purchased about 3 years ago still brand new) that I’ve tested and same results.

It’s probably not the DH. It could be the sensor is bad - but more than likely, it’s a communication issue that needs to get solved before anything else. You need some repeaters for a stronger mesh.

But the sensor is right beside the hub as I’m testing ? What are those and how do I install them? Where Do I buy them?

Funny as the one I pair last year work fine.

Let me know. Many thanks .

If the sensor is right next to the hub, I’d exclude it and then try to re-add it to your hub. Maybe the first time it didn’t link up correctly.

Regarding Z-Wave repeaters: Any Z-Wave device that’s powered via house power (i.e., not batteries) is most likely a z-wave repeater. But, since the sensor is right next to the hub, that’s probably not your issue. I’d try excluding it, resetting it and trying to set it up again.

2 Likes

You’re correct, it always helps to have a repeater between a device and the hub since the hub doesn’t buffer messages. Sometimes devices connecting directly with the hub face communication issues which disappear when they placed further away from the hub but with a repeater in between the hub and the device forcing the device to connect to the repeater. Here’s a FAQ that explains it more detail: FAQ: why would I need another beaming repeater if my zwave lock is already close to my hub?

2 Likes

If the sensor is right next to the hub, I’d exclude it and then try to re-add it to your hub. Maybe the first time it didn’t link up correctly.

Regarding Z-Wave repeaters: Any Z-Wave device that’s powered via house power (i.e., not batteries) is most likely a z-wave repeater.

1 Like

Installed the RBoy device handler and paired. It reads the battery and tamper switch, but no matter if movement or vibration, it always reads inactive.

Update - just figured out if the tamper switch is active, cover is off, it will not report any motion or vibration activity.

nothing happend even after published rboy device handler could any one help me please

Official Monoprice Shock and Acceleration Sensor Device Handler - Version 01.03.00

  • Added support for new ST app
  • Added capability to report as a Motion Sensor in addition to Shock/Acceleration sensor so it can be used with SHM

NOTE: If the device is shaken very violently, sometimes the “spring” mechanism inside the device could get “stuck” behind the capacitor in some devices which can cause it to stop sending further notifications until it is reset.

1 Like

The new device handler from RBoy Apps works perfectly with the Monoprice shock sensors. The Smart Home Monitor portion of the Smartthings app recognizes them as motion sensors and will display an intrusion just as if a door/window switch was triggered. I recommend the RBoy Apps company and their support them without reservation.

1 Like

Anyone know what kind of 500K pot that is? Mine just broke off.