[RELEASE] Monoprice Dual Relay On/Off Device type 11990

@justintime

My switches are working, but I am still receiving the error above every minute.

@justintime

Sorry, NM, I was using the other device type on the ones getting the error. I have changed all of my relays back to this DTH.

Hey Guys-

Thanks a ton for the work on this app. Hoping to purchase some of these soon for the fans in my house. Wanted to ask about manual operation though first. If i install these, can i still use the manual pull strings on the fan? Or if for example i have it switches off on the smarthings app, will it leave power off until i turn it on on the app.

Hoping there is some kind of override that allows manual operation but wanted to check prior.

Thanks,

Kevin

I hooked these up to two switches with a switch that has a mechanical dimmer slider and now the dimmers don’t do anything. Is this normal? Anyone else use these with a dimmer?

All the switch wire does is tell the relay if the physical switch has been toggled or not. It’s not a dimmer relay so having a dimmer switch won’t do anything.

I have 2 light switches in a dual gangbox. One switch controls a kitchen light and the other one controls a three way light switch (hallway and stairs). Will this be able to control both or will I need to use two of them? Has anyone done this and can they comment on how to wire it? Thanks!

As long as the 3 way is powered at that box, yeah it should work without any wire pulls. you’d have the slave switches only wired to the relay and common wire on the relay. The wiring for the 3 way would stay the same I think. I’m not real good at conceptualizing 3 ways though. Basically you just need the slave’s to switch power to the relay leg, it energizes and the relay activates, doesn’t matter which switch energizes it.

  • I am not an electrician, my theories and ideas are probably wrong, please don’t die, I’d feel bad.

Thanks Michael. I will try hooking it up according to your instructions. Sorry for the late response.

First, thanks to @justintime for compiling all of this and making it easy for new people to jump right in.

Now for my question. I got the 11990 installed, tested, and buttoned up. Everything worked as it should.

After I loaded the device type, the control from ST only worked when switch 1 was physically turned on. The same continued after loading the smart app.

Has anyone else experienced this or do I have a dud 11990?

Hi guys thanks for the great work on this.
I have the Monoprice 11992 which is a 3 relay switch instead of a two relay one for the 11990.
Could you give me some advise on the best way to integrate this with Smartthings.

I am looking at the code, and have see where the switches are defined and referenced for on and off in the code, but would want some advice.

Thanks in advance.
Trevor

That’s a low voltage relay, would it even be close to the same? I honestly don’t know, that’s why I’m asking. :slight_smile:

Yes I was looking at that. The other difference is that the way the 11992 should work with curtains, it should be a normally off position and then when pressed it should stay on for enough time for the curtains to close. Similarly for the close relay switch, it should work in exactly the same manner. The stop switch should be a momentary on when pressed.

From looking at the zwave command classes, they seem very similar for the two devices, so I think that I may be able to use the base of this device. In looking at the documentation again there seems to be a configuration option for the amount of time that each of the switches stays on. I will contact Monoprice to get details of what is necessary to set those options.

I will keep the team updated on my progress.

Trevor

I’ve been having a weird issue with my dual relay. I have it connected to my interior garage lights on the “primary” switch and the exterior garage lights on the “secondary” switch. The goal is that when the garage doors open, the interior lights come on and when I enter my geofence in the evening, the exterior garage lights come on.

Anyway, what I’ve noticed is that the exterior lights rarely come on. If I check the logs, all of the logic is running correctly and it indicates that the exterior lights were turned on, even though they’re clearly not on. Also, manually controlling the lights through the app gives me some strange results - the interior lights seem to work nearly flawlessly but the exterior ones have issues and sometimes I’ll have to recycle the main Garage Relay in the app to get it to work. When that happens, it then seems that both lights have issues coming on at the same time.

Any thoughts or anyone seeing similar issues? The issues seem mainly isolated to that secondary switch.

Just got home and my outside lights didn’t turn on. I reviewed the SmartThings logs and the “on” command was definitely sent to the lights and the button status reflected them being on, even though they weren’t. I cycled the button and they did turn on. It’s almost like the thing is going to sleep or something.

Maybe it’s a range issue? I have this same relay hooking up to my exterior motion light fixture and have very similar problems due to range. Also because it’s using virtual switches which sometime out of sync when using motion or presence.

I don’t think it is range - the primary switch operates flawlessly. Maybe I’ll try another DH and see if that fixes it. Otherwise, I guess I’ll have to consider just moving to regular switches in for those. Like I said, the rules are firing as they should and are activating the light, but the light rarely comes on.

The rules are firing in the cloud doesn’t mean it will get to the switch. Definitely try another DH and hopefully that will fix it.

I switched device handlers and used a new SmartApp to bind the secondary relay to a virtual switch. It seems much more responsive. I’ll test it for a few days but hopefully that fixes it.

1 Like

I’m continuing to test with the new DH and SmartApp, but last night I saw the exact same symptoms as before - the logic all fired but the lights on the secondary switch didn’t come on. Playing with the buttons in the app finally got it to come on. It is seriously like the secondary switch is falling asleep or something and needs to be awakened. The primary switch works flawlessly. I don’t think I can fit two of these relays in the gangbox without some major work, so if this continues, I may just end up buying a couple of z-wave switches or perhaps try another relay. I’m a little gun shy on going with another dual relay like the Enerwave, however.

EDIT: I just created a new rule triggering off a contact sensor and the secondary switch worked every single time. I’ll keep plugging away and testing. :slight_smile:

Hey Brad,

I think you should work with Monoprice on getting a replacement unit, it sounds like you got one that isn’t quite right. I’ve had 3 of these relays running on this DTH since the day I wrote it, and I have literally never had a single misfire from any of them.

MP is usually really easy to work with on RMA’s – I’d go that route next if I were you.

Justin