[RELEASE] Mode Based Thermostat - Control Multiple Thermostats Temperature / Remote Temperature Sensors when Changing Modes

Right. So, the Mode method won’t enable us to disable this SmartApp without interfering with the normal operations of our other SmartApps.


  1. since the Mode method is NOT safe for a production environment, and

  2. since the Switch method IS safe for a production environment, and

  3. since the Switch method is more efficient, offers more versatility, and empowers the user to disable the app as desired without interfering with anything else, and

  4. since, (as you pointed out) just about the same amount of effort would be needed to do the ‘prep work’ for either approach (i.e. creating and configuring Modes for the Mode method, or creating and configuring Switches for the Switch method),

it would appear that IF one were hoping to maximize time, energy, resources, and effectiveness (i.e. actually accomplishing the intended objective), then the Switch method is superior, and the ‘better’ choice.

Still not really meaning to argue with you, or try to pressure you into it, but just attempting to present the facts in a logical, reasonable way. :slight_smile:

1 Like

Absolutely and just to be in the same page, as I mentioned before, I’m not saying it can’t be done. Just pointing out that it’s a bit counter intuitive for the uninitiated to use a switch to control a smartapp and can be confusing for folks.

Your feature request has been noted and added to our queue. The more folks request the feature, it helps prioritize the request :slight_smile:

1 Like

Does anyone have any ideas on how I can setup so a virtual switch will change my thermostat mode without needed temperature inputs? All I want to do is have the switch turn on and it sets the system to cool. Ideas?

Use CoRE, create a rule to do just that.

Not familiar with CoRE. Link?

You can find it our webpage, the last app (22nd), http://smartthings.rboyapps.com/#a3

Direct link:



Well, I wish I had known about this before! Just eliminated a bunch of my IFTTT stuff! Thanks!


You’ve got quite a few thermostat smart apps (and I have a membership, so I have full access). I’m wondering if you can tell me which one would be best for me.


  • Set schedule that reduces energy when I’m in Away mode
  • Returns to normal schedule when I return to Home mode
  • Run multiple scheduled based on time of day and day of week

So you would need two SmartApps to cover all your scenarios.

This one - Ultimate Mode Based Thermostat which allows you to set temperatures while in away mode or other modes.

For regular scheduling you should use the 5-2 Day Thermostat which allows 4 schedules per day for the weekday and weekend. Just set the modes you want it to operate in, e.g. home and night.

1 Like

Ultimate Mode Change Thermostat Temperature - Version 02.04.01

  • < no change >

Mode Change Thermostat Single Temperature - Version 01.01.00

  • Added support for automatic update notifications when new versions are available

Once you update the SmartApp code you will need to open the app on your phone and click on Done for the changes to take effect.

Ultimate Mode Change Thermostat Temperature - Version 02.05.00

  • Updated app to support ST’s new Thermostat device handler with ‘Deadzones’

SmartThings new thermostat defines deadzones which would interfere with the operation of this SmartApp when using remote sensors. Update to this version if you’re using Remote Sensors.

Mode Change Thermostat Single Temperature - Version 01.01.00

  • < no change >

I’ve been having problems with this app. I’m using a remote sensor at night, and maybe 50% of the time, the thermostat doesn’t change once the remote sensor reaches the correct temperature. It’s quite annoying, seeing as it gets stuck at either 90 of 45! Is there anything I can do to diagnose where things are breaking?

It could be one of two things:

  1. The sensor update isn’t reaching the hub/app
  2. The app commands aren’t reaching the thermostat

How far is the thermostat and sensor from the nearest repeater? For reliable performance the sensor and thermostat should be no more than 30-40 ft from the nearest repeater. The more repeaters around the house (3-4) it makes for a reliable mesh.

First thing to do, before trying to debug this, reboot your hub and if you’re using a Z-Wave network do a Z-Wave repair. This along with adding a few repeaters fixes 99% of all these types of issues.

To find out if it’s 1 or 2, open you IDE click on your device in my device and click on event list. See if the temp sensor reported the temperature change to ST and what time it reported the change. Similarly for the thermostat you can see what time the app sent the command to the thermostat. The tricky part is that most thermostats don’t send a confirmation back that they received the message.

If this is happening intermittently it’s almost certain that it’s due to weak z-wave/zigbee mesh and adding repeaters should solve the issue.

EDIT: You do realize this is a mode based thermostat and not a scheduler. So it only sets the temperature once on each mode change. If you want a motion or scheduler based thermostat you should be looking at one of our other apps which are designed for that.

EDIT2: One more reason (which happened yesterday) as that the platform stopped executing the SmartApps so they didn’t respond to temperature events and didn’t send the commands to the thermostats. These would be one off issues.

I checked the sensor status in the SmartThings app. It is reporting correctly. And the thermostat responds well to all my manual commands. I also see it reporting in the app.

I know that this is a mode based thermostat, but when using a remote temperature sensor, shouldn’t the app send signals to the thermostat to alternate between 45 degrees and 90 degrees based on the remote sensor’s temperature?
Another weird thing: If the app is in the “broken” state (by which I mean the remote sensor is below my set threshold, but the app still has the thermostat set to 45 degrees), and I go into the app settings and hit Next, then Save, it fixes itself. It checks the status of the remote sensor and then sets the thermostat accordingly (either to 45 or 90). But then it won’t update if the temperature changes on the remote sensor.

@RBoy I left the Live Logging on tonight and found something interesting. Here it is:

There’s a bunch of errors there every time it gets an update from the remote sensor.

Thanks for that, will look into it and come back to you.

Ultimate Mode Change Thermostat Temperature - Version 02.05.03

  • Fixed remote temperature sensor when using multiple modes
  • Optimize operations and compatibility with GoControl thermostats

Mode Change Thermostat Single Temperature - Version 01.01.00

  • < no change >
1 Like

Fixes work. Thanks!


Does anything dictate a mode change for Heat to Cool Automatically for the Ultimate Mode Based Thermostat Temperature Management? Or s this a manual change on each device? @RBoy

Also it doesn’t seem to be functioning correctly. Its getting null error in notifications and setting my cool levels to 90!