[RELEASE] MiHome (Connect) V2.0.1 [Energenie] (not Xiaomi MiHome)

You have to use the hub. It doesn’t use ZigBee or Z Wave so you can’t connect directly.

1 Like

Ok thanks, Back to the drawing board i has i don’t really want more clutter with another hub.

Hi everyone,

It has taken me all day to try and get to a point where I think I can log on to the smarthings IDE, and I get very little spare time.

I have no chance of working out how to make this a smartapp.

Would anybody be willing to create and install this for me and what would you charge?

I couldn’t do it without you log on details.
Search how to creat apps and dh

Tip
Once on github click raw
Ctl a
Ctrl c to copy

Hi I’m new to SmartThings

I’m probably one of the few that bought and uses the mihome relay - which I use for a bathroom extractor fan normally through IFTTT and Alexa mostly

Using the device handlers on this topic my double in wall plug sockets picked up no problem
And my light switch too so that was great

I’m not sure if anyone has experience with the relay switch at all? Sorry to ask (especially if it’s simple)

Have you tried adding it as a socket?

when I use the MIhome connect it already brings through my wall sockets - I can add all the other device handlers in for mihome devices, but had only loaded light switch and wall sockets so far
I’ll give the other device handlers a go and see if it helps

Nope no extra devices pulled through, thanks anyway

Second note - also tried changing the device sub group on the mihome portal to choose both - smartplug and smart lightswitches - but that didn’t help me either - my wall sockets are in the plug group for example but didn’t pull through
I’m thinking the device identifier just isn’t in any of the device handlers as it’s not even one of their more popular products (but had the suitable Wattage needed for the extractor compared to a standard switch)

Think I need get into the api and pull back the device list then look further at least they document the API :slight_smile:

Anyone else having trouble with this smart app recently? Since yesterday I’ve not been able to control my Energenie devices from Smartthings, Alexa and it’s own app works fine. When I go to check my authentication it comes up with a near blank screen and a “next” button at the bottom, if I click that it says it’s having trouble connecting and freezes the screen.

Mine stopped working yesterday as well.

Yes very same issue here. Are you using iOS OR Android devices ?

Android for me, but as this runs in Samsung’s cloud it may not be an OS issue, I’m guessing something has changed with the way authentication is working on MiHome rest api?
Don’t know a great deal how the groovy apps work so I’m going to move my devices to using virtual switches and using Alexa routines to communicate between Smartthings and MiHome.

Thanks I’ve tried logging it with Energenie support

Any Luck with your support query. Mine is also stopped working same issue while authenticating.