SmartThings Community

[RELEASE] Lowes Iris and XFinity CentraLite keypad DTH + Apps

Zack,

The problem was the beep length like you said. It was set to 1 but when you go to the ide and look under my devices and click on the keypad under preferences the value showed 0. So even though it was 1 in the app it was showing 0 under the device. After I did an edit to 1 it know works.

I do have another question.

I have 2 keypads with them both selected but only one will chime.

Also when I open a door it takes a good 3 to 5 seconds before you get a chime. Is this normal?

1 Like

The 3-5 second delay is normal, and so far I haven’t found a way around it (The keypads only wake up every ~7 seconds to check for commands, so that’s as quick as we can get them to beep)

I’ve got 2 keypads in the same configuration, and both chime for me. I’d check to make sure the beep length is set to 1 for both of them, and that they’re both selected. If they still don’t work, you can check the logs, and see if either keypad is reporting an error.

You can check the selection in the API (similar to the device preferences) by going to “My Locations”, and clicking “Smart Apps” for your location.

–Zack

1 Like

I tried that a few times and it did not help I ended up removing and re-pairing the device 3 times. On the 3rd time it worked. Thanks for trying. If if happens again ill let you know

Ok here is the results.

If I turn on chime for both keypads only one will chime but both will beep at exit/entry delay.

They both will work individually. if I select one at a time only the first one will chime.

That’s strange. I’ll play around with that tonight, and see if I can replicate it and see whats going on.

–Zack

Guys, have any of you tried to use this keypad outside garage?
Like with some weatherproof box so that along with arming/disarming it can also open and close garage?

What type of box have you used?
Did the keypad stayed connected with box? any interference?
does it have any bad effect on battery life?

If anyone has done it, can you share the pic( to get an idea about box).

thank you.
Hemanshu

There was a guy in the original thread that did this:

He used a (fairly ugly) box from Amazon to contain it, and didn’t report any issues.

I wouldn’t expect any interference issues, as long as you’re within zigbee range, and battery life shouldn’t change (But keep in mind these things don’t report their battery life correctly).

As far as getting it to open / close the garage, you’d need a second instance of ULM configured to call routines that open or close the garage door, in addition to changing the location mode. Shouldn’t be too much of an issue to do though.

–Zack

1 Like

@zcorneli
Thank you very much, yes I’m okay from routine’s side as to how to make it open garage door along with arming and disarming.
I’ll have to find something good looking(WAF) box from somewhere, I’m also planning to place a zigbee repeater( from lowes) in garage so that range can’t be issue there.

Theoretically anything that’s a non-metallic weatherproof box should work.

There is a slightly better looking box here:

Its really just the same box, but with a white lid, instead of that smoked lid. The 5x5" size isn’t much bigger than the keypad itself, so it’s not “much” oversized.

–Zack

Awesome thank you…

after removing the keypad and device handlers and re adding them I am still having issues. The keypad will not beep when buttons are pressed or for delay. It doesn’t always disarm and im still getting an error at line 228

i took out batteries and will try again tomorrow

I’ll see if I can get a fix in there quickly for that issue with line 228. It shouldn’t be getting stuck in a delay state though, that indicates that something else is going on.

–Zack

When I click on the device from the phone app does the button with the speaker do anything? When I push it while looking at the logs I don’t see anything

The button with the speaker should cause the device to beep, but by default, beep doesn’t log anything

–Zack

Ok, there’s a fix that should fix the null errors on line 228 (I really hope so anyway).

I don’t think that’ll fix getting stuck in that state, but should fix that error.

perhaps the speaker quit on the device…it was working fine until i had issues the other day and unpaired it…it was never dropped so idk why it wont beep

Not sure. Could be a low battery, or just low volume. I think you can hold the 2 button to turn the volume up (and 5 to turn it down?)

–Zack

the update for the error seems to be working…but the volume up and down keys dont seem to do anything at least for me…from what ive read you are correct thought; those should adjust it.

I’ll be working this week on trying to get proper battery reporting (The current reporting is wrong), so perhaps that’ll indicate an issue.

–Zack

1 Like

Ok so I got my chimes working on both the keypads. For know I am using exit/entry beep but not using the chime do to only one will chime at the same time. I’ve decided to try using core Pistons with great results. So using both smart alarm and core Pistons I have finally achieved my goals for using smartthings for my home alarm.