SmartThings Community

[RELEASE] Lowes Iris and XFinity CentraLite keypad DTH + Apps

dth_security
smartapp_security

(John) #766

Brilliant! Thank you SO much! The second one worked for me!


(Arn B) #767

Personally I would prefer battery information be shown as voltage rather than some arbitrary, misleading calculation of “percentage”.

I tried the change shown above. The percentage continues showing 100%, calculated on 3.0 volts.


#768

Second one worked for me too! It was reporting 0% battery after I reset the device yesterday, this fixed it.


(David Lounsbury) #769

Fixed for me as well. I’m going to check some other DHs with similar problems - thanks.

Anyone know if the Github master repo is going to be updated?


(Zack Cornelius) #770

Beat be to the punch here by minutes. Github repo just got updated with this update.


(Arn B) #771

In SHM Delay a user reported they were able to make multiple keypads chime when a door opens. Only the first keypad defined in the list chimed. I have two keypads and was able to reproduce the issue.

Wrote a simple test program code (shown below) and eventually traced it to the DTH.

I’m not a Zigbee guru, but for some reason this worked for me and the user reporting the issue.

/**

preferences {
section(“Keypads to chime”) {
input “theKeypads”, “device.CentraliteKeypad”, required: true, multiple: true, title: “Keypads?”
}
section(“Contact sensors to monitor”) {
input “theContacts”, “capability.contactSensor”, required: true, multiple: true, title: “Contact Sensors?”
}
}

def installed() {
log.debug “Installed with settings: ${settings}”
initialize()
}

def updated() {
log.debug “Updated with settings: ${settings}”

unsubscribe()
initialize()

}

def initialize() {
subscribe (theContacts, “contact.open”, chimeHandler)
}

def chimeHandler(evt)
{
def alarm = location.currentState(“alarmSystemStatus”)
def alarmstatus = alarm?.value
log.debug “chimeHandler entered ${alarmstatus}”
if (alarmstatus == “off”)
{
// theKeypads.beep()
theKeypads.each
{
def beepDevice = it.getDevice()
log.debug “beeping ${beepDevice.displayName}”
it.beep()
}
}
}


(Zack Cornelius) #772

These things are notoriously finicky for their timings (What got me into updating this DTH in the first place was I couldn’t get mine to pair with the initial timings in mitchpond’s DTH)

I’ve updated the repo with the new timings for beep, People should try it, and let me know how it works.


(Arn B) #773

Thank you for the quick response!

Yes, these things are a timing PITA. Recently both my keypads (Iris and Centralite) randomly fell off the network (network light went out) immediately after entering a pin, causing all the icons to blink on the Centralite, and the Off, Partial, On keys to randomly blink on the Iris. This makes a nice, but very unwanted light show. This all started on the Beta 24.5 hub firmware and the simultaneous silent Groovy update.

Reported it to support on the beta forum, who suggested changing routine “private handleArmRequest(message)” to issue the Acknowledgement as shown in the comments, thus avoiding any processing delays. I did that, but for whatever reason set the timing as shown in the beep command change , and negated “def acknowledgeArmRequest(armMode)” and "def sendInvalidKeycodeResponse() by adding a “return false” as the first statement of each of those routines avoiding a double acknowlegement. I was very skeptical, however it works allowing my SHM Delay code to be used without modification, curing the issue. It’s been tested on the current hub firmware and the latest beta 24.8

Should anyone else bump into this issue, let me know and I will send you the code.


(Ian) #774

Hi,
I just got a Iris 3405-L Keypad. I paired it and installed User Lock Manager. I created one user and set 4-digit code with slot one and enabled. I also have the hello home phrase set to disarmed.

When I hit on or partial without passcode or with passcode, there is nothing happened. The SHM does not turn on to Armed away or stay. If I manually set it to armed away then hit the passcode then hit off, it does not disarm also. I am confused how should I set it up. Is there a guide have a clear direction for set it up I can follow? Thank you so much.

I also attach a screenshot for the Iris 3405-L Keypad thing. It only shows the temperature.


(Ian) #775

Weird, it suddenly works???


(Ian) #777

Hi arnb,
Thank you for the reply. I read the withdrawn post from you and read “Simultaneously running ULM and SHM is not recommended”. Does that mean I should just use SHM Delay? Thanks


(Arn B) #778

Use either Ulm or SHm Delay, but not both.


(Ian) #781

I finally got it. I just need your SHM Delay V2 to have total control. Thank you!


(Ian) #782

Today the keypad stopped working then I removed then re-paired then I got the same issue as yesterday. The keypad app does not show any status.


(basschica) #783

Hi, I have 2 Iris 3405-L keypads. There’s been a few times where things kind of flake out. When I got the 2nd keypad I had to go through a myriads of hits and misses to finally get it working. So, for a few weeks, it was working well, though I used to have a door chime beep that originally worked with the first keypad and never has worked since I removed and re-added it. I am not sure where it got to working originally or why that broke, but I do have separate piezo buzzers controlled through the smartlighting app, so that’s not the end of the world.

My current problem is that yesterday, when I went to disarm from a partial mode (for staying at home/in for the night) and the front door keypad (which is “working” right now) didn’t disarm the first time and when I entered things again, it gave a beep and the iris logo was green. Looking at a tablet where I have action tiles in the dining room, it showed green/good to go, so I took my dog out. Then, I got ready for work and maybe an hour later, went to leave and the keypad in the basement was doing the off/partial/on light racing back and forth with the different colors, like the alarm had been triggered. I couldn’t get it to arm with my PIN, so I just used the SmartThings app on my phone once I got in my car and set to Away from there. Later in the day, while at work, I got an intrusion alert for the front door sensor intrusion detected with "IRIS 3405-L Living Room Keypad motion detected detected SHM Delay App at Home). It’s possible it detected something due to a pet, but that’s not normally the case. I don’t see how I can exclude it from motion detection (it’s not in my away sensors at all…I just have the simulated sensors for doors and then a real motion sensor in the basement, glassbreak, and smoke detectors that are monitored…I do not have the keypads listed). I do have the motion on the keypads in the exit delay for the simulated doors, so the simulated front door has exclusion of living room keypad.

When I got home, the keypad was still showing the alarm/chasing lights at the bottom again. I tried re-pairing it several times and when I actually do get it to the pairing mode, I can pair it via ST & I can add the SHM Delay app and associate to the Profile: Delay: Basement Door like I want to, so it essentially “looks” the same in ST as how I have the front door/living room keypad configured, but at that point, I still have the fast blink of the pairing with the connectivity indicator on the upper right of the keypad. I tried a “single” press of the tamper button like others have suggested where you wait 2-3 minutes, but I can wait a 1/2 hr and it still blinks. I can type in a valid PIN and arm/disarm and I’ll get the notifications from ST, so in functionality, the keypad is working… however, it still shows like it is pairing. After a long period of time, I tried removing batteries and putting them back in (without the tamper switch pressed because I don’t want to go through pairing again), and then it loses connectivity altogether and I can’t arm. So… it’s working, so long as I don’t remove the batteries, but it looks as though it hasn’t finished pairing (from the keypad indicator), but SmartThings seems to think it has finished pairing. Also if I look at my “things” list, this basement keypad has the black dot next to it, which I think is normally a “disconnected” indicator, and it says 0% battery remaining in light grey under the name of the keypad, but the keypad, if I go into it, will show disarmed and if I remove the plastic tamper back slider things so it would be in a “tamper” mode, it will immediately show that tamper is triggered, so it’s getting instant feedback and it’s on. I did try other batteries in this process, but everything seems to be the same as I go through the process.

Does anyone have an idea as to how to get the fast blink pairing to “complete” so that if I remove/swap batteries, it doesn’t break everything?


(Arn B) #784

There is a lot of info in your note and I’m a bit short of time right now so here are some thoughts. However I personally would not use the keypad as a motion sensor.

The fast blinking light show occurs when the keypad does not get a response within a certain (unknown) time period. This could be caused by either software or hardware: internet, cloud delays, or whatever, or sometimes a bad Zigbee mesh or network interference on the 2.4k band.

If the keypad’s network light stays on, this can usually be cleared by entering a valid pin, then OFF. Should that not clear it remove then reinstal the battery. If the network light turns off when the device blinks, then it is a timing issue that can likely be fixed using usingmy modified DTH

Please followup by posting in the SHM Delay thread


(Warren) #785

I’m struggling to figure out how to get the keypad (Iris via Amazon) working. I know there is a lot of info here but thusfar wading through 776+ posts hasn’t been fruitful.

What I am trying to do is just use it as a way to arm/disarm the SHM as well as show the current status (armed or not). The primary use case is for someone that needs to simply disarm the system to prevent the stay alarm from going off after it arms. I’m not looking for the delayed arm functionality though I might consider it.

I have the community DTH installed and I was able to get it paired with ST. After the initial pairing ST recognized the device as the Iris 3405-L Keypad as expected and then I pressed the tamper switch a couple of times while network light blinked rapidly and at some point the network light went solid - but no beeps as I recall. The device just shows “Updated: 0” all the time. I uninstalled and reinstalled and the behavior seems the same.

I also installed the User Lock Manager app and attempted to set up a code or two but they keypad doesn’t really do anything except beep when entering the code. Pressing On or Off just plays a two-tone beep and the Off/Partial/On lights just blink. The main “Iris” light is always green regardless of the armed state of SHM.

Perhaps the second stage of pairing isn’t complete but even so I think I must be missing something, namely how SHM and the keypad are linked.

Can anyone explain the link between SHM and the keypad? Any suggestions on how to get the 2nd phase of the pairing to be successful?


(Arn B) #786

Try using my SHM Delay App supports Iris and Centralite keypadd. The Lock Manager app should be removed as it may iinterfere with SHM Delay. Also be sure to use the DTH suggested in the documentation.


(Warren) #787

I’m trying to figure out the app and might be using it wrong, but I have been using the RBoy DTH which the docs mention is also supported but when I go to “Restrict use by mode or to device” under the “Real Keypads…” it says that “There are no devices of this type” so I am at a loss. What is it looking for?


(Arn B) #788

I’m guessing you may be using SHM Delay. If true please follow the following instructions.

Please reinstall from the beta repo. Then go to global settings and scroll down until you find the RBoy DTH flag, then set it on. This feature is not yet fully tested so please post your results, positive and negative, in the SHM Delay thread.

This is a link to the beta release notice.