SmartThings Community

[RELEASE] Lowes Iris and XFinity CentraLite keypad DTH + Apps

dth_security
smartapp_security

(Zack Cornelius) #21

I’m trying to work on getting the chime more consistent (Even if I can’t make it faster, make it consistently X seconds). The keypads state they support the power control protocol, so I might be able to put them into a slightly faster polling cycle (Right now it seems they ‘wake up’ every 7 seconds or so)

–Zack


(Zachary Evans) #22

I guess that feature needs to be weighed against the reduction in battery life…as of now what is the expected battery life?


(Zack Cornelius) #23

They claim (I can’t find where now) 2 year battery life. I don’t think the radio makes up a large portion of that, so it should be OK to wake up the radio a bit more, if I can figure out how.

–Zack


#24

Mine has been working stops working every couple days for a few hours. The lights cycle at the bottom and no input is accepted. Is this from the scheduling or something else?

-Looking at my event list, my keypad stopped sending info to the hub after 616 when I got home and disarmed the system. At 1046, I attempted to arm the system and the lights at the bottom were cycling and no commands were sent to the hub. However, when I removed the keypad from the wall and walked it closer to the hub to see if it was a range issue and the lights were still cycling but the event log showed info from the tamper switch was received.

-At 1153, the keypad started updating the temperature again then this morning at 6am it was showing the correct mode again and functioning properly.


(Greg Walsh) #25

Hi, I’m new and having a consistent problem with trying to connect the IRIS + ULM + SA. I keep getting this error in the logs while using ULM:

c98ccd0a-93bf-414d-9705-837cdaaa3169 5:44:21 PM: error  java.lang.NullPointerException: Cannot execute null+null @ line 228
c98ccd0a-93bf-414d-9705-837cdaaa3169 5:44:21 PM: trace Arm mode: entryDelay
c98ccd0a-93bf-414d-9705-837cdaaa3169 5:44:21 PM: debug Sending status to device...

To get this, I click on Lock Info -> Refresh Lock Data

I have un-paired and re-paired several times and waited several minutes for the system to update and ULM and the keypad to fully connect. Right now I’m just trying to get ULM to work with SHM. I looked at line 228 in the ULM source code and it seems to be a “}” so I’m at a loss (Did I mention, I’m new here?)

There was another post in the old thread about this but I’m not sure what happened with the poster…I don’t think they were explaining it correctly.

Note: I was using SA and the keypad smartapp from early on in the old thread and it worked well enough. The lack of audible feedback was difficult for my family. My goal is to use this solution to get the audible beeps with Entry/Exit Delays in SA.

Greg


(Zachary Evans) #26

I’m having somewhat of a hard time understanding which smart apps you are attempting to use. However, I use as the newest apps mentioned at the top of the post and do not use smart home monitor. I have no issues whatsoever, everything works as it should.


(Greg Walsh) #27

I don’t want to use SHM either. I’m trying to bring on each on one at a time to make sure it all works. When I only have ULM installed, I get that Java error. I’m using the latest code from the links at the top.


(Ray) #28

Maybe try reinstalling ULM again. I don’t think it’s the keypad or device handler issue. More like the smartapps ULM itself.


(Greg Walsh) #29

Thanks Ray,

I uninstalled all SmartApps and then started with ULM. I didn’t get the error this time. Then I turned on SA and the two aren’t talking to each other.

I’ll keep playing but I think the error is between the screen and keyboard now.


(Zack Cornelius) #30

That error actually in the DTH, not the smartapps, but I thought I thought
I had fixed it. I’ll check the code to make sure the fix is in.

The way you can avoid that, when it happens, is to set ULM to send status
to the keypad, then manually execute the goodbye and I’m back routines

Not sure why ULM and SA wouldn’t talk, maybe a missed step in the
instructions?

----Zack


(Greg Walsh) #31

Thanks Zack!

After I deleted everything, I succeeded when I followed the directions.

I was able to get them to sync up. Again, it was my error in the SmartApp. I would recommend that the part where you choose which status to do in which mode was made clearer (for future users). I thought it meant which status could be changed in which mode so I picked all three for each one. I thought I was enabling it to change states regardless of what mode I was in but then realized that I was actually trying to set three statuses!


#32

Is there any way to figure out what is causing my keypad to stop working? Every couple days it stops communicating with the hub and the lights cycle at the bottom for a few hours. My hub is approximately 10-12 ft away from my hub in line of sight with each other so I don’t think it is out of range. I also switched a majority of my devices over to 5Ghz to cut down on interference. Im at a loss since it seems everyone else is working now.


(Zachary Evans) #33

Batteries? Just because it says they are good doesnt mean anything


(Ray) #34

Beside battery there could also be a flaky zigbee repeater nearby that the keypad could be using instead of direct connection to the hub. You mentioned about switching over to 5Ghz but how about the location of your WiFi router? In between the hub and keypad? Beside the ST hub? Your neighbor WiFi? If possible how about turn off your 2Ghz for testing?


#35

Batteries are new. My router is about 3 feet away from the hub on the opposite side of hub from the keypad. I removed my ZigBee lights for now. I will try and figure out how to turn off the 2.4ghz and give that a try for a few days as well.


(Zack Cornelius) #36

The cycling lights indicate “Busy”, which could indicate flaky zigbee comms, or the keypad not getting a response from the hub (Potential software issue)

The SmartThings hub within 3 feet of the WiFi router is going to be quite bad for signal quality (The router will just drown out anything else), so there definitely might be some interference on the 2.4G band there.

For the software issues, it would hopefully throw an error when it happens (Or at least show something), so if you can catch it with the live logging running, there might be some more info there.

–Zack


I cant figure out how to get the DELAY function to work on the Iris Keypad, any help would be appreciated
#37

Ok so my keypad started acting up again 14hrs ago but I have been home with pneumonia so I did not notice. I pulled the keypad off the wall and set it next to the hub in hopes of making it easier for it to connect. I have my laptop sitting with the live logger on so hopefully I will get something out of it.

After a few minutes sitting next to the hub it began communicating with the hub again. @zcorneli can I send you the live logging data to see if there is any errors? I’m assuming my issues are caused by my router. I disabled my 2.4ghz wireless, so hopefully this will give me more of an idea if the signal is just being drowned out.


(thatninjachris) #38

thanks to all that have contributed to this.

im all set up with the iris keypad v2, shm, have the dth, ulm, and smartalarm, but i cant get the delays to function when arming and disarming…

can anyone be of assistance, what am i missing? i can find the option in smartalarm and have it set to 30 seconds, but i dont get 30 second notifications and it essentially doesnt delay??


(Daniel Eshbaugh) #39

Someone please help. I have alot left over from when I had xfinity and I’m NOT a programmer and I know nothing at all about it. I would really like to use my keypad, motion sensor, and door/window sensors. I have gotten the centralite 3400 to pair but it is unknown and I have no idea what to do next. I know it has something to do with a manager and app. Please I need step by step instructions.


(Scott Windmiller) #40

What is the purpose of this setting?
I just set all this up according to the post above and it all worked fine.
I am using the keypad as a backup to Presence and for people who are not setup with Presence sensors.

I left without using the keypad and my system changed modes and armed as it usually does.
When I got home my Presence triggered the mode change but when I opened the front door the keypad was beeping.
I was able to stop the beeping by typing in my code and hitting off.
After that the lights at the bottom just scroll back and forth and have been for a while.
I just switched that setting back on and manually switched my mode to away and the keypad immediately picked up the change and started beeping (exit delay).

Confused, should I have this setting on or off?

Thanks,
Scott