SmartThings Community

[RELEASE] Lowes Iris and XFinity CentraLite keypad DTH + Apps

dth_security
smartapp_security
(Ian) #781

I finally got it. I just need your SHM Delay V2 to have total control. Thank you!

1 Like
(Ian) #782

Today the keypad stopped working then I removed then re-paired then I got the same issue as yesterday. The keypad app does not show any status.

(basschica) #783

Hi, I have 2 Iris 3405-L keypads. There’s been a few times where things kind of flake out. When I got the 2nd keypad I had to go through a myriads of hits and misses to finally get it working. So, for a few weeks, it was working well, though I used to have a door chime beep that originally worked with the first keypad and never has worked since I removed and re-added it. I am not sure where it got to working originally or why that broke, but I do have separate piezo buzzers controlled through the smartlighting app, so that’s not the end of the world.

My current problem is that yesterday, when I went to disarm from a partial mode (for staying at home/in for the night) and the front door keypad (which is “working” right now) didn’t disarm the first time and when I entered things again, it gave a beep and the iris logo was green. Looking at a tablet where I have action tiles in the dining room, it showed green/good to go, so I took my dog out. Then, I got ready for work and maybe an hour later, went to leave and the keypad in the basement was doing the off/partial/on light racing back and forth with the different colors, like the alarm had been triggered. I couldn’t get it to arm with my PIN, so I just used the SmartThings app on my phone once I got in my car and set to Away from there. Later in the day, while at work, I got an intrusion alert for the front door sensor intrusion detected with "IRIS 3405-L Living Room Keypad motion detected detected SHM Delay App at Home). It’s possible it detected something due to a pet, but that’s not normally the case. I don’t see how I can exclude it from motion detection (it’s not in my away sensors at all…I just have the simulated sensors for doors and then a real motion sensor in the basement, glassbreak, and smoke detectors that are monitored…I do not have the keypads listed). I do have the motion on the keypads in the exit delay for the simulated doors, so the simulated front door has exclusion of living room keypad.

When I got home, the keypad was still showing the alarm/chasing lights at the bottom again. I tried re-pairing it several times and when I actually do get it to the pairing mode, I can pair it via ST & I can add the SHM Delay app and associate to the Profile: Delay: Basement Door like I want to, so it essentially “looks” the same in ST as how I have the front door/living room keypad configured, but at that point, I still have the fast blink of the pairing with the connectivity indicator on the upper right of the keypad. I tried a “single” press of the tamper button like others have suggested where you wait 2-3 minutes, but I can wait a 1/2 hr and it still blinks. I can type in a valid PIN and arm/disarm and I’ll get the notifications from ST, so in functionality, the keypad is working… however, it still shows like it is pairing. After a long period of time, I tried removing batteries and putting them back in (without the tamper switch pressed because I don’t want to go through pairing again), and then it loses connectivity altogether and I can’t arm. So… it’s working, so long as I don’t remove the batteries, but it looks as though it hasn’t finished pairing (from the keypad indicator), but SmartThings seems to think it has finished pairing. Also if I look at my “things” list, this basement keypad has the black dot next to it, which I think is normally a “disconnected” indicator, and it says 0% battery remaining in light grey under the name of the keypad, but the keypad, if I go into it, will show disarmed and if I remove the plastic tamper back slider things so it would be in a “tamper” mode, it will immediately show that tamper is triggered, so it’s getting instant feedback and it’s on. I did try other batteries in this process, but everything seems to be the same as I go through the process.

Does anyone have an idea as to how to get the fast blink pairing to “complete” so that if I remove/swap batteries, it doesn’t break everything?

(Arn B) #784

There is a lot of info in your note and I’m a bit short of time right now so here are some thoughts. However I personally would not use the keypad as a motion sensor.

The fast blinking light show occurs when the keypad does not get a response within a certain (unknown) time period. This could be caused by either software or hardware: internet, cloud delays, or whatever, or sometimes a bad Zigbee mesh or network interference on the 2.4k band.

If the keypad’s network light stays on, this can usually be cleared by entering a valid pin, then OFF. Should that not clear it remove then reinstal the battery. If the network light turns off when the device blinks, then it is a timing issue that can likely be fixed using usingmy modified DTH

Please followup by posting in the SHM Delay thread

(Warren) #785

I’m struggling to figure out how to get the keypad (Iris via Amazon) working. I know there is a lot of info here but thusfar wading through 776+ posts hasn’t been fruitful.

What I am trying to do is just use it as a way to arm/disarm the SHM as well as show the current status (armed or not). The primary use case is for someone that needs to simply disarm the system to prevent the stay alarm from going off after it arms. I’m not looking for the delayed arm functionality though I might consider it.

I have the community DTH installed and I was able to get it paired with ST. After the initial pairing ST recognized the device as the Iris 3405-L Keypad as expected and then I pressed the tamper switch a couple of times while network light blinked rapidly and at some point the network light went solid - but no beeps as I recall. The device just shows “Updated: 0” all the time. I uninstalled and reinstalled and the behavior seems the same.

I also installed the User Lock Manager app and attempted to set up a code or two but they keypad doesn’t really do anything except beep when entering the code. Pressing On or Off just plays a two-tone beep and the Off/Partial/On lights just blink. The main “Iris” light is always green regardless of the armed state of SHM.

Perhaps the second stage of pairing isn’t complete but even so I think I must be missing something, namely how SHM and the keypad are linked.

Can anyone explain the link between SHM and the keypad? Any suggestions on how to get the 2nd phase of the pairing to be successful?

(Arn B) #786

Try using my SHM Delay App supports Iris and Centralite keypadd. The Lock Manager app should be removed as it may iinterfere with SHM Delay. Also be sure to use the DTH suggested in the documentation.

(Warren) #787

I’m trying to figure out the app and might be using it wrong, but I have been using the RBoy DTH which the docs mention is also supported but when I go to “Restrict use by mode or to device” under the “Real Keypads…” it says that “There are no devices of this type” so I am at a loss. What is it looking for?

(Arn B) #788

I’m guessing you may be using SHM Delay. If true please follow the following instructions.

Please reinstall from the beta repo. Then go to global settings and scroll down until you find the RBoy DTH flag, then set it on. This feature is not yet fully tested so please post your results, positive and negative, in the SHM Delay thread.

This is a link to the beta release notice.

(Warren) #789

I was using SHM Delay v2. I’m trying the beta now but not having great results so I’ll post over there in the beta thread.

#790

My keypad ran low on batteries so I swapped in two freshies (one at a time) and everything seems good except

  1. I forevermore see 0% battery… both the app and debugging in the IDE show a clear 0%. How do I get this to refresh/reset?
  2. The keypad doesn’t actually work anymore with Door lock code user management with notifications and automatic relock

These two things happened at the same time but might be unrelated, I’m not really a pro so I’m not sure. Any thoughts on what I can try next to debug this?

(jay yankacy) #791

I have 0% on my 2 keypads as well! But, they still work.

1 Like
(Arn B) #792

The latest keypad DTH release corrects this issue that was caused by a change to the ST Groovy language. More info is available in my SHM Delay SmartApp documentation Section 14

1 Like
#793

Good to know! I actually updated my DTH before coming here to post… that didn’t fix things. We’re talking about Centralite Keypad by Mitch Pond, Zack Cornelius right?

(Arn B) #794

That is correct.
https://raw.githubusercontent.com/miriad/Centralite-Keypad/master/devicetypes/mitchpond/centralite-keypad.src/centralite-keypad.groovy

#796

I just realized I was not using the mitchpond DTH. I have it in my IDE and I did, in fact, update it before posting here, however I was actually using v01.02.01 of the RBoy DTH. I’ve now gone ahead and updated the actual DTH I’m using and I’ll see what happens!

I’m seeing odd debug logs that make me wonder if I need to re-sync the keypad… perhaps it somehow got half-disconnected when the batteries died?

(www.rboyapps.com - Make your home your butler!) #797

If you’re using the Enhanced ZigBee DTH you need to use version 01.05.00 or newer to use with SHM Delay 2.0 and Lock User Management simultaneously.

#798

Noted. I’m on the lates RBoy DTH and App for lock management. I am not using the SHM delay thing you speak of (at least not intentionally…?).

(www.rboyapps.com - Make your home your butler!) #799

Whoops, my bad I think I mixed your post with another post. SHM Delay is another app by Arn and some folks like to use in conjunction with the user management app. Feel free to PM me for details.

(Steve White) #800

For those experiencing problems with pairing the Iris keypads and having the network light continue to flash, here’s one solution that works for me.

After the initial pairing is successful, the network light will continue to blink. Disregard this for a moment, and exit device inclusion. Open the device in the mobile app to ensure that it’s sending Events to ST. This indicates that the keypad has paired successfully. Once events have been confirmed, press the tamper switch on the back 5 times. Within 1-2 seconds the network light will stop blinking and the keypad will remain connected.

I’ve successfully replicated this process on all 3 of my Iris keypads as part of migrating to the v3 hub.

3 Likes
(Jeremy) #801

I have this keypad but have not used it yet. I got it in a security pack that was on clearance for $38. What kinds of things can I do with this keypad? Looks like motion detection and then the buttons. Can the buttons be used like a remote? Anyway, I’m curious what it can be used for and it looks like there are a lot of smart people in this thread.