SmartThings Community

[RELEASE] Lowes Iris and XFinity CentraLite keypad DTH + Apps

dth_security
smartapp_security
(Arn B) #749

Take your time. First get the keypad functional. Then, install the SHM Delay Version 2 app or whatever you prefer. I understand it appears complicated to get it all working, however I feel the result is worth the time and effort. As I said earlier, take your time and follow the directions.

As for it, or anything, working after the “Big Transition”, I’ve read it will, but who knows.

#750

Got everything installed and paired so far. It will probably take me a week to figure out how to setup the app properly. Fingers crossed. I really appreciate the work you guys put into this.

(Erik) #751

If only there was a weatherproof keypad that could be used to open and close garage doors!!!

(lehighkid) #752

I use my Iris keypad in combination w/ Lock Manager for exactly this. I can set user codes, tie to routines, etc.

Further up in this post #89, someone provided a response link to weatherproof mounting cases from Amazon. I have had mine up and running for several months issue free.

#753

I’ve been out of the loop for a while - is this still the best Smartapp to use with this Iris keypad?

I’m trying to get it working with the Smart Alarm smartapp as suggested, but I can’t seem to do two things - successfully set a key to press or hold to arm the alarm in either state, or to be able to set a PIN to disarm. The only PIN reference is to block API access?

Any ideas?

(Arn B) #754

You may want to check out my SHM Delay App, full support for Exit and Entry delays, Iris and Centralite/Xfinity keypads, simulated keypads (beta version), user pins and more.

BTW Smart Alarm was deprecated and replaced with Smart Home Monitor

1 Like
#756

I guess this answer is still true. I tested the panic button on my Iris keypad after installing it a few days ago, and the icon in the device screen still shows it in red.

( Cosmo) #757

Modify the DTH not to display the panic tile

(Christopher Saksa) #758

I’ve read through this thread a bunch of times now, and followed pairing directions to a T. My Iris partially pairs but does not complete pairing? Is this an issue with a newer version of the IRIS Smart Keypad? I hit the tamper switch and the rapid blinking continues for as long as I let it. The device is 5 feet from the hub.

I’m stumped…

(Zack Cornelius) #759

Make sure you’ve got the device handler properly installed. It will do that if it’s using the generic “Thing” handler.

You can check with handler it’s using in the API, under my devices. Find the device, and look at the handler.

–Zack

#760

This morning I received an alert from the ST app that my Iris keypad is reporting 0% battery. I’ve only had this thing for a couple of months. It’s functioning properly otherwise, and the battery light on the keypad itself is not lighted up, so I think the notification is wrong. When I look at the “Recently” tab for the device, it shows that yesterday from about noon to 4:30 PM the battery level kept bouncing back and forth between 80% and 0%. Sometimes there would be just a few minutes between each battery report, and sometimes it would report both percentages back-to-back in the same minute. The last battery reported was 0% as of 4:30 yesterday, so I guess that’s why it’s still showing 0% currently on the “Right Now” tab. It doesn’t update when I hit the refresh button on the Right Now tab. I’ve removed each battery one at a time from the keypad (removed one, wait a little while and put it back in, then removed the other, waited a little while, then put it back in). No change.

Any recommendations?

(Christopher Saksa) #761

Zack,

Thanks for your reply… I had the DTH installed and the Iris was recognized in ST. I got frustrated with the Iris system, so I returned them and bought two centralite keypads.

(Cody) #762

Is this device handler for the Iris keypad compatible with the new ST app and the hub V3? I had it working on my V2 hub in the old app, but now I can’t get it to pair properly. it constantly says “Checking status…”

(Mark) #763

I’m not interested in using the new app so haven’t tried at all myself, but IIRC, it’s still not possible to use custom device handlers with the new app?

(John) #764

It has nothing to do with you. Mine are doing the same thing. Per ST Support, they made some changes on the “backend” that are affecting some non-stock DH’s which of course they don’t support. So we’re stuck unless someone can figure out how to fix the code in the DH.

[Release] SHM Delay Version 2.0
#765

I was given this fix from another thread. In the DTH, somewhere around line 387 or 391, you’ll need to change this:

result.value = Math.min(100, (int) pct * 100)

to this:

result.value = Math.min(100, (int) (pct * 100))

or this:

result.value = Math.min(100, Math.round(pct * 100))

When you’re done, save the change and publish the DTH to yourself, then refresh it in the ST app.

3 Likes
(John) #766

Brilliant! Thank you SO much! The second one worked for me!

(Arn B) #767

Personally I would prefer battery information be shown as voltage rather than some arbitrary, misleading calculation of “percentage”.

I tried the change shown above. The percentage continues showing 100%, calculated on 3.0 volts.

1 Like
#768

Second one worked for me too! It was reporting 0% battery after I reset the device yesterday, this fixed it.

(David Lounsbury) #769

Fixed for me as well. I’m going to check some other DHs with similar problems - thanks.

Anyone know if the Github master repo is going to be updated?