SmartThings Community

[RELEASE] Lowes Iris and XFinity CentraLite keypad DTH + Apps

dth_security
smartapp_security

(John) #672

@arnb reinstallation of SHM worked as you indicated. Thanks for this and all of your efforts to help the community.


(Steve) #673

Hey everyone, I’ve read through the majority of this thread, and am not able to find the specific problem I’m having. I apologize if it’s here and I just missed it, but man, this thread is long.

I am a new user (installing this week) and picked up an IRIS keypad model 3405_L because it seemed like the right thing to use for my security at my business. I want to have multiple users and track who uses it. So I have User Lock Manager (ULM) app installed as well as Smart Home Monitor (SHM). But I can’t make the Keypad arm or disarm the system.

On the ULM app I have the Iris keypad selected under “select locks” and under Keypad Info I have the Iris Keypad selected as well. For routines I have “Goodbye!” set for arm/away and “I’m Back!” set for disarm.

I have 1 user added with a code of 1234 to play with it. From what I understand (I saw conflicting info) I should be putting in the code 1234 then “on” or “partial” to set Arm/Away on SHM. And 1234 “Off” to disarm SHM. Neither does anything.

I’ve tried doing the code without the buttons. I’ve tried doing the code then on/off and have tried on/off then the code. No reaction.

When I look at the keypad in my things it says “Disarmed”. If I select the device from the list I see a control panel with a big green “disarmed” on it. There are 7 tiles below that. “motion” and “Off” are in color (blue and green respectively) there are 5 more that are “grey”: Tamper, Panic, a speaker, a reset/refresh symbol and “80% battery”. Recent activity shows changes whenever I’ve made changes in the ULM. So if I unlink the keypad and relink it. it will give updated status. They keypad beeps whenever I touch a button. and if I set the ULM to notify me if a bad code is used, as soon as I type in a 5th number it does a two tone beep. So it seems to know something is happening.

Help? Any ideas why it wouldn’t be sending a signal? Am I missing something?

Update: I just noticed it’s updating the temperature in the right now and recently tabs. So its definitely communicating at least for that…

Steve


(Arn B) #674

ULM deprecated see following link


#675

I just installed the Iris Keypad 3405-L1 and I am using ethayer’s Lock Manager and arnb’s SHM Delay. Everything is working as expected except for the exit/entry beeps. How do I enable those? A second but less pressing questions is how do I use/enable the panic button?

Thanks.


(Steve) #676

Thanks! I’ll give it a shot tomorrow am.

That is the keypad DTH I am using, but not the same lock manager app I have installed… And I assume the delay is just to give entry/exit delays. I saw a bunch about that but was worried about getting it actually functional before trying to get that running. Sweet to have it all here in 1 reply though! Thanks again. Here’s hoping!

Steve


(Arn B) #677

Panic Button: no idea don’t have Panic on my Xfinity keypad

Sounds: in no particular order


#678

When I manually test the keypad tone it works. Toggling #8 does not affect the manual tone test. Still can’t get entry or exit tones. Toggling #8 also does not affect entry or exit tones.

I have discovered a larger problem. The exit delay is not working…

Edit: I just figured out the exit delay only works when you arm from the keypad. I was testing from my phone at times. Still not exit or entry tones.

Second edit: Exit delay is only working with the keypad and only when set to Armed/Away. I would like the exit delay to work with Armed/stay. Is this possible?


(Arn B) #679

Confused about why no tones on exit delay or entry delay, but tones from DTH screen. It’s failing in two independent SmartApps. Usually it’s the wrong DTH. Make sure it matches image below. You should also see the commands being sent to the device by tapping on DTH “Recently”

Please try following for exit tone.
In Lock Manager keypad profile settings set:
Act as SHM device : on / true
Arm Delay 30 or number of your choice
Then arm system from keypad in Away (xfinity/centralite) On (Iris)

For entry tones in SHM Keypad Profile
On settings page 1 Alarm elay time in seconds: 30 or number of your choice
Make sure the Keypad is specified in the SHM Delay profile (second settings screen, scroll down)
Tones should sound when armed in Away/On mode and associated contact sensor opens


(Arn B) #680

Armed / Stay is generally “Night” mode. In the SHM Delay Global Settings set True Night Mode to Off/False

BTW are you using an Iris or Xfinity/Centralite Keypad?


(Steve) #681

OK. Installed all that stuff (Except the delay app, not messing with that right now). Same problem.

I see the keypad. It feeds back temperature just fine. When I install or change anything in the app I et a message saying the iris keypad is disarmed. I’ve taken a bunch of pics of my app screens to see if that makes anything jog for anyone looking. I am beginning to think the keypad its self is just faulty? (and would have settled on that a long time ago if it wasn’t for the fact that it’'s clearly communicating on SOME level)

Did I mess something up?

Steve


(Arn B) #682

In the Keypad settings set Arm/Stay and Arm/Night to Night routine.

Are any Core, WebCore, or other app installed that may interfere with nominal keypad operation?

Do beep tones work from DTH? tap speaker icon?

Try arming your system with the keypad by entering your pin; then On (Away)
(Not sure it could be On then pin as on my Xfinity)
Should give 30 second exit beeps (last 10 secs are very fast)
then after delay period system should go into Away mode, check on your Phone app SmartThings status


(Steve) #683

Set Arm/Night, etc: OK I set them to “I’m Back” I dont have a night routine. its pretyt much a binary system. everything is all on or everything is all off. Since its a business we are either in there and working or everyone is gone.

core/wecore: I don’t think so? but nothing of those names for sure. Here are the apps I have installed:

The keypad Beeps when I press buttons. If I do a few of the things I found in other places like push and hold 8 to change a setting… it gets the beeps. It beeps differently at me if I try to enter 5 numbers. And at various stages of playing with this and trying different apps. At one point I would get a delay beep when a contact was tripped no matter the state of the system… door contact 1 is opened and the delay would start. beep…beep…
for about 20 seconds then a faster beeping then it would stop. (This happened when I was using SmartAlarm app for a bit before i figured out it was not being supported any more and thought maybe that was the issue). Panic button creates a tone when I push it.

I’ve tried both pin/on pin/off and on/pin off/pin. None of them arm.

I do have some key fobs I got with the stuff I bought a long time ago I was going to use it with securifi almond + but the router quit before they ever got the support running for it right. And those work perfectly. At this point just thinking I’ll go buy a few more of those and have everyone carry one. cause man. I;ve put days into this so far and just cant make it work.

Everything else is working brilliantly. just can’t get the keypad to arm or disarm the system. It acts like it doesn’t send the contact or signal when the code is pushed.

Steve


(Arn B) #684

I beleive on the Iris it is pin followed by ON/Off/Partial Can someone with a working Iris keypad please confirm

I assume Smartalarm is removed, but it along with the DTH test confirms key pad works. There is only exit delay, no entry delay in the Keypad module, that requires SHM Delay, however until the exit works I suggest waiting.

Just a thought, you do have User’s with Pins added to the Lock Manager?

Panic button AFAIK is not supported beyond the DTH. What is should do is go into immediate intrusion alert status. ST in their wisdom has not documented that process so developers are stuck with using simulated contact sensors

Please do some additional exit delay testing then check the DTH “Recently” for any issues or missing commands. You should see it issue the Exit Delay command.


(Steve) #685

Yeah. that’s where I am. Smart alarm app was removed to make sure it wasn’t conflicting.

Yeah I did add a single user with a generic 1234 password to play with. Here’s where my setting are. I JUST noticed at the top of the user panel, it says active/0 did I fail to engage it somehow?


(Arn B) #686

The active/0 also shows on all my users, no idea what it means
You need to use pin 8974 based upon what’s in the images

Edit: If you are truly in a on / off situation, suggest setting the arm/stay|night to Goodbye so if Partial is used the system arms


(Steve) #687

Yeah I switched the code to 1234. wasn’t paying attention to realize it was different on the previous one.

I;m not too worried about what happens with that partial switch right now either as literally nothing I can do can make it arm. I’ve played around with all of those settings and made them be different things to see if change happened and nothing changes it. pretty sure my keyboard is just defective.

Is there a way to determine if something is happening when I do pin/on or pin/off (or off/pin on/pin)?


(Arn B) #688

Check in your smartphone app dashboard or open the door the alarm should go off


(Steve) #689

The alarm goes off if I arm the system from the app or one of the key fobs I have. But I can’t arm the system (or disarm it) from the keyboard. It’s not accepting an arm signal from the keyboard. (the problem I’ve been fighting with). the keyboard is there. it’s clearly working on some level. the temperature readout works. it seems to know it’s there and occasionally if I play around with it it gets some sort of signals to/from the keyboard.

the only problem is that I can not use a code to activate or disarm my Smart Home Alarm smartapp. pin/ON does not Arm it. pin/OFF does not disarm it.


Iris Keypad stopped working recently
(Steve) #690

Something else I just tried if I press the button from the keyboard device dashboard, my keypad will beep. so there’s defintiely info going from app to keypad too.


#691

True Night Mode is off. Are you saying I should be able to achieve an exit delay when setting Armed/Stay?

Edit: I am using the Iris keypad.