SmartThings Community

[RELEASE] Lowes Iris and XFinity CentraLite keypad DTH + Apps

dth_security
smartapp_security

(Arn B) #654

Lock Manager does not support EntryDelay. One way to achieve an entry delay is with my Smartapp, SHM Delay.
Btw ULM is deprecated, use ethayer’s Lock Manager


(Kian) #655

So use ethayers Lock Manager and SHM Delay along with SHM(SmartThings official app)?


(Arn B) #656

That’s correct. Be sure to use the keypad dth suggested in the SHM Delay documentation


(Eddie Tsui) #657

Can someone post a step by step instruction to add Iris Keypad as a new device? Some of the instruction have “Install DTH” as the first step, but how to install DTH? Do I have to add my hub to the Developer page first? Thank you much!


(Arn B) #658

Check @jdroberts Faq


(Arn B) #659

When you are ready

  1. install a Keypad DTH
    The direct link to the Keypad DTH I suggest is at the end of this message.
    The Repo settings are miriad Centralite-Keypad master The name is Centralite Keypad.
  2. Pair the keypad with the Hub and test it
  3. then install @ethayer’s Lock Manager
  4. then my app SHM Delay

(Tapan Samaddar) #660

I copy-pasted the above code and clicked “Create”

I got the following error message:


No signature of method: script_app_metadata_e79af261_7c81_4e4e_a200_f12f886c9467.metadata() is applicable for argument types: (script_app_metadata_e79af261_7c81_4e4e_a200_f12f886c9467$_run_closure1) values: [script_app_metadata_e79af261_7c81_4e4e_a200_f12f886c9467$_run_closure1@2e768059] Possible solutions: getMetadata(), getState(), setState(java.lang.Object), metaClass(groovy.lang.Closure)


What am I doing wrong?


(Arn B) #661

Add it to devices not apps


(Eddie Tsui) #662

@tapsemi, You have to install select the Lock Manager first (which is the second option), before installing the other 3 childs. And another tip is to pick “Z-wave Lock with Code” as the type under IDE My Device for the Lock Manager to recognize it has a keypad devise.

I was able to install the Lock Manager smartapp. But my next problem is how to set disarm passcode.

This is what I did on the SmartThing (ST) app on my phone:
Markplace> Lock Manager> New Keypad, and added the smartapp on the keypad.
Markplace> Lock Manager> New User> Set Code 4-8 digits, select slot 1.

After doing that I the keypad appeared to be armed when I arm the ST app. But right now the keypad will trigger an alarm when I press any key on the keypad. It’s a good sign because it means the keypad and ST is communication, but that also means the passcode doesn’t work. How do I use the keypad to disarm ST system? Thank you.

Really shout out to all the programmers. You guys are amazing typing up the code and instructions! Really appreciate your works!!


(Arn B) #663

Are you installing a keypad or a lock?

In either case

  1. remove the market place app
  2. then follow the directions to install this lock manager into the IDE.
  3. Then on your phone go to Automations–>tap Smartapps on top menu–>scroll to bottom–>tap + Add a Smartapp–>Scroll to bottom–>tap + My apps. Install lock manager from the list

(Joel W) #664

OK I need some help with the IOS keyboard config! I was going around the house calibrating all my temperature sensors. I came to the Centralite keypad, and was not able to use a minus 5 degrees. There is only an option for + degrees. Can someone give me some guidance on this?


(Nick) #665

I’m looking at getting an Iris, but need some direction on what can/can’t be used together.

My current setup is SHM with a few local devices, and one simulated device (to allow for entry delays through WebCore). I’d like to keep using SHM as the “brains” due to local processing, but others have indicated that lock manager and SHM should not be used together.

If I don’t use lock manager, am I still able to create codes and use SHM for “monitoring” and WebCore for entry delays?


(Mark) #666

FYI, SHM doesn’t run completely locally.

The alerts you setup in SHM can run locally, assuming all the devices themselves are eligible for local execution (I think).

However, arming and disarming SHM requires that your hub has an active internet connection and the ST cloud is functioning too.

And any SHM monitoring rule that incorporates a simulated sensor wouldn’t run locally too.

At least that’s how it was working the last time I checked.


(Nick) #667

Provided the devices are all local, I believe that arm/disarm would also be local. And again, as long as devices are local, the alerts are also local.

I’m aware that using a simulated sensor and WebCore would make that component not run locally (and I accept that part of the system would be down in the case of an outage), but is there some way to integrate the keypad into SHM such that I can keep as much as possible running locally (ie, the non simulated devices), since we know that lock manager runs entirely in the cloud?


(Mark) #668

But how would you arm/disarm SHM if the cloud were down? Mobile app, routines, WebCoRE, none of them would be functional.

Iris keypad isn’t officially supported, so it requires a custom device handler. No custom device handlers are eligible to run locally, unfortunately.


(John) #669

Hi. I bought the IRIS keypad on ebay and am in the process of integrating it into my system. I installed the DTH, ULM and SM apps at the top of this post. When I followed the instructions, I was able to get the keypad to “Arm” (and disarm) the system; however, whenever motion was triggered, or a door was opened (past the delay time), SM fails to indicate/recognize that there is an intrusion. I am therefore not able to get a text notification if there is an intrusion while the system is armed.

To remedy this, I re-installed the ULM and SM app and configured as suggested. This did not make a difference. Reading through the previous posts, I noticed that SM could conflict with SHM, so I uninstalled SHM. This also did not make a difference.

I am intrigued by @arnb recommendation to use e Thayer’s lock manager and the delay for SHM. I however do not know how to re-install SHM.

Does anybody have a suggestion on how I can get the ULM/SM recognize/notify me of an intrusion?

Does anybody know how to re-install SHM?

I appreciate the support on these forums!


(Arn B) #670

I’m not sure this will work but it’s worth a try.

  1. In your ST phone app, tap on bottom ‘Automation’
  2. tap ‘+ Add a SmartApp’
  3. tap ‘:heart: SmartThings Recommends’
  4. Tap ‘Smart Home Monitor Security’
  5. You are on your own. Let us know if it works

(Mark) #671

SM = smart alarm? Smart alarm is a pretty old smartapp at this point that’s not really actively developed/updated anymore. Smart home monitor, for all its flaws, is a better bet in my opinion. Especially with the delay smartapp from this thread.

If you uninstall SHM security in the IDE you should be able to reinstall it from the dashboard in the mobile app.


(John) #672

@arnb reinstallation of SHM worked as you indicated. Thanks for this and all of your efforts to help the community.


(Steve) #673

Hey everyone, I’ve read through the majority of this thread, and am not able to find the specific problem I’m having. I apologize if it’s here and I just missed it, but man, this thread is long.

I am a new user (installing this week) and picked up an IRIS keypad model 3405_L because it seemed like the right thing to use for my security at my business. I want to have multiple users and track who uses it. So I have User Lock Manager (ULM) app installed as well as Smart Home Monitor (SHM). But I can’t make the Keypad arm or disarm the system.

On the ULM app I have the Iris keypad selected under “select locks” and under Keypad Info I have the Iris Keypad selected as well. For routines I have “Goodbye!” set for arm/away and “I’m Back!” set for disarm.

I have 1 user added with a code of 1234 to play with it. From what I understand (I saw conflicting info) I should be putting in the code 1234 then “on” or “partial” to set Arm/Away on SHM. And 1234 “Off” to disarm SHM. Neither does anything.

I’ve tried doing the code without the buttons. I’ve tried doing the code then on/off and have tried on/off then the code. No reaction.

When I look at the keypad in my things it says “Disarmed”. If I select the device from the list I see a control panel with a big green “disarmed” on it. There are 7 tiles below that. “motion” and “Off” are in color (blue and green respectively) there are 5 more that are “grey”: Tamper, Panic, a speaker, a reset/refresh symbol and “80% battery”. Recent activity shows changes whenever I’ve made changes in the ULM. So if I unlink the keypad and relink it. it will give updated status. They keypad beeps whenever I touch a button. and if I set the ULM to notify me if a bad code is used, as soon as I type in a 5th number it does a two tone beep. So it seems to know something is happening.

Help? Any ideas why it wouldn’t be sending a signal? Am I missing something?

Update: I just noticed it’s updating the temperature in the right now and recently tabs. So its definitely communicating at least for that…

Steve