SmartThings Community

[RELEASE] Lowes Iris and XFinity CentraLite keypad DTH + Apps

dth_security
smartapp_security

(Mike Breault) #623

I did that, I can now see my users, just entering the codes now doesn’t do anything…just keeps flashing all the modes


(Arn B) #624

Yep bumped into that and wish I understood the cause, very annoying. I can key codes in and nothing happens.

In the Lock manager app–>Keypad–> “act as SHM device” make sure it is ON, then try using the Smartthings phone app Dashboard to change the armed mode. Thist sends a status change to the device and usually clears it. Once it clears the good news is it rarely happens.

Should you determine how to recreate the blinking lights, please post it here.


(Mike Breault) #625

I actually figured it out, the problem I had was that I changed the device type from centralite keypad to the z wave reporting lock like the instructions say to, once I changed it back to centralite keypad its been working like a charm since :smiley:


(Arn B) #626

Good find, but where are those instructions? Please send a link.

BTW I got the blinking lights a few times without messing up the device type.


(Mike Breault) #627

I actually didn’t find a link, this is just me trying different things to see what works and what doesn’t, soo far its running nicely!


(Arn B) #628

Ok good.

The next step you may want to consider is choosing between SmartHome or SmartAlarm. Should you go with SmartHome please consider using my recently released SHM Delay app.

Update Aug 21, 2017. I only recently read that support was withdrawn from SmartAlarm, and withdraw my suggestion to use SmartAlarm.


(Mike Breault) #629

and from what I was explained earlier, smarthome is the default monitoring app through smartthings? if so, ill give your delay app a try… that is a very handy idea!


(Arn B) #630

Yes SmartHome is the default.
Thank you for giving it a try. Any feedback would be appreciated.


(Brad Langhorst) #631

Question - I have 2 keypads, one of which was added a long, long time ago and one I added today. On the one I added today, the network indicator light continues flashing even though the keypad seems to work fine. On the older one, no lights are active until I approach it. I’m using mitchpond’s original DTH and his X-3400 keypad manager, though I will be switching those out Any thoughts why the indicator light might be flashing?


(Zack Cornelius) #632

The continuous flashing of the network light generally indicates that the
keypad hasn’t finished pairing properly.

I believe there was an issue with the timings from mitchpond’s original
DTH, where some keypads didn’t want to finish their pairing, but did work,
at least most of the time.

When using the DTH from this thread, pressing the tamper switch after
pairing has “completed” should cause the keypad to actually finish the
enrollment process, and stop the flashing (and probably beep at you too)


(Brad Langhorst) #633

Thanks! Everything appears to be working now. Debating whether I should stick with Mitch’s Keypad Manager or go ULM. I think I’ll install ULM and play with it a bit.


(Arn B) #634

The ULM (User Lock Manager) is deprecated. You may want to try E Thayers Lock Manager, then add my SHM Delay to get an EntryDelay


(GP) #635

i cant seem to find the latest version DTH for iris keypad (centralite) Does anyone know of this?


(Mark) #636

Pretty sure you can still use the link at the top of the thread for the github repository.


(Never Trust @bamarayne) #637

Anybody add or remove and re-add one of these lately?

If so are you on android?

Does it work?

For one reason, one of mine reset to factory. I had to re-add it now it won’t work. Acting like these did years ago when adding on android, something was broke with the android ST app and adds for these while completed were not allowing the device to work property for some reason.


(Ryan Worrell) #638

I added mine to an IRIS hub months ago to update the firmware and was never able to get them to factory reset and pair ever again.


(Jason "The Enabler" as deemed so by @Smart) #639

Take the batteries out.
Hold down either the on button or the partial button while putting the batteries back in.
It makes a crazy chiming tone thing.
Start ST discovery.
Press the on button

I’ve done this many times

For the factory reset, you might have to hold down one of the buttons above, and the tamper button in the back while putting in the batteries.


(Andrew) #640

I’m using this device handler for my Iris Centralite keypad. It all seems to work fine, except the status doesn’t update on the keypad when I arm it to partial (by that I mean the partial light will not light up, even though it does arm SHM to armed/home). I was wondering if anyone else has had this problem? It seems to show the correct state the rest of the time. I know this isn’t a huge deal, but it would be nice if it updated correctly. I have reset the keypad with the same results. I don’t have an Iris hub, so I don’t know the version of the firmware on this keypad (although, I’d be hesitant to update it given some of the experiences of others above). Thanks for the help!


(Arn B) #641

I may be able to help, but need more information.

  1. In the Lock Manager–>Iris Keypad Profile: is Act as SHM device? set to: true/on or false/off.

  2. After arming with the “Partial” button, what does it say in the My Home -->Iris Device–>recently log:
    Armed Night or Armed Stay?

  3. Disarm SHM, then in the Dashboard, tap Armed (Home). Does “Partial” light? (Act as SHM device must be true)

  4. Is the SHM Delay app or any user written Core Pistons in use for the device?


(Andrew) #642
  1. Yes, the Keypad is set on/true to act as SHM device
  2. It says Armed Night
  3. Yes, if I arm it through SHM, the partial light will light on the keypad.
  4. Yes, I’m using your app for the SHM Delay. I don’t have any pistons that affect the keypad.

Thanks for your help!