SmartThings Community

[RELEASE] Lowes Iris and XFinity CentraLite keypad DTH + Apps

dth_security
smartapp_security

(Zack Cornelius) #521

Not sure what the original firmware reported as, but my keypads (Updated via Iris) report version 0x11005310 in the IDE for the device.

As far as getting them into pairing mode, I’d say try waiting different periods between putting in the battery and releasing the tamper switch. I think the official docs say “Before the keypad lights come on”, I’ve found ~1 second normally works.

Also, make sure you’re holding the tamper hard enough. It’s not a clicky switch, so its hard to tell where it activates.

–Zack


(Ryan Worrell) #522

Gotcha. My firmwares were reporting 10025310 before I removed them so then I should be able to see the newer firmware version once I can get them repaired. I’ll try again various times holding the button. The official instructions say two seconds but the lights definitely come on sooner than that. If I recall paring them in the first place was a huge pain so this isn’t surprising. Thanks for your help!


(Zack Cornelius) #523

If I remember right, they won’t go into pairing mode with low batteries (below 50% or so). Worth a shot to try and pair them up with fresh batteries if you have a set.

–Zack


(Ryan Worrell) #524

Ah I bet that is my problem. I have some more zwave contact sensors arriving today that will come with brand new CR123 batteries I can try and use to pair. I swear I’ve tried 30+ times by now to get either one of these things to pair. What’s strange is they paired to Iris just fine but I properly removed the devices from within SmartThings so perhaps I did not remove them properly from Iris to cause them to go back into pairing mode.


(Ryan Worrell) #525

Well brand new Panasonic CR123 batteries in both and still can’t get them into pairing mode. I think I am just going to give up soon. I guess something with the firmware update or something screwed them up. :frowning:


(MacTechGenius) #526

I am hardwired!

I bought the power supply from TRC Electronics ($18 total) along with some wire from Amazon.

The power supply features an AC Input (Hot/Neutral), ground, and DC output (±). By default it outputs 3.3V but it has a small rotary for voltage adjustments, I tuned mine down to 3.2V (same as my battery).

The power supply is slightly larger than I anticipated. (Comparison with AA battery)

It was somewhat tedious getting it to fit inside, I wired the white wire to the neutral line (wire nut), and daisy chained the black wire to the hot wire on the switch. The ground cable went to the unused ground wire in the back. My light switch wasn’t connected to the ground since my box was metal. I also covered the screw terminals on the light switch with electric tape as a precautionary.
If you have a Z-Wave/Zigbee switch, this power supply will likely not fit as those are larger.
I also took this bracket out, they were two (top/bottom) took the bottom one out for more space.

Here are some more pics:

I taped the battery terminals as I didn’t want to solder.

Seems to work perfectly so far! App reports 100% battery.


[Release] SHM Delay Version 2.0
(Zen) #527

Kind of hesitate to order one from Amazon after hearing the battery drain issue I don’t expect it will come with new firmware installed but I need a keypad couple with a siren to make a more complete setup for my smartthings home


(Rob Lisska) #528

I just got mine from Amazon yesterday. I’ll try to keep an update here of how it works. I’ll also post the firmware version as soon as I link it to my hub.


(MacTechGenius) #529

Likely a hit and miss…the one I bought last year from my local Lowe’s works perfectly but the one I ordered online (from lowes.com) last month has a battery drain issue (so I plugged it in).


(Zen) #530

Thanks i will hold my impulse buy for now as i am not located in USA not easy to return if there is any problem


(Zack Cornelius) #531

Lowes seems to have discontinued them for now, at least. (Still selling the security bundle with them though).

Perhaps an indication they’re coming out with something better / newer?

The only way right now to be sure to get a keypad that doesn’t have this issue is to get one that someone has updated via an Iris hub v2.

–Zack


(Zen) #532

Hi Rob,

Just wonder if there is any good news about the iris keypad

Thanks

Ny


(Rob Lisska) #533

So far so good. It’s been about a week and it works as it should. I was even able to get entry delay beeps using Core. No battery drain yet but I know people said it can happen at anytime


(Rob Lisska) #534

IDE is reporting firmware as 10025310 which I believe is the old one. Guess I’ll just have to keep my fingers crossed.


(Zen) #535

Thanks for the info though I purchased the action tiles I may still get one


(Rob Lisska) #536

I have action tiles too but it’s a lot harder to add a secure way for arming and disarming using that.


(Zen) #537

Yes indeed although seems action tiles is adding a pin feature, I may just try my luck with Amazon then


(Daniel Pena) #538

Mine has the same firmware and the battery dropped to 60% in the first day or 2, but has held there for the last 2 months. I’ll wait and see if it drains too much I guess I’ll have to find someone with a Iris hub and update the firmware.


(George) #539

Has anyone tried the Xfinity TCH/UEI keypad? Looks like it has variable volume capabilities.



(Zack Cornelius) #540

The TCH/UEI keypad is made by a different manufacturer, so it probably won’t work with this DTH, but there’s a possibility it could work if someone were to write a DTH for it.

The Centralite keypads (both the Iris and Xfinity ones) have variable volume control as well. It’s controlled by holding the 2 key for volume up, and holding the 5 key for volume down. (See: https://support.irisbylowes.com/link/portal/30143/30206/Article/629/How-do-I-turn-the-volume-up-and-down-on-my-Next-Gen-Iris-Keypad )

–Zack