[RELEASE] Lock User Management (LUM)

I’ve just done a check for updates and the Sonos Playbase firmware is up to date. I guess this just isn’t working for me. Shame as I really wanted to use it too

For some strange reason my lock stopped locking automatically after 5 minutes. It has been working faithfully ever since I installed the lum & universal dth 3 years ago. I just updated my dth & lum is current
Have there been any issues that I have may missed?

@maddie can u help pleqse.

@all4dom having the same issues as of a few days ago. If I set LUM to re-lock immediately upon door close it works fine, but if I set a delay it never re-locks. I contacted @maddie via email, but haven’t found a resolution for it yet. I wonder if something changed on the Smartthings side of things? I looked in the event log in the IDE. I see the re-lock command being ‘scheduled’, but it never seems to execute.

Still troubleshooting. May just have to set it to lock immediately upon door close for now and hope this gets worked out eventually…

Try uninstalling the app & reinstalling. Maddie said it has something to do with Samsung platform outage other day. I called support but the girl had no clue. @Brad_ST can u help?

@RBoy @jody.albritton can you guys help? Since then last few days my door is not locking with a 5.min delay after closing. Does not even lock automatically after closing. Called support & they said it was roboys app & if I delete it I cant reinstall unless.on classic. I’m trying not to uninstall it because I have a ton of lock user codes for my daughters nurses & I have a free automations tied with the lock. Thanks.

Sounds like support is either unaware or misguided. The installation instructions link in the first post are for the new app.

I checked and re-lock is working here with a 2 minute delay on Schlage and Yale locks.

  • If you have multiple locks selected in the app, double check which door lock you’re setting the delay on.
  • If you’re seeing it schedule the re lock action in the logs and it doesn’t execute then likely the platform scheduler is dropping or not executing the command (this can happen if the platform is under heavy load or experiencing an outage)
  • If the platform is executing the command but the lock doesn’t re-lock then likely the command is being lost in the mesh.

Hi @RBoy & thanks for responding. I have a schlage lock & I have been using the new app since last year. This just happened a few days ago. Even some of my automations were acting up but they are working now. I am using the lock delay in the lum smart app & I’ll reboot my router & see if that works but my door is locking automatically after closing. Support was misguided to put it nicely.
Thanks
Dom

Folks in general are seeing issues with automations and schedules across the platform for the past few days. More reports here.

I suspect some servers (shards) are impacted more than others; some folks are seeing issues while working for others.

I hope.they get this stuff fixed soon. It’s very annoying.

Multiple times a day I have been getting notifications that say: Lock User Management has detected a code upgrade… please open the app and save. Why am I getting this? Where do I open App. I have tried in IDE. New app and classic app none stop this message.

You need to get @rboy’s updated code from his site, update your code in the IDE, and then follow the directions in that message.

@Shanapadila thats the informational message you get immediately after updating your code - and it will recur until you do it.

  • Open Smartthings
  • Tap the hamburger menu (top left)
  • Tap ‘smartapps’
  • Scroll down to Lock Multi User Code Manager
  • Hit ‘Done’ to update and save settings

Hi, i have just purchased the software and have it running on my hub, I’m using a yale lock with zigbee. Do I also need a buffering device or is that only for zwave locks?

Hi @Framedtrash, only if you’re experiencing performance or connectivity issues. If you’re able to control the lock now, you’re probably going to be fine. As you add more Zigbee devices you’ll want to consider adding a device or two that is capable of repeating Zigbee.

@RBoy still.not working after update. @jody.albritton could you please help???

RBoy,
I been using Lock User Management for 4 years without any issue but for the past 3 months LUM doesn’t work for the other user to lock the door works only for the master password any advice thank you
never mind I found the problem was code entry on off just i have to turn it back on on the app
thanks

1 Like

I have now been running the software for thr past few weeks and its been great. I have the yale yrd226 and it has a feature called privacy mode that is activated by holding down a button on the rear unit.
Wondering if this is something that could be implemented into this software? I believe most of tbe yale smart locks use this button.