[RELEASE] Lock User Management (LUM)

That isn’t the LUM SmartApp, it’s the GuestSmartLocks interface from SmartThings.
If you see the last step of the installation instructions for SmartApps it tells you how to access your installed LUM SmartApp from the Automations page in the SmartThings mobile app.

Great - ill give that a try. I was thinking I probably had the wrong app. THanks!

1 Like

Using LUM with your Enhanced Zigbee Keypad Lock handler and want to know if the door open/close actions only apply to one open/close sensor. I would like all my windows and doors to chime my Iris V2 keypad. Thanks.

I’m having trouble getting this to work. I’m using an Iris v2 with Enhanced ZigBee Keypad. I detect the keypad and the device seems to be working (it detects the tamper switch, etc.). I add LUM and under “Select Lock(s)” I see “You can’t currently add this”.

Hi, I just installed this application the other day and configured it with my Zwave Schlage Connect locks. I’ll admit, I’m new to all this, so I’m convinced I’m doing something incorrectly here.

I connected the locks initially with the default device handler and configured the SmartThings app just to make sure they would lock/unlock from the phone.

Then I updated the device handler to the Enhanced Zwave version from the site(updating via the IDE to make sure it applied to the two locks after adding it), then added the LUM. I did follow the clear codes procedure on the website. I can lock/unlock the locks from the SmartThings “Things” interface still at this point. I programmed 3 users with unique codes, all configured to access both locks. When I program them, it goes yellow at first, then goes green about 10 seconds later, indicating programming to the lock was successful.

However, the codes I’m programming are not actually working on the locks.

I did a clear codes procedure again, and reprogrammed another code for both locks and I get the same result.

I’m going to wipe everything when I get home later and try to attach the locks using the Enhanced Device Handler initially(rather than updating it per the website instructions) and I guess I can copy/paste the LUM app again(although I think it’s working correctly), but is there anything else I’m probably doing wrong?

Thanks for any suggestions.

edit - just in case it matters, the two doors are both near each other(garage and front door). The SmartThings hub is sitting maybe 10-15 feet from each door with clear line of site. I do have a ZWave repeater i can plug in closer, but I don’t think that’s the issue, as I interpreted the yellow/green measure to indicate that a confirmation was being made of the lock code provisioning. I’d assume the code is stored in the actual lock, and that the SmartThings LUM is only doing “provisioning” and notifications and any other automation, not actually doing the authenticating, that’s all inside the lock…maybe I’m wrong.

LUM app can associate one sensor with each lock, so under Door Open/Close actions, for each lock you can select a corresponding sensor and a chime which can be activated.
On popular request, we’re also working on a new SmartApp for door bell chimes and window/door sensor chimes which will allow you to use a single chime for multiple doors/windows which don’t have locks on them.

This is SmartThings way to saying that it cannot find your keypad to use. That means that your SmartApp and keypad aren’t installed in the same location. (some new/migrated ST accounts have a dummy location which is created and if you’ve accidentally installed your device or app in that location it won’t be able to interact with your real location/devices/apps)

The repeater should ideally sit between the hub and the lock so it can buffer messages. See this topic for more details: FAQ: why would I need another beaming repeater if my zwave lock is already close to my hub?
Since you’re seeing green, that’s a confirmation from the lock that it has successfully programmed the codes. Check if the keypad is disabled (i.e. vacation mode), if you’re using the Enhanced Z-Wave lock DTH you can re-enable the keypad using the Classic ST app on the lock device page. Also another very common mistake is that users accidentally install 2 or more copies of LUM (or another app like RLA) on the same lock while testing and don’t realize that they conflict with each other. One adds the code while the other deletes the code. You can verify this with the Classic ST app, open your lock device page under My Home, click on the SmartApp tab and it’ll show all SmartApps connected to the lock. There should only be one instance of LUM (or RLA) connected.

I’ve done some more digging and I think I found the problem. There’s another device handler for the keypad which is getting installed first. It has capability Lock Codes but not Lock so it’s not being found. When I get home I’ll remove the extra handler and reinstall the lock.

Sorry but I’m not understanding entirely. So the list of sensors is just to go through each and assign a chime to them, thus allowing all doors to chime, or is the app only capable at the moment of having a single sensor activate a chime?

Also I removed LUM and reinstalled LUM yesterday because of conflicts with SHM Delay’s user management and now my door open/close actions is entirely blank under General Settings. Is there anything I should do to make it come back?
Edit: Nevermind. I wiped LUM again and started over and it’s back now.

So here’s what I’m looking to ultimately do:

  1. Using your keypad DTH with Iris V2 keypad
  2. Have all doors and window sensors chime when opened
  3. Use SHM Delay to give us time to enter the home and deactivate SHM
  4. Use LUM to assign user codes
  5. Use the Off/On/Panic/Partial keys on the Iris V2 (currently, I have no custom actions for these buttons under Lock Management, so I’m assuming they will function as intended by default? SHM Delay 2.0 advises to create a 0000 Instant On account to use the ON button, but I’m not sure how its settings allows me to restrict the Instant On account to just arming and disallow disarming, which is why I’m using LUM instead for user management).

Hi @maddie & @RBoy,

What is the best way to create the equivalent of “Routines Backup” for Lock User Management?

Roughly 10% of the time, one of my locks will not respond to the re-lock command issued to it by LUM. I am guessing this is just due to simple interference/mesh related issues, as I live in a densely populated urban area with plenty of RF in the air. Regardless of the cause, it is intermittent and unpredictable, and has resulted in discovering that one of the doors has remained unlocked several hours after coming home.

I use “Open/Close Door/Window/Switch/Lock/Valve/Shade Notification and Actions when the Hub Changes Mode” to serve as a backup when I am leaving the home (i.e. going “Away”), but this does not work so well for coming home (i.e. switching to “Home” mode) because it does not have the option to specify a certain delay time (i.e. to match the 5 minute timer specified in LUM auto-relock).

What is the recommended solution for ensuring that auto-relock commands issued by LUM are re-issued until confirmed successful?


Is there anyway using WebCore to enable/disable the option in the SmartApp to Relock the Door Automatically and/or control the Relock time?

I’d like to Occasionally disable the Autolock during parties and whatnot. I can’t use the one in the DeviceHandler as my keypad doesn’t support that (Kwikset). When enabled, the one in the SmartApp works great for me.

1 Like

Hi @RBoy

We like using the auto lock on our Schlage connect. But I need to keep my door unlock for a few hours during a certain time of the day for little children. Is there a way to schedule the “AutoLock” to turn off and on? Thank You

I’m not sure if this is a bug or intended??

If I set a sensor to be assigned to the lock to re-lock immediately, it all works fine and locks the door when it is closed; after someone has unlocked the door and come in.


If you open the door from the inside to leave or visitor or delivery etc, it tries to lock the door on closing again. It is already locked as it has been opened from the inside.

Yale Connected Keyless keycode door lock

I need to be able to configure only to re-lock door on close IF lock is currently unlocked

Is the only push option to SMS?

You can check out this new app we released on popular request that does a better job of chiming devices and notifying folks when sensors are triggered:

1 Like

Excellent! Thanks!

Hi all,

I brought the rboy apps, to automate my Schlage Lock.

I have a hard time figuring out how I can go about doing this.

Here is what I want to do.

Few days a week we have a housemaid come and clean. Before she arrives she will give us a call, and usually I unlock the door for her remotely, at times she leaves the house and has to go to the other side of the yard to clean… this leaves the door unlocked. Finally, when she after she is done, she leaves and locks the doors.

However, I would like to simplify the process by…

  1. She calls us, and we can flip a switch in the ST app and change the passcode to 0000 (something easy), this is the password she would know. Thus when she gets in she can use this password, and each time she has to go around the house and yard she can lock and unlock the door using the same passcode.
  2. Usually, it takes her about 2 hrs to clean the house, I would like to automate a timer that automatically resets the passcode to the original (master passcode that we use). Say like after 3 hrs the password automatically sets back to the original passcode.

This way, we can restrict access on when and who can enter or exit.

I’d appreciate a few steps from you on how I can do this.

Not sure which Schlage lock you have, but mine supports multiple codes and I think most of them do also. With LUM you can set a separate code for your house cleaning person and select user type of Weekly / Daily Schedules to define when that code is valid and LUM will take care of adding and deleting the code for you. If your scheduling requirements are more complex than what is available with LUM, you can choose the Activate on Mode(s) user type and use a Routine, some other smart app or webCoRE to trigger the mode change per your requirements. Or you can use the Routine to manually set the mode it you prefer to control it yourself. LUM provides lots of flexibility here.



I keep getting these messages below in my Messages feed. Any idea why?

Hi there. The usually means that the lock response isn’t reaching the app so the Sure Programming Engine keeps trying until the lock responds or it times out. See the LUM FAQ page for more details.

@I_am_Root, to add onto what @mikesas said, one more way is to create a Virtual Presence Sensor device which can be manually toggled on / off. Set the user type to Activate on user presence and select the virtual presence sensor in “…if any of these people are present”. Now you can toggle the presence sensor to enable/disable the user on demand.