[RELEASE] Lock User Management (LUM)

I noticed yesterday my batteries were down to 1%. They seemed to have drain very fast all of the sudden. Today is was not locking and unlocking & it was unresponsive from the app. I did a zwave repair and i.noticed it said failed to repair lock, lights & mesh. Now it seems like its qo3king but slow? Has samsung doing updates that we are unaware of? It seems like my whole zwave network is buggy.

Hoping someone can help. My schlage lock is not responding to any commands & does not lock automatically anymore. Had an issue with batteries a few days ago & I replaced them. Am I correct that I need to exclude the lock from zwave & repaor?

@RBoy can you help me please?

. I have 4 of these locks. try removing it then send the zwave exclude command which should reset it. then reconnect. When reconnecting it has to be close to the hub. I remove mine from the door and bring it to the hub to include it or the key excange will fail.

1 Like

Looks like he figured it out, apparently his apps and DTH’s had disappeared after he re-paired the lock. Maybe he can clarify if was an IDE issue or something else:

For some strange reason the lock unpaired. I repaired it but it still didnt work. After trying a few times I googled searched because smartthings search is not as detailed. I had to reset it & repair it & everything came back. Reason why I posted help was because I have night nurses for my daughter & I was afraid of royally screwing things up.

1 Like

I installed the Device Handler, then I installed the LUM app. I must have done something wrong, because it did not erase any of my existing codes. When I add a new user with a new code, the code is not opening the lock.

I’m not sure how to get it to accept new codes.

I just noticed I received a text alert:
Retry programming exceeded. user 3 (Name) addition not confirmed by lock

What am I doing wrong How do I get the lock to confirm the programming?

You aren’t doing anything wrong, your lock is having trouble with the mesh. Assuming your battery is good, see this:
FAQ: why would I need another beaming repeater if my zwave lock is already close to my hub?


@RBoy This is a really great SmartApp. Thanks for putting all that effort in!


Are you going to make updates to support the new Schlage Connect Z-Wave Plus locks?

Has anyone ever had an issue with their Schlage Connect locks that won’t allow you to add custom user codes? These locks have always worked perfectly for me until recently. I tried a full factory reset on the locks and completely defaulting out the smartapp (removed all users etc). I re-added everything and it still doesn’t work. This is the error I’m seeing in the app. Any ideas? I have the latest device handler and smart app installed and i also renamed the device handler to “Z-Wave Lock” as suggested.

I went out and purchased 1 repeater and placed it within 10 feet of the door and was still having issues. Then I went out and purchased a second one and put it on the other side of the door, also within 10 feet.

The repeaters I purchased are: https://www.amazon.com/GE-Weather-Resistant-Required-Works-SmartThings-14284/dp/B06W9NWFM3

The issue is, after I program lock codes, I wait about 30 minutes and try and the codes all work. But then within 24 hours, the codes stop working. Then I add them back in, and they work again for some small period of time, but then stops working again.

Also, in the app, it appears that the users are sometimes green, sometimes yellow.

The users are color coded to show their current state:

  • Green means the user is active (confirmed by the lock)

  • Grey means the user is inactive/deleted (confirmed by the lock)

  • Yellow means the programming request has been sent and the app is awaiting confirmation from the lock

  • Red means the lock is not responding to programming requests and may indicate problems with the lock/mesh

If you’re seeing yellow users after a few minutes (you need to save/re-open the app for to see status updates) that means your lock is having trouble with the mesh because the app isn’t getting a confirmation from the lock that the user programming was completed successfully. The app will retry a couple of times before finally giving up and will mark it as red and notify you as you’ve seen above. For some users factory resetting the lock and excluding/re-pairing helps the lock overcome mesh issues (in addition to adding the repeater).

If you’re seeing this happen with users that are of type “Permanent”, then it means that you have another app which is interfering with your lock and deleting the codes. Often folks accidentally install two or more instances of LUM and don’t realize that they will conflict with each other (one adds while the other deletes).

1 Like

Thanks for the quick reply. I will try factory resetting the lock. and uninstalling the app and re-install.

Using a Kwikset 910. I no longer get notifications of locking/unlocking. I am using both the DTH and Smartapp. I can still lock/unlock, ST app shows correct status. But I can’t get any push or SMS notifications. I used to get them ok. I also tried setting a audio notification device, no luck there either.

I checked for the latest versions of the apps and am up to date.

1 Like

I am already using the latest DTH. It shows version 04.03.05. The smartapp shows version 07.08.10.

I can control the lock from the ST app no problems. All the activity shows up in the recents tab. ST app notification settings are fine as I get notifications for other things in ST.

I am not getting the SMS notification either. I also tried an audio device that I have and nothing comes in on it either.

I changed to the stock DTH, no help.

I looked at the log in the IDE and it is showing the events. I just don’t get the notifications.

Here are some log entries if that helps any:
No individual routine configured to run when locked electronically for Door Lock

44cdb502-9cec-4182-80cc-27da7246c204 9:41:31 AM: trace Lock Door Lock locked manually, Source type: electronically

44cdb502-9cec-4182-80cc-27da7246c204 9:41:31 AM: trace Processing Door Lock lock actions: [name:lock, value:locked, displayName:Door Lock, descriptionText:Door Lock lock is locked, data:[microDeviceTile:[backgroundColor:#00A0DC, icon:st.locks.lock.locked, type:standard]], lockId:940da588-719c-4ef8-a0b3-d2e6ee282287, lockMode:electronically]

It looks like LUM is receiving and processing the event. Check if you’ve enabled the option for Notify on Manual Lock at the bottom of the Lock/Unlock Actions -> Manual Lock page. If it’s enabled and the notifications still aren’t reaching you then the app may be corrupted and you may need to reinstall it.