[RELEASE] Lock User Management (LUM)

Notifications are no longer showing ‘who’ unlocked door. Now it just say door was unlocked electronically. I’m using Prior version rather than version released hours ago. Also using universal (rboy) device handler. Logs do show user 1, user 2 in activity on the mobile app. Just not verbose notifications. Any ideas?

When you say no longer working, assuming it was working. Did you change any settings? Did you disable verbose notifications on the first page?

There is no new version released hours ago. the last version released was about a month ago (it’s pretty stable, mostly just new features).

Ever since the latest update some messages have been shortened. See the below thread as an examp,e, but I experienced it too:

Yes Verbose unlock notification used to work, Now it only says “Unlocked electronically” . I turned on the get detailed notification in the bottom settings of the first page. I got a bunch of programming messages for the lock. Still can’t figure out to get this to work. General setting Notifications for users setting, all setting are on but ‘notify on keypad lock’ there is NO setting for Notify on keypad unlock’ Maybe this is just mislabeled is it might do both?

It’s working fine here, on all three of our test hubs. There are no special settings, it just sends the entire message via push and to the notifications feed. If you’re seeing the full message in the notification feed but not on the push message it could be what @ritchierich pointed out in the post above.

The solution posted above was to delete your ST Mobile app and reinstall it and if that doesn’t work for you maybe ST support may need a be involved as to why your mobile app has started shortening notifications.

need help :slight_smile: I have my 910 on your universal zwave DTH, but when I go to use this smart app I get this error after hitting create, any help to get me going would be much apperciated!!!

No signature of method: script1504542398807162410191.metadata() is applicable for argument types: (script1504542398807162410191$_run_closure1) values: [script1504542398807162410191$_run_closure1@252c3e80] Possible solutions: getMetadata(), getState(), setState(java.lang.Object), metaClass(groovy.lang.Closure)

You’re using the wrong installation instructions. SmartApps and Device Handler have different installation instructions. The Universal DTH is a Device Handler, Door Lock Code Management is a SmartApp. You can find detailed step by step instructions on our website for each type.

I just purchased the one year and am using some of the apps, does that mean after a year the apps will not work?

No, It means you wont get access to the code.

2 Likes

Can you change the PinLength remotely?

No. Changing the pin length clears all codes from the lock and hence is recommended that users do it manually. This should ideally be done only when the lock is installed or reconfigured.

I need a little help. I have the Yale z-wave touchpad lock. I have 4 users set up, myself first. In the log I see it warn that the first user is duplicate, and then that the first user is not getting set. I guess this makes sense as I am the master user. Can/should I ignore this error? Seems like it’s constantly trying to set this user and failing. Note that I removed the lock from ST, did a full factory reset, and then re-added it. Still having the same messages.

6444ef5a-7303-49c8-b5f4-9107239f0bfd  11:57:53 PM: debug code report parsed to [['name':'codeReport', 'value':1, 'data':['code':''], 'descriptionText':Front Door Lock code 1 is not set, 'displayed':true, 'isStateChange':true, 'linkText':'Front Door Lock']]

6444ef5a-7303-49c8-b5f4-9107239f0bfd 11:57:44 PM: debug "zw device: 24, command: 9881, payload: 00 71 05 71 01 " parsed to [‘descriptionText’:Front Door Lock code 1 is duplicate, ‘isStateChange’:false, ‘displayed’:false, ‘linkText’:‘Front Door Lock’]

You should not ignore duplicate user code warnings as the programming will
fail (locks do not accept duplicate codes, each has to be unique).

Run the clear codes procedure on our webiste to reset the lock and ensure
that your lock is no further than 15-20ft from the nearest z wave repeater
and you should have no problems with the programming.

Actually, thinking about it on the way to work this morning, I figured it out. My own user code was the same as the master code, that’s why it was complaining it was a duplicate. Makes sense since the master code can be used to open the door as well. All the codes need to be unique to be able to report the correct user when a code is entered. Duh. Made the codes different and now all is well.

1 Like

I need a little help, I am a little bit confused. I have the schlage fe599. After setting the lock code with setCode function. I can see at the codeReport that the code was set. I will like to know if there is a function to get the current code of the lock?

Ok still can’t recieve notification with user lock app. Re-installed, however I noticed this setting, disable all push notifications under it says "play notifications on theses devices, you can’t currently add this.
Could that be anything?

No, Schlage locks (and many others) do not read back programmed codes for security reasons. I think your question may be directed to the Universal Z-Wave Lock Device Handler thread.

That’s only for folks who have the Contact Address Book Feature enabled on their SmartThings accounts (you can search the forum for more details on how to enable this feature). Are you sure you’ve got notifications enabled for your ST mobile app on your phone.

Everything is on, pushed notifications and notification in the app are
one, but they are both still very basic. "Door unlocked/locked
electronically.) Went into the smartapp where the notifications are set per
user-code they are all set correctly. Still cannot get user X unlocked
door. This is a Schlage and I’m using RBOY device controller. Still
nada. Any logs I can look into?

If it was working earlier then suddenly stopped I suspect you accidentally installed another instance and it got mixed up. You should review your hub and IDE setup.