[RELEASE] Lock User Management (LUM)

Hello! – I’m a new user. Have setup the App & Z-Wave device handler. Have a question about managing user codes. I set up a user code and selected “notify me”; did not qualify which modes – so that it runs all the time; inputted the code but did not receive a text.

Also, wanted to check – does the notify if multiple invalid codes work by default? Did not see any settings to configure so wanted to confirm if that’s how it works.

Much thanks for this great utility!

1 Like

Yes, it will notify you automatically when the lock sends the message (note different locks behave differently).

As for the notification, it depends on how you’re configured it. Are you entering a sms number for text messages or do you have the contact address book feature where you can select multiple contacts. If it’s the latter make sure the sms numbers are assigned to each user in your address book and verified otherwise you won’t get the message. Push notifications are more reliable than text messages.

If you still want to use SMS with contact address book here is how you should configure it:

  1. Using your ST mobile app, under More, click on Contact Book
  2. Select your name (or add one by clicking on +)
  3. Click on the gear icon (this is required EVEN if you already have a phone number since the format has changed recently and you need to re enter it)
  4. Make sure you have entered your eMail address that is registered with your ST presence sensor/account (without this SMS/Push notifications may not work)
  5. Add a new number, select Mobile as the label
  6. Click on Country and select USA/Canada (or whatever country you want) and then click on Edit Contact to go back
  7. Enter your mobile number in the next field where is asks for your number
  8. Click Done

This will take your back to the previous page.

NOTE: Due to a bug in the contact address book you won’t see the number you entered but some digit(s) may be missing. For examples if you selected USA and entered the number 6785555555, when you click Done you’ll see 85555555. If you edit the contact again it will show the country as Antigua and the number as 85555555. That’s the bug, don’t worry about it, test it out and it should be working fine, you should receive SMS’s. You can always email ST support and request them to fix the contact address book, it’s just not at the top of the priority right now.

I just switched one of my locks over from lock manager to this smart app and was wondering do i need to change the device type from Z wave reporting back to ether Z wave lock or Z wave lock with keypad?

You should use either the stock ST device handler or if you want access to
the advanced lock features I would recommend the Universal Z-Wave Lock
Device Handler

Hey @RBoy, by chance did you patch the behavior of the Schlage BE469 locks where when you lock it from the outside by pushing the Schlage logo, that the logs report that <“Lock Name”> was locked by Master Code via keypad?

I just updated to 05.08.00, but I didn’t see anything in the release notes and wanted to see if this was something that you were still planning on changing.

Thanks!

1 Like

Yes it was patch up but we didn’t make the release as we got busy adding more features. The issue isn’t with the SmartApp but was with the device handler. We will make the release this week along with a bunch of new features and support for additional locks. Thanks for the follow up. Keep an eye on the Universal Z-Wave Lock device handler page.

1 Like

Hey sorry to bother you on here, new to ST. I’m just wondering if you can tell me if you’re code will work for what I need.

I will have a schlage connect lock, and need to be able to assign user codes, assign names to those codes, and then be able to view detailed activity logs that will show me who, when, and what. I understand notifications can be sent with this info, but I’d like to be able to just pull up an app on my iPhone and view the current log info. If your code can do that, or you can implement any of the things I’ve listed that it can’t yet, I’ll be signing up for your lifetime subscription as soon as my lock arrives!

1 Like

Yes, it supports all the features and lots more
The “logs” are saved in the Notifications page from the SmartApps and Device “logs” can be found in the event or device activity pages. ST does not allow downloading anything as of now. However you can configure the app to send you SMS’s which you can store.

2 Likes

I’d be interested in this as well. I was never able to figure out how to run pistons with webcore based on locking the door manually from the outside. I also have a BE469. I ended up doing a work around using virtual switches, and then using the smart app to turn them on and off, then using those actions to trigger pistons, but I’d rather not have to worry about the virtual switches.

@RBoy I got your lock code user management installed. Before I start using it…

I have a Schlage BE469 with 5 users. Works fine with the Smartthing market app. I want more granularity hence why I decided to support your development and go for your app :smiley:

My question is… Do I have to reset to factory default my lock before I use your app? Or just clear all users and codes?
Is there a step by step on how to setup for the first time your app?

Thanks for your help!

1 Like

Thank you for your support. No need for a reset, just clearing the codes is enough. The “Clear Codes” procedure, step by step is given on our website. Apart from that there should be no manual required, it is designed to be simple and intuitive. If you do find you get stuck please let us know so we can look into the design to see how we can improve it better.

“Any product that needs a manual to work is broken” -Elon Musk

1 Like

Awesome. Thanks. Will give it a try.
Excuse my ignorance as I am new to this whole IDE and custom apps thing :stuck_out_tongue:

One more question. Do I need your device handler?

Universal Enhanced Z-Wave Lock with Alarm, Notification, RFID, Door Sensor and Advanced Features

It isn’t mandatory, all your basic functionality will work fine with the stock ST device handler but we do recommend it as it opens up many advanced features for the device and app to use like lock based codes, jammed locks, invalid code notifications, autolock features etc.

1 Like

My Schlage 469 keeps saying it’s jammed but it doesn’t seem hindered in any way. Any advice? I’m using your DTH, btw, so I’m holding out hope…:slight_smile: Thx!

Nothing to do with the DTH, it to do with how the lock is installed and operated. That message is being sent by the lock. Either the lock is being opened/closed too slowly or your deadbolt isn’t perfectly aligned with the door frame and is scraping it (and yes it does tend to lose alignment over time when doors are slammed etc), try adjusting your mounting of the lock and alignment to the door frame. The lock is very sensitive to resistance and speed. See this post:

@RBoy all went well except that is stuck with “user 4 is not set” and it repeats for user 5.
1 2 and 3 add it just fine.

Any ideas?

@RBoy, are there any plans to support an iCal link for automatically updating codes?

The following project did the iCal integration, but it does not seem compatible with the Rboy Door Lock.
The code is doing a pull a day on the iCal calendar, and if an entry is found for the day, it uses the last 4 of the phone number as door code. Maybe you could add something like that to your Door Lock app?
Very useful for AirBnB hosts

@RBoy I just did a test and it looks like the code is there but is reporting it as “unknown user”… Any ideas? :slight_smile:
Thanks again!

Edit: Seems to be a problem with the last slot. I had it set to 5 and it never took the code of the last user… It keep clearing out in the app and the app keep coming up with an error along the lines error refreshing page" every time.

So I add it another slot and that did the trick to add all of my home users… It still complains in the logs about it but at least my users work…

I keep seen this: 7:06:54 PM: debug Front Door Deadbolt Guest user 6 already deleted

Did you run the Clear Codes procedure, if not do that. It’s best to start on a clean slate. Also this tends to indicate a problem with the Z-Waves mesh. Make sure that you lock is no further than 10-15 ft from the nearest Z-Wave repeater. Anytime more and it tends to overload the mesh and lock communication which causes issues like this. Best practices includes:

  1. Reboot hub
  2. Repair Z-Wave network
  3. Ensure that the lock is no further than 10-15ft from a Z-Wave repeaters/active device

Yes, this is already in the works. If you want to be a beta tester please email us.

3 Likes