[RELEASE] Lock User Management (LUM)

Are you sure you’re using this app? If so it’ on the second page where you enter the user names and codes. Each user has an option to define custom actions.

Under keypad info?

I don’t think you’re using this app. Please see the first post.

User lock manager smart app from your server right? I am using it from what I can tell

This is all I’m seeing is this not the app?

Again you’ve got the wrong app. Please see the first post on how to get
access to our app. Our app is called Lock Multi User Code Management and
has all of the features you’re asking about.

wrong info - deleted by me

Sorry if this has been asked before, but I couldn’t find any related replies. Is there a way to enable/disable the autolock feature for a specific user? I currently have autolock enabled, and I would like to turn this off for one user only.

I used to get confirmations about a user being deleted or a code being added…but no longer. I try to add codes, it sends a request the the lock, I never get a confirmation, and the code never gets added to the lock. Any ideas on how to fix this?

Hi - just installed the Smart App and DH - when I view the Schlage lock device I see the current state, battery level, and “buttons” for lock and unlock. Are there any other options I should be seeing?

Thanks

Here’s a screenshot of what I see when I view my Schlage lock. If I recall correctly, I didn’t see all the buttons when I first installed the Smart App and DH. I think it took a little time for them to appear, or maybe I changed a setting.

1 Like

If you don’t see a confirmation that means the lock is having issues communicating with the hub. It would also explain why the code never gets added (because there is no confirmation). Repair the z wave network or try to exclude and re pair your lock.

Unfortunately I’m having connectivity issues as well. My door lock is literally 5 ft by my smartthings hub. I can’t get it to remember to auto lock door, I came home Thursday and my codes were all deleted, its been acting really odd. I’ve tried removing the schlage door lock, but it seems to be a persistent thing. It worked flawlessly until Thursday.

Did you hub get a firmware upgrade? If it suddenly started Thursday it’s likely the network or hub changed something. Try this. Reboot the hub, exclude your lock pair it again. Then do a network repair from your hub utilities. Then reinstall your SmartApp. Don’t forget to use the clear codes procedure before programming your codes.

One thing to check do you have active repeaters around? Very unlikely but a bad repeater could also mess up the network.

I didn’t get a firmware update that I’m aware of.
Firmware Version: 000.016.00014
I rebooted the hub
When you say exclude, do you mean remove and re-add? I did try this
I did a network repair
I deleted the smartapp and re-added it
I don’t know how to clear the codes- so I skipped this (tried to google it)

So the auto lock worked right after I installed the smartapp and set preferences. Then, my wife left and the door was still unlocked when she shut the door. I just attempted to open the door and see if it would auto lock and it did. I then did it again and it didn’t auto lock.

It seems to be an intermittent issue and I’m completely stumped. I think the user codes are working correctly. I’ll find out tomorrow, we’re remodeling our house so I have a construction guy coming and I gave him a temp code.

Hopefully we can get this auto lock feature to work like it did before Thursday. I really enjoy your Apps RBoy- thanks for all the help and keep it up- I’ll continue to support your work!

The code clearing steps are given on our website next to the SmartApp description but anyways that isn’t the issue from what you’re describing.

This is a typical symptom of a z-wave network issue. Either you have a Z-wave device that is interfering with your network or your mesh is weak and you may need additional active devices, if you don’t have any active devices around the house, I would start by adding a few. If you have try turning them off one by one (the active ones, driven by line voltage) till you find the issue.

I have a lot of devices… I never bought a specific repeater like you mentioned in your previous post… I’ll try removing some and see what happens… Last item I installed was a gocontrol zwave dimmable light… I’ll start with that.

These days almost every zwave/plus device that is powered by line voltage acts like a repeater.

I have a situation where I have two Schlage Connect locks #1 and #2. I setup this @RBoy smartapp whenever a legitimate code is entered in lock#1 to disarm the SHM and also run a routine I’m Back! This routine also will unlock Lock#2 with the idea being if I get home to an ARMED system my lock keypad acts not only to disarm but also unlock the second door so I don’t have to.

The problem is entering a valid code doesn’t seem to be running the I’M Back routine nor disarming the SHM? I can trigger the routine from the ST app fine so I know the routine works if it could only get triggered. What is going on with the routine not triggering when I unlock? What am I doing wrong?

This is what all that is being reported during Live Logging on my valid code entry
7:26:28 PM: debug Lock Frnt Stl Door Lock unlocked by Dale, notify true, notify modes null, via keypad

I don’t think you may be doing anything wrong, just ensure that you’ve selected in the actions to run the routine and disarm SHM. It may be ST timing out. SHM often times out or doesn’t always register the event notification in a timely manner, it’s better to run a routine and disarm the SHM through the routines instead of doing it through the app. If there’s an error it should show up in IDE Live Logging, otherwise it’s probably the platform running slow/timing out. Do you have many actions in your routines? Too heavy routines also tend to timeout.

Ill take a look, If the routines are “too heavy” you would think doing it manually would also be an issue, right? Manually it works, but through the smartapp , no. So you want me to trigger everything I want in the routine when possible not the smartapp?

update:
The I’m Back Routine
Turn Off 1 light
Set SHM to Disarmed
Unlock these doors set to Frnt Door Lock
Change the mode to Home