[RELEASE] Lock User Management (LUM)

It looks like ST is polling your device which is normal. Nothing to do with the app. Battery depleting can be caused from bad batteries to lock issues. I have a lock which for no apparently reason drops 4x faster than an identical lock. Chalked it up to a bad piece.

2 Likes

Thanks for the help via email in regards to this!

1 Like

@RBoy and others, is anyone being successful at auto lock for a period longer than 30 min? For some reasons my locks don’t autlock after 30 or 60 min but have no problems for 5 min.

I would open “My Locations”, find your SmartApp and look at the scheduling history to see if the routine executed. That will tell whether ST’s new Ticker dropped the schedule or if your lock had an issue communicating with the hub.

1 Like

I did look and it schedules it ok, but then an hour pases and when I go back to look why it didn’t lock, there is no record of the schedule. That’s how I ended up trying for 5 min and that worked ok.

Ok, I see what it does. It reschedules every time the contact opens. So door unlocks, it schedules out an hour. Then someone else goes out within an hour it reschedules for another hour. And then maybe 3 hours later, someone else locks the door and the schedule is canceled. Makes sense. I do need shorter periods in this case.

1 Like

Hi,

I recently implemented the device handler and smartapp on my kiwkset 916 and happy to say everything seems to be working awesome!

But when i checked the live logging I got the following message a couple times:

“warn Unknown device with MSR 0090-0001-0001, report it to developer” is this an issue?

  1. That message is from the DH, nothing to do with the SmartApp
  2. That’s normal, Kiwkset is a particularly cost efficient lock (Schlage and Yale are more comprehensive) that supports only reading some parameters, so when it tries to write to it, it says unsupported.

Thanks!

I also ran one more test where I pulled the battery out of my kwikset 916 to see what would happen upon replacing the battery. It seems that I had to re-initialize all the passwords I had for that lock. After about 15 minutes it looks like all the passwords work again, but I am no longer getting push notifications upon unlock even though every password has push notification upon unlock activated…

I noticed that it took a few minutes for the passwords in general to work again after a battery replacement, but I was curious if push notifications are activated on a different process or could take longer than it takes to activate all the passwords again.

No push notifications is a platform or phone issue. There is no configuration for it apart from enabling it in the app (double check it). Are you getting notifications from other apps on your phone?

1 Like

Yup getting it, actually after a day or so I started getting the push notifications again. Thanks!

1 Like

Does this app support notifications for invalid code entry? Not seeing an option for it but I could be missing it?

The other way around. If your DH supports the invalid attribute the app will show the option to configure it.

Doesn’t the BE469 support this? I thought it was one of the more featured locks. Maybe not :stuck_out_tongue:

Yes but the standard DH doesn’t support it. You’ll have to my DH to enable this capability

I am using your DH

I thought this is a function of the Alarm mode app when used in conjunction with the aforementioned DTH?

The alarm mode app with change the alarm state of the lock if supported by the lock (eg BE469)
This app will report invalid codes when reported by the lock though the DH

I would be all about that and more than happy to donate/pay for such an app. We run a rental property that has SmartThings for home automation, Sonos for sound, Nest for temp and I’m shopping for the smartlock solution now.

Having some doors that are separate and only for owners/cleaners and then the access doors that get automatic keys for renters on Airbnb + Homeaway + VRBO would be perfect.

Even an SDK I could drop into my own app would be fine.

Thank you!

1 Like

I’m having some issues with this - it is now re-adding each lock code every 60s. I’m not talking about the cloud check -it’s actually talking to the door lock every 60s - cant be good for battery